* Updated luaposix Makefile (prepare for merge to OpenWRT)
authorSteven Barth <steven@midlink.org>
Fri, 23 May 2008 20:55:59 +0000 (20:55 +0000)
committerSteven Barth <steven@midlink.org>
Fri, 23 May 2008 20:55:59 +0000 (20:55 +0000)
contrib/package/luaposix/Makefile

index 09a6379..9f28713 100644 (file)
@@ -14,12 +14,12 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 include $(INCLUDE_DIR)/package.mk
 
 define Package/luaposix
 include $(INCLUDE_DIR)/package.mk
 
 define Package/luaposix
-  SECTION:=lib
-  CATEGORY:=Libraries
-  TITLE:=Lua Posix library
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=LUA
+  TITLE:=Posix library for Lua
   URL:=http://luaforge.net/projects/luaposix/
   DEPENDS:=+liblua
   URL:=http://luaforge.net/projects/luaposix/
   DEPENDS:=+liblua
-  MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
@@ -33,12 +33,12 @@ define Build/Compile
                RANLIB="$(TARGET_CROSS)ranlib" \
                INSTALL_ROOT=/usr \
                LUAINC=$(STAGING_DIR)/usr/include
                RANLIB="$(TARGET_CROSS)ranlib" \
                INSTALL_ROOT=/usr \
                LUAINC=$(STAGING_DIR)/usr/include
+       $(STRIP) $(PKG_BUILD_DIR)/posix.so
 endef
 
 define Package/luaposix/install                
        $(INSTALL_DIR) $(1)/usr/lib/lua
 endef
 
 define Package/luaposix/install                
        $(INSTALL_DIR) $(1)/usr/lib/lua
-       $(STRIP) $(PKG_BUILD_DIR)/posix.so
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/posix.so $(1)/usr/lib/lua
+       $(CP) $(PKG_BUILD_DIR)/posix.so $(1)/usr/lib/lua
 endef
 
 $(eval $(call BuildPackage,luaposix))
 endef
 
 $(eval $(call BuildPackage,luaposix))