libs/core: fixes for network model
[project/luci.git] / libs / core / Makefile
index 8a30256..f7fac77 100644 (file)
@@ -1,12 +1,2 @@
 include ../../build/config.mk
 include ../../build/module.mk
-
-%.o: %.c
-       $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
-
-compile: src/luci_cutil.o
-       mkdir -p dist$(LUCI_LIBRARYDIR)
-       $(LINK) $(SHLIB_FLAGS) -o dist$(LUCI_LIBRARYDIR)/cutil.so src/luci_cutil.o
-
-clean: luaclean
-       rm -f src/*.o