contrib: make remove dependency to custom olsrd
[project/luci.git] / contrib / uci / Makefile
index cf3020f..b0ea8c0 100644 (file)
@@ -1,22 +1,32 @@
 include ../../build/config.mk
 include ../../build/gccconfig.mk
 
-UCI_VERSION = 0.4.5
-UCI_SITE = http://mirror2.openwrt.org/sources
-UCI_DIR = uci-$(UCI_VERSION)
-UCI_FILE = $(UCI_DIR).tar.gz
-UCI_URL = $(UCI_SITE)/$(UCI_FILE)
+UCI_VERSION  = 0.8.0
+#UCI_SITE    = http://mirror2.openwrt.org/sources
+#UCI_DIR     = uci-$(UCI_VERSION)
+#UCI_FILE    = $(UCI_DIR).tar.gz
+#UCI_URL     = $(UCI_SITE)/$(UCI_FILE)
+UCI_GITREV   = aa3ab8012bfbf793d2884c08ea924545a04e9544
+UCI_SITE     = http://nbd.name
+UCI_DIR      = uci.git
+UCI_FILE     = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
+UCI_URL      = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=$(UCI_GITREV)
+UCI_PATCHDIR = patches
 
 all: compile
 
 include ../../build/module.mk
 
 $(UCI_FILE):
-       wget -O $@ $(UCI_URL) || rm -f $@
+       wget -O $@ "$(UCI_URL)" || rm -f $@
 
 $(UCI_DIR)/.prepared: $(UCI_FILE)
        rm -rf $(UCI_DIR)
        tar xvfz $(UCI_FILE)
+       (cd $(UCI_PATCHDIR); ls *.patch | sort > series) || true
+       [ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
+               patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
+       done < $(UCI_PATCHDIR)/series || true
        touch $@
 
 compile: $(UCI_DIR)/.prepared
@@ -26,7 +36,6 @@ compile: $(UCI_DIR)/.prepared
        $(MAKE) -C $(UCI_DIR)/lua CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
        $(MAKE) -C $(UCI_DIR)/lua install DESTDIR=../../dist luadir=$(LUA_LIBRARYDIR)
 
-
 compile-all: compile
 
 clean: