* luci/applications: force success for postinstall scripts
[project/luci.git] / contrib / uci / Makefile
index 1363b78..8e35420 100644 (file)
@@ -1,13 +1,12 @@
 include ../../build/config.mk
 include ../../build/gccconfig.mk
 
-UCI_VERSION  = 0.6.0
-UCI_APPEND   = +luci1
+UCI_VERSION  = 0.6.3
 #UCI_SITE    = http://mirror2.openwrt.org/sources
 #UCI_DIR     = uci-$(UCI_VERSION)
 #UCI_FILE    = $(UCI_DIR).tar.gz
 #UCI_URL     = $(UCI_SITE)/$(UCI_FILE)
-UCI_GITREV   = 12c5b22102873e303e540f886489831461d54ea9
+UCI_GITREV   = c79cc497e7b0caa0f9f6a2c978fa9a5f0f097463
 UCI_SITE     = http://nbd.name
 UCI_DIR      = uci.git
 UCI_FILE     = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
@@ -27,33 +26,14 @@ $(UCI_PATCHDIR)/series:
 $(UCI_DIR)/.prepared: $(UCI_FILE)
        rm -rf $(UCI_DIR)
        tar xvfz $(UCI_FILE)
-       ln -s ../$(UCI_PATCHDIR) $(UCI_DIR)/patches
        touch $@
 
-$(UCI_DIR)/.patched: $(UCI_DIR)/.prepared $(UCI_PATCHDIR)/series
-       (cd $(UCI_DIR); \
-               if [ -x "$$(which quilt 2>/dev/null)" ]; then \
-                       quilt push -a; \
-               else \
-                       cat patches/*.patch | patch -p1; \
-               fi; \
-       )
-       touch $@
-
-refresh: $(UCI_DIR)/.patched
-       (cd $(UCI_DIR); \
-               for i in $$(quilt series); do \
-                       quilt refresh $$i; \
-               done; \
-       )
-
-compile: $(UCI_DIR)/.patched
+compile: $(UCI_DIR)/.prepared
        $(MAKE) -C $(UCI_DIR) CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
        mkdir -p dist/usr/lib dist/usr/bin
        $(MAKE) -C $(UCI_DIR) install DESTDIR=../dist prefix=/usr
        $(MAKE) -C $(UCI_DIR)/lua CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
        $(MAKE) -C $(UCI_DIR)/lua install DESTDIR=../../dist luadir=$(LUA_LIBRARYDIR)
-       mv dist$(LUA_LIBRARYDIR)/uci.so dist$(LUA_LIBRARYDIR)/uci2.so
 
 compile-all: compile