Overall CBI-UVL ineraction fixes
[project/luci.git] / contrib / uci / Makefile
index cf3020f..31551af 100644 (file)
@@ -1,18 +1,27 @@
 include ../../build/config.mk
 include ../../build/gccconfig.mk
 
-UCI_VERSION = 0.4.5
-UCI_SITE = http://mirror2.openwrt.org/sources
-UCI_DIR = uci-$(UCI_VERSION)
-UCI_FILE = $(UCI_DIR).tar.gz
-UCI_URL = $(UCI_SITE)/$(UCI_FILE)
+UCI_VERSION  = 0.6.1
+UCI_SITE    = http://mirror2.openwrt.org/sources
+UCI_DIR     = uci-$(UCI_VERSION)
+UCI_FILE    = $(UCI_DIR).tar.gz
+UCI_URL     = $(UCI_SITE)/$(UCI_FILE)
+#UCI_GITREV   = 43124956bc9c1083e476f6cadaedf27b7788d004
+#UCI_SITE     = http://nbd.name
+#UCI_DIR      = uci.git
+#UCI_FILE     = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
+#UCI_URL      = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=$(UCI_GITREV)
+UCI_PATCHDIR = patches
 
 all: compile
 
 include ../../build/module.mk
 
 $(UCI_FILE):
-       wget -O $@ $(UCI_URL) || rm -f $@
+       wget -O $@ "$(UCI_URL)" || rm -f $@
+
+$(UCI_PATCHDIR)/series:
+       (cd $(UCI_PATCHDIR); ls *.patch | sort > series)
 
 $(UCI_DIR)/.prepared: $(UCI_FILE)
        rm -rf $(UCI_DIR)
@@ -26,7 +35,6 @@ compile: $(UCI_DIR)/.prepared
        $(MAKE) -C $(UCI_DIR)/lua CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
        $(MAKE) -C $(UCI_DIR)/lua install DESTDIR=../../dist luadir=$(LUA_LIBRARYDIR)
 
-
 compile-all: compile
 
 clean: