modules/admin-full: only render ipv6 options if ipv6 is available
[project/luci.git] / contrib / package / sysupgrade-atheros / Makefile
index 6b52ee1..e4414b1 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sysupgrade-atheros
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -17,8 +17,8 @@ define Package/sysupgrade-atheros
   SECTION:=luci
   CATEGORY:=LuCI
   SUBMENU:=Freifunk
-  TITLE:=Experimental sysupgrade support for Atheros SoC
-  DEPENDS:=+base-files
+  TITLE:=Experimental sysupgrade support for Atheros SoC and AR71xx target (UBNT RS)
+  DEPENDS:=@TARGET_atheros||@TARGET_ar71xx
 endef
 
 define Package/sysupgrade-atheros/description
@@ -40,10 +40,8 @@ endef
 define Package/sysupgrade-atheros/postinst
 #!/bin/sh
 [ -n "$${IPKG_INSTROOT}" ] || {
-  if ! grep -q /etc/firewall.freifunk /etc/config/firewall; then
-    uci add firewall include >/dev/null
-    uci set firewall.@include[-1].path=/etc/firewall.freifunk
-    uci commit firewall
+  if [ -f /lib/upgrade/kill-ffwatchd.sh ]; then
+    rm -f /lib/upgrade/kill-ffwatchd.sh
   fi
 }
 endef