contrib: remove luci-light collection, throw out admin-mini of default collection...
[project/luci.git] / contrib / package / luci / Makefile
index b30caca..f8bb81e 100644 (file)
@@ -9,6 +9,8 @@ endif
 PKG_NAME:=luci
 PKG_RELEASE:=1
 
+PKG_BUILD_PARALLEL:=0
+
 ifeq ($(USELOCAL),1)
   PKG_VERSION:=0.10+svn
 else
@@ -77,7 +79,7 @@ define Package/luci-lib-core
   URL:=http://luci.subsignal.org/
   MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
   SUBMENU:=Libraries
-  DEPENDS:=+lua
+  DEPENDS:=+lua +libuci-lua
   TITLE:=LuCI core libraries
 endef
 
@@ -151,10 +153,6 @@ define library
   LUCI_BUILD_PACKAGES += luci-lib-$(1)
 endef
 
-define Package/luci-lib-lucid/extra-install
-       $(call Package/luci/install/template,$(1),libs/lucid-http)
-endef
-
 define Package/luci-lib-web/conffiles
 /etc/config/luci
 endef
@@ -202,8 +200,9 @@ $(eval $(call library,httpclient,HTTP(S) client library,+luci-lib-web +luci-lib-
 $(eval $(call library,ipkg,LuCI IPKG/OPKG call abstraction library))
 $(eval $(call library,json,LuCI JSON library))
 $(eval $(call library,lmo,LuCI LMO I18N library))
-$(eval $(call library,luanet,LuCI luanet library,+libiw))
 $(eval $(call library,lucid,LuCId Full-Stack Webserver,+luci-lib-nixio +luci-lib-web +luci-lib-px5g))
+$(eval $(call library,lucid-http,LuCId HTTP Backend,+luci-lib-lucid))
+$(eval $(call library,lucid-rpc,LuCId RPC Backend,+luci-lib-lucid))
 $(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl))
 $(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
 $(eval $(call library,sys,LuCI Linux/POSIX system library,+libiwinfo))
@@ -361,7 +360,7 @@ $(eval $(call application,diag-devinfo,LuCI Diagnostics Tools (Device Info),\
 
 $(eval $(call application,voice-core,LuCI Voice Software (Core)))
 
-$(eval $(call application,voide-diag,LuCI Voice Software (Diagnostics),\
+$(eval $(call application,voice-diag,LuCI Voice Software (Diagnostics),\
        +luci-app-voice-core +luci-app-diag-devinfo))
 
 
@@ -420,6 +419,7 @@ $(eval $(call application,vnstat,LuCI Support for VnStat,\
        +PACKAGE_luci-app-vnstat:vnstat \
     +PACKAGE_luci-app-vnstat:vnstati))
 
+$(eval $(call application,lqtapifoss,Lantiq voip))
 
 ### Server Gateway Interfaces ###
 define sgi
@@ -459,7 +459,7 @@ define theme
     SUBMENU:=Themes
     TITLE:=$(if $(2),$(2),LuCI $(1) theme)
        MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
-       DEPENDS:=$(ifneq $(1),base,+luci-theme-base) $(4)
+       DEPENDS:=$(if $(filter-out base,$(1)),+luci-theme-base) $(4)
        $(if $(5),DEFAULT:=y if PACKAGE_luci-lib-core)
   endef
 
@@ -476,7 +476,6 @@ endef
 
 $(eval $(call theme,base,Common base for all themes,,+luci-lib-web))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
-$(eval $(call theme,openwrtlight,OpenWrt.org - light variant without images))
 $(eval $(call theme,fledermaus,Fledermaus Theme))
 
 $(eval $(call theme,freifunk,alternative Freifunk Theme,\
@@ -550,21 +549,17 @@ endef
 
 $(eval $(call collection,,\
        Standard OpenWrt set including full and mini admin and the standard theme,\
-       +uhttpd +luci-mod-admin-full +luci-mod-admin-mini +luci-theme-openwrt \
-    +luci-app-firewall +luci-app-initmgr))
+       +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
+       +luci-app-initmgr))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-mod-admin-mini \
-    +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr))
-
-$(eval $(call collection,medium,\
-       Medium package set using only admin full and a theme without graphics,\
-       +uhttpd +luci-mod-admin-full +luci-theme-openwrtlight))
+       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
+       +luci-app-firewall +luci-app-initmgr))
 
 $(eval $(call collection,light,\
-       Minimum package set using only admin mini and a theme without graphics,\
-       +uhttpd +luci-mod-admin-mini +luci-theme-openwrtlight))
+       Minimum package set using only admin mini and athe standard theme,\
+       +uhttpd +luci-mod-admin-mini +luci-theme-openwrt-light))
 
 
 ### Compile ###