Fixed OpenWRT Makefile, mark Freifunk packages as broken
[project/luci.git] / contrib / package / luci / Makefile
index 3b7d731..e3a0ea8 100644 (file)
@@ -55,31 +55,31 @@ define Package/luci/libtemplate
   TITLE:=LuCI - Lua Configuration Interface
   URL:=http://luci.freifunk-halle.net/
   MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
-  SUBMENU:=LuCI Libraries
+  SUBMENU:=LuCI Libraries
   DEPENDS:=+luci-core
 endef
 
 define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI - Freifunk Support (GERMAN ONLY)
-  DEPENDS:=+luci-mod-freifunk
+  SUBMENU:=LuCI Freifunk Support (CURRENTLY BROKEN)
+  DEPENDS:=+luci-mod-freifunk @BROKEN
 endef
 
 define Package/luci/httpdtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
+  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
   DEPENDS:=+luci-httpd
 endef
 
 define Package/luci/i18ntemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Translations
+  SUBMENU:=LuCI Translations
   DEPENDS:=+luci-web
 endef
 
 define Package/luci/thtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Themes
+  SUBMENU:=LuCI Themes
   DEPENDS:=+luci-web
 endef
 
@@ -325,7 +325,7 @@ endef
 
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-admin-full
+  DEPENDS:=+luci-admin-full @BROKEN
   TITLE:=LuCI Freifunk module
 endef
 
@@ -354,14 +354,10 @@ endef
 
 define Package/luci-app-firewall
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core
+  DEPENDS+=+luci-admin-core +firewall
   TITLE:=Firewall and Portforwarding application
 endef
 
-define Package/luci-app-firewall/conffiles
-/etc/config/luci_fw
-endef
-
 define Package/luci-app-firewall/install
        $(call Package/luci/install/template,$(1),applications/luci-fw)
 endef
@@ -369,7 +365,7 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +olsrd-mod-txtinfo
+  DEPENDS+=+luci-admin-full +olsrd +olsrd-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -391,7 +387,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luasocket +iptables-mod-nat +iptables-mod-ipopt
+  DEPENDS+=+luasocket +firewall
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -485,7 +481,7 @@ endef
 ### Themes ###
 define Package/luci-theme-fledermaus
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-web
+  DEPENDS:=+luci-web @BROKEN
   TITLE:=Fledermaus Theme
 endef