libs: remove obsolete iwinfo, its independant now
[project/luci.git] / contrib / package / luci / Makefile
index a1b5955..d38a1ac 100644 (file)
@@ -10,12 +10,12 @@ PKG_NAME:=luci
 PKG_RELEASE:=1
 
 ifeq ($(USELOCAL),1)
-  PKG_VERSION:=0.9+svn
+  PKG_VERSION:=0.10+svn
 else
   PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
     PKG_REV:=$(shell LC_ALL=C svn info $(CURDIR) | sed -ne's/^Revision: //p')
-    PKG_VERSION:=0.9+svn$(PKG_REV)
+    PKG_VERSION:=0.10+svn$(PKG_REV)
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -23,13 +23,18 @@ else
   PKG_SOURCE_VERSION:=$(PKG_REV)
 endif
 
+PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILD_DEPENDS:=libnotimpl
 LUA_TARGET:=source
+LUCI_CFLAGS:=
 PKG_SELECTED_MODULES:=
 
+ifeq ($(BOARD),brcm-2.4)
+  MAKE_FLAGS += CRAP="1"
+endif
+
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -50,42 +55,51 @@ endef
 ### Templates ###
 
 define Package/luci/libtemplate
-  SECTION:=admin
-  CATEGORY:=Administration
+  SECTION:=luci
+  CATEGORY:=LuCI
   TITLE:=LuCI - Lua Configuration Interface
   URL:=http://luci.freifunk-halle.net/
   MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
-  SUBMENU:=LuCI Libraries
+  SUBMENU:=Internal Libraries
   DEPENDS:=+luci-core
 endef
 
-define Package/luci/fftemplate
+define Package/luci/webservertemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Freifunk Support
-  DEPENDS:=+luci-mod-freifunk
+  SUBMENU:=Webserver
 endef
 
-define Package/luci/httpdtemplate
+define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCIttpd
-  DEPENDS:=+luci-httpd
+  SUBMENU:=Freifunk
+  DEPENDS:=+luci-mod-freifunk
 endef
 
 define Package/luci/i18ntemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Translations
+  SUBMENU:=Translations
   DEPENDS:=+luci-web
 endef
 
 define Package/luci/thtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Themes
+  SUBMENU:=Themes
   DEPENDS:=+luci-web
 endef
 
+define Package/luci/maintemplate
+  $(call Package/luci/libtemplate)
+  SUBMENU:=
+endef
+
 define Package/luci/webtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Components
+  SUBMENU:=Components
+endef
+
+define Package/luci/collectiontemplate
+  $(call Package/luci/libtemplate)
+  SUBMENU:=Collections
 endef
 
 
@@ -100,7 +114,7 @@ endef
 
 define Package/luci-core
   $(call Package/luci/libtemplate)
-  DEPENDS:=+lua
+  DEPENDS:=+lua +luci-nixio
   TITLE:=LuCI core libraries
 endef
 
@@ -127,9 +141,6 @@ define Package/luci-core/config
        config PACKAGE_luci-core_source
                bool "Full Source"
 
-       config PACKAGE_luci-core_zipped
-               bool "Precompiled and compressed"
-
        endchoice
 endef
 
@@ -147,17 +158,6 @@ endif
 
 
 ### Libraries ###
-define Package/luci-cbi
-  $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web +luci-uvl +luci-uci
-  TITLE:=Configuration Binding Interface
-endef
-
-define Package/luci-cbi/install
-       $(call Package/luci/install/template,$(1),libs/cbi)
-endef
-
-
 define Package/luci-uci
   $(call Package/luci/libtemplate)
   DEPENDS+=+libuci-lua
@@ -220,6 +220,16 @@ define Package/luci-json/install
 endef
 
 
+define Package/luci-lmo
+  $(call Package/luci/libtemplate)
+  TITLE:=lmo
+endef
+
+define Package/luci-lmo/install
+       $(call Package/luci/install/template,$(1),libs/lmo)
+endef
+
+
 define Package/luci-luanet
   $(call Package/luci/libtemplate)
   TITLE:=luanet
@@ -227,17 +237,29 @@ define Package/luci-luanet
 endef
 
 define Package/luci-luanet/install
-        $(call Package/luci/install/template,$(1),libs/luanet)
+       $(call Package/luci/install/template,$(1),libs/luanet)
+endef
+
+
+define Package/luci-lucid
+  $(call Package/luci/webservertemplate)
+  TITLE:=LuCId Full-Stack Webserver
+  DEPENDS+=+luci-nixio +luci-http +luci-px5g
+endef
+
+define Package/luci-lucid/install
+       $(call Package/luci/install/template,$(1),libs/lucid)
+       $(call Package/luci/install/template,$(1),libs/lucid-http)
 endef
 
 
 
-NIXIO_TLS:=axtls
+NIXIO_TLS:=
 
 define Package/luci-nixio
   $(call Package/luci/libtemplate)
-  TITLE:=NIXIO Socket Library
-  DEPENDS:=
+  TITLE:=NIXIO POSIX Library
+  DEPENDS:=+PACKAGE_luci-nixio_openssl:libopenssl +PACKAGE_luci-nixio_cyassl:libcyassl
 endef
 
 define Package/luci-nixio/install
@@ -247,12 +269,17 @@ endef
 define Package/luci-nixio/config
        choice
                prompt "TLS Provider"
-               default PACKAGE_luci-nixio_axtls
+               default PACKAGE_luci-nixio_notls
+
+               config PACKAGE_luci-nixio_notls
+                       bool "Disabled"
 
                config PACKAGE_luci-nixio_axtls
                        bool "Builtin (axTLS)"
-                       select PACKAGE_dropbear
-                       select PACKAGE_dropbearconvert
+
+               config PACKAGE_luci-nixio_cyassl
+                       bool "CyaSSL"
+                       select PACKAGE_libcyassl
 
                config PACKAGE_luci-nixio_openssl
                        bool "OpenSSL"
@@ -260,14 +287,35 @@ define Package/luci-nixio/config
        endchoice
 endef
 
+ifneq ($(CONFIG_PACKAGE_luci-nixio_axtls),)
+  NIXIO_TLS:=axtls
+endif
+
 ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
   NIXIO_TLS:=openssl
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-nixio_cyassl),)
+  NIXIO_TLS:=cyassl
+  LUCI_CFLAGS+=-I$(STAGING_DIR)/usr/include/cyassl
+endif
+
+
+define Package/luci-px5g
+  $(call Package/luci/webservertemplate)
+  TITLE:=RSA/X.509 Key Generator (required for LuCId SSL support)
+  DEPENDS:=+luci-nixio
+endef
+
+define Package/luci-px5g/install
+       $(call Package/luci/install/template,$(1),libs/px5g)
+endef
+
 
 define Package/luci-sys
   $(call Package/luci/libtemplate)
   TITLE:=LuCI Linux/POSIX system library
+  DEPENDS:=+libiwinfo
 endef
 
 define Package/luci-sys/install
@@ -277,9 +325,10 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-sys +luci-uci +luci-sgi-cgi
+  DEPENDS+=+luci-http +luci-sys +luci-nixio +luci-uci \
+       +luci-sgi-cgi +luci-lmo
   TITLE:=MVC Webframework
-  $(call Config,luci.main.lang,string,en,Default Language)
+  $(call Config,luci.main.lang,string,auto,Default Language)
 endef
 
 define Package/luci-web/conffiles
@@ -303,26 +352,12 @@ endef
 
 
 
-### HTTPD ###
-
-define Package/luci-httpd
-  $(call Package/luci/httpdtemplate)
-  DEPENDS:=+luci-http +libuci
-  TITLE:=Server Core
-endef
-
-define Package/luci-httpd/install
-       $(call Package/luci/install/template,$(1),libs/lucittpd)
-endef
-
-
-
 ### Community Packages ###
 
 define Package/luci-freifunk-community
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-cgi +luci-app-splash \
+   +luci-web +luci-app-splash \
    +luci-app-ffwizard-leipzig \
    +luci-i18n-german \
    +PACKAGE_luci-freifunk-community:olsrd-luci +PACKAGE_luci-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
@@ -340,21 +375,26 @@ endef
 
 define Package/luci-admin-core
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-web +luci-cbi +luci-i18n-english
+  DEPENDS+=+luci-web +luci-i18n-english
   TITLE:=Web UI Core Module
 endef
 
-define Package/luci-admin-core/conffiles
-/etc/config/luci_hosts
-/etc/config/luci_ethers
-endef
-
 define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
        touch $(1)/etc/init.d/luci_fixtime || true
 endef
 
 
+define Package/luci-niu
+  $(call Package/luci/maintemplate)
+  DEPENDS+=+luci-admin-core @BROKEN
+  TITLE:=NIU - Next Generation Interface 
+endef
+
+define Package/luci-niu/install        
+       $(call Package/luci/install/template,$(1),modules/niu)
+endef
+
 define Package/luci-admin-mini
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-core
@@ -390,7 +430,7 @@ endef
 
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-admin-full +luci-json
+  DEPENDS:=+luci-admin-full +luci-json +PACKAGE_luci-mod-freifunk:freifunk-firewall
   TITLE:=LuCI Freifunk module
 endef
 
@@ -440,7 +480,8 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-olsr:olsrd-luci +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-olsr:olsrd-luci \
+   +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -462,7 +503,10 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+PACKAGE_luci-app-splash:luci-nixio +PACKAGE_luci-app-splash:iptables-mod-nat-extra
+  DEPENDS+=+PACKAGE_luci-app-splash:luci-nixio \
+   +PACKAGE_luci-app-splash:tc +PACKAGE_luci-app-splash:kmod-sched \
+   +PACKAGE_luci-app-splash:iptables-mod-nat-extra \
+   +PACKAGE_luci-app-splash:iptables-mod-ipopt
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -479,7 +523,7 @@ define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-full +PACKAGE_luci-app-statistics:collectd \
    +PACKAGE_luci-app-statistics:rrdtool1 \
-   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 \
+   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool \
    +PACKAGE_luci-app-statistics:collectd-mod-wireless \
    +PACKAGE_luci-app-statistics:collectd-mod-interface \
    +PACKAGE_luci-app-statistics:collectd-mod-load
@@ -494,6 +538,56 @@ define Package/luci-app-statistics/install
        $(call Package/luci/install/template,$(1),applications/luci-statistics)
 endef
 
+define Package/luci-app-diag-core
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core 
+  TITLE:=LuCI Diagnostics Tools (Core)
+endef
+
+define Package/luci-app-diag-devinfo
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+PACKAGE_luci-app-diag-devinfo:luci-app-diag-core \
+       +PACKAGE_luci-app-diag-devinfo:smap \
+       +PACKAGE_luci-app-diag-devinfo:netdiscover \
+       +PACKAGE_luci-app-diag-devinfo:mac-to-devinfo \
+       +PACKAGE_luci-app-diag-devinfo:httping \
+       +PACKAGE_luci-app-diag-devinfo:smap-to-devinfo \
+       +PACKAGE_luci-app-diag-devinfo:netdiscover-to-devinfo
+  TITLE:=LuCI Diagnostics Tools (Device Info)
+endef
+
+define Package/luci-app-voice-core
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core 
+  TITLE:=LuCI Voice Software (Core)
+endef
+
+define Package/luci-app-voice-diag
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+PACKAGE_luci-app-voice-diag:luci-app-voice-core \
+     +PACKAGE_luci-app-voice-diag:luci-app-diag-devinfo
+  TITLE:=LuCI Voice Software (Diagnostics)
+endef
+
+define Package/luci-app-diag-devinfo/conffiles
+/etc/config/luci_devinfo
+endef
+
+define Package/luci-app-diag-core/install
+       $(call Package/luci/install/template,$(1),applications/luci-diag-core)
+endef
+
+define Package/luci-app-diag-devinfo/install
+       $(call Package/luci/install/template,$(1),applications/luci-diag-devinfo)
+endef
+
+define Package/luci-app-voice-core/install
+       $(call Package/luci/install/template,$(1),applications/luci-voice-core)
+endef
+
+define Package/luci-app-voice-diag/install
+       $(call Package/luci/install/template,$(1),applications/luci-voice-diag)
+endef
 
 define Package/luci-app-upnp
   $(call Package/luci/webtemplate)
@@ -539,25 +633,14 @@ define Package/luci-app-samba/install
 endef
 
 
-define Package/luci-app-uvc_streamer
+define Package/luci-app-mmc-over-gpio
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-uvc_streamer:uvc-streamer
-  TITLE:=Webcam Streaming - UVC-Streamer module
-endef
-
-define Package/luci-app-uvc_streamer/install
-        $(call Package/luci/install/template,$(1),applications/luci-uvc_streamer)
-endef
-
-
-define Package/luci-app-mmc_over_gpio
-  $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-mmc_over_gpio:kmod-mmc-over-gpio
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-mmc-over-gpio:kmod-mmc-over-gpio
   TITLE:=mmc_over_gpio
 endef
 
-define Package/luci-app-mmc_over_gpio/install
-        $(call Package/luci/install/template,$(1),applications/luci-mmc_over_gpio)
+define Package/luci-app-mmc-over-gpio/install
+        $(call Package/luci/install/template,$(1),applications/luci-mmc-over-gpio)
 endef
 
 
@@ -582,14 +665,14 @@ define Package/luci-app-ushare/install
         $(call Package/luci/install/template,$(1),applications/luci-ushare)
 endef
 
-define Package/luci-app-hd_idle
+define Package/luci-app-hd-idle
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-hd_idle:hd-idle
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-hd-idle:hd-idle
   TITLE:=hd-idle
 endef
 
-define Package/luci-app-hd_idle/install
-        $(call Package/luci/install/template,$(1),applications/luci-hd_idle)
+define Package/luci-app-hd-idle/install
+        $(call Package/luci/install/template,$(1),applications/luci-hd-idle)
 endef
 
 define Package/luci-app-tinyproxy
@@ -652,41 +735,76 @@ define Package/luci-app-openvpn/install
         $(call Package/luci/install/template,$(1),applications/luci-openvpn)
 endef
 
+define Package/luci-app-p2pblock
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for the Freifunk P2P-Block addon
+  DEPENDS+=+luci-admin-core +luci-app-firewall \
+    +PACKAGE_luci-app-p2pblock:freifunk-p2pblock
+endef
+
+define Package/luci-app-p2pblock/install
+        $(call Package/luci/install/template,$(1),applications/luci-p2pblock)
+endef
+
+define Package/luci-app-multiwan
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for the OpenWrt MultiWAN agent
+  DEPENDS+=+luci-admin-core +luci-app-firewall \
+    +PACKAGE_luci-app-multiwan:multiwan
+endef
+
+define Package/luci-app-multiwan/install
+        $(call Package/luci/install/template,$(1),applications/luci-multiwan)
+endef
+
+define Package/luci-app-wol
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for Wake-on-LAN
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-wol:etherwake
+endef
+
+define Package/luci-app-wol/install
+        $(call Package/luci/install/template,$(1),applications/luci-wol)
+endef
+
+define Package/luci-app-vnstat
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for VnStat
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-vnstat:vnstat \
+    +PACKAGE_luci-app-vnstat:vnstati
+endef
+
+define Package/luci-app-vnstat/install
+        $(call Package/luci/install/template,$(1),applications/luci-vnstat)
+endef
+
 
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
-  $(call Package/luci/libtemplate)
-  TITLE:=SGI for CGI
+  $(call Package/luci/webservertemplate)
+  TITLE:=CGI Gateway behind existing Webserver
 endef
 
 define Package/luci-sgi-cgi/install
        $(call Package/luci/install/template,$(1),libs/sgi-cgi)
 endef
 
-define Package/luci-sgi-luci
+define Package/luci-sgi-uhttpd
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-httpd
-  TITLE:=SGI for LuCIttpd
+  TITLE:=Binding for the uHTTPd server
+  DEPENDS+=+uhttpd +uhttpd-mod-lua
 endef
 
-define Package/luci-sgi-luci/install
-       $(call Package/luci/install/template,$(1),libs/sgi-luci)
+define Package/luci-sgi-uhttpd/install
+       $(call Package/luci/install/template,$(1),libs/sgi-uhttpd)
 endef
 
-define Package/luci-sgi-webuci
-  $(call Package/luci/libtemplate)
-  TITLE:=SGI for Webuci
-endef
-
-define Package/luci-sgi-webuci/install
-       $(call Package/luci/install/template,$(1),libs/sgi-webuci)
-endef
 
 ### Themes ###
 define Package/luci-theme-base
   $(call Package/luci/thtemplate)
-  DEPENDS:=+luci-web
+  DEPENDS:=
   TITLE:=Common base for all themes
 endef
 
@@ -740,7 +858,8 @@ endef
 define Package/luci-theme-openwrt
   $(call Package/luci/thtemplate)
   TITLE:=OpenWrt.org (default)
-  DEPENDS:=+luci-theme-base
+  DEPENDS:=+luci-theme-base luci-core
+  DEFAULT:=y if PACKAGE_luci-core
 endef
 
 define Package/luci-theme-openwrt/install
@@ -838,13 +957,107 @@ define Package/luci-i18n-greek/install
        $(call Package/luci/install/template,$(1),i18n/greek)
 endef
 
+
+define Package/luci-i18n-catalan
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Catalan (by Eduard Duran)
+endef
+
+define Package/luci-i18n-catalan/install
+       $(call Package/luci/install/template,$(1),i18n/catalan)
+endef
+
+
+define Package/luci-i18n-portuguese
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Portuguese (by Jose Monteiro)
+endef
+
+define Package/luci-i18n-portuguese/install
+       $(call Package/luci/install/template,$(1),i18n/portuguese)
+endef
+
+
+define Package/luci-i18n-spanish
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Spanish (by Guillermo Javier Nardoni)
+endef
+
+define Package/luci-i18n-spanish/install
+       $(call Package/luci/install/template,$(1),i18n/spanish)
+endef
+
+
+define Package/luci-i18n-vietnamese
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Vietnamese (by Hong Phuc Dang)
+endef
+
+define Package/luci-i18n-vietnamese/install
+       $(call Package/luci/install/template,$(1),i18n/vietnamese)
+endef
+
+define Package/luci-i18n-malay
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Malay (by Teow Wai Chet)
+endef
+
+define Package/luci-i18n-malay/install
+       $(call Package/luci/install/template,$(1),i18n/malay)
+endef
+
+
+### Collections ###
+define Package/luci
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Standard OpenWrt set including full and mini admin and the standard theme
+  DEPENDS:=+uhttpd +luci-admin-full +luci-admin-mini +luci-theme-openwrt \
+    +luci-app-firewall +luci-app-initmgr
+endef
+
+define Package/luci/install
+       true
+endef
+
+
+define Package/luci-ssl
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Standard OpenWrt set with https support
+  DEPENDS:=+uhttpd +uhttpd-mod-tls +px5g +luci-admin-full +luci-admin-mini \
+    +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr
+endef
+
+define Package/luci-ssl/install
+       true
+endef
+
+
+define Package/luci-medium
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Medium package set using only admin full and a theme without graphics
+  DEPENDS:=+uhttpd +luci-admin-full +luci-theme-openwrtlight
+endef
+
+define Package/luci-medium/install
+       true
+endef
+
+
+define Package/luci-light
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Minimum package set using only admin mini and a theme without graphics
+  DEPENDS:=+uhttpd +luci-admin-mini +luci-theme-openwrtlight
+endef
+
+define Package/luci-light/install
+       true
+endef
+
+
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
        PKG_SELECTED_MODULES+=libs/core
 endif
-ifneq ($(CONFIG_PACKAGE_luci-cbi),)
-       PKG_SELECTED_MODULES+=libs/cbi
-endif
 ifneq ($(CONFIG_PACKAGE_luci-fastindex),)
        PKG_SELECTED_MODULES+=libs/fastindex
 endif
@@ -860,12 +1073,21 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-json),)
        PKG_SELECTED_MODULES+=libs/json
 endif
+ifneq ($(CONFIG_PACKAGE_luci-lmo),)
+       PKG_SELECTED_MODULES+=libs/lmo
+endif
 ifneq ($(CONFIG_PACKAGE_luci-luanet),)
        PKG_SELECTED_MODULES+=libs/luanet
 endif
+ifneq ($(CONFIG_PACKAGE_luci-lucid),)
+       PKG_SELECTED_MODULES+=libs/lucid libs/lucid-http
+endif
 ifneq ($(CONFIG_PACKAGE_luci-nixio),)
        PKG_SELECTED_MODULES+=libs/nixio
 endif
+ifneq ($(CONFIG_PACKAGE_luci-px5g),)
+       PKG_SELECTED_MODULES+=libs/px5g
+endif
 ifneq ($(CONFIG_PACKAGE_luci-uci),)
        PKG_SELECTED_MODULES+=libs/uci
 endif
@@ -879,10 +1101,6 @@ ifneq ($(CONFIG_PACKAGE_luci-uvl),)
        PKG_SELECTED_MODULES+=libs/uvl
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-httpd),)
-       PKG_SELECTED_MODULES+=libs/lucittpd
-endif
-
 ifneq ($(CONFIG_PACKAGE_luci-admin-core),)
        PKG_SELECTED_MODULES+=modules/admin-core
 endif
@@ -892,6 +1110,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-admin-full),)
        PKG_SELECTED_MODULES+=modules/admin-full
 endif
+ifneq ($(CONFIG_PACKAGE_luci-niu),)
+       PKG_SELECTED_MODULES+=modules/niu
+endif
 ifneq ($(CONFIG_PACKAGE_luci-admin-rpc),)
        PKG_SELECTED_MODULES+=modules/rpc
 endif
@@ -924,6 +1145,18 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-statistics),)
        PKG_SELECTED_MODULES+=applications/luci-statistics
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-voice-core),)
+       PKG_SELECTED_MODULES+=applications/luci-voice-core
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-voice-diag),)
+       PKG_SELECTED_MODULES+=applications/luci-voice-diag
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-diag-core),)
+       PKG_SELECTED_MODULES+=applications/luci-diag-core
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-diag-devinfo),)
+       PKG_SELECTED_MODULES+=applications/luci-diag-devinfo
+endif
 ifneq ($(CONFIG_PACKAGE_luci-app-upnp),)
        PKG_SELECTED_MODULES+=applications/luci-upnp
 endif
@@ -936,11 +1169,8 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-samba),)
        PKG_SELECTED_MODULES+=applications/luci-samba
 endif
-ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
-       PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
-endif
-ifneq ($(CONFIG_PACKAGE_luci-app-mmc_over_gpio),)
-        PKG_SELECTED_MODULES+=applications/luci-mmc_over_gpio
+ifneq ($(CONFIG_PACKAGE_luci-app-mmc-over-gpio),)
+        PKG_SELECTED_MODULES+=applications/luci-mmc-over-gpio
 endif
 ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
         PKG_SELECTED_MODULES+=applications/luci-p910nd
@@ -948,8 +1178,8 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-ushare),)
         PKG_SELECTED_MODULES+=applications/luci-ushare
 endif
-ifneq ($(CONFIG_PACKAGE_luci-app-hd_idle),)
-       PKG_SELECTED_MODULES+=applications/luci-hd_idle
+ifneq ($(CONFIG_PACKAGE_luci-app-hd-idle),)
+       PKG_SELECTED_MODULES+=applications/luci-hd-idle
 endif
 ifneq ($(CONFIG_PACKAGE_luci-app-tinyproxy),)
        PKG_SELECTED_MODULES+=applications/luci-tinyproxy
@@ -969,17 +1199,29 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-openvpn),)
        PKG_SELECTED_MODULES+=applications/luci-openvpn
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-p2pblock),)
+       PKG_SELECTED_MODULES+=applications/luci-p2pblock
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-multiwan),)
+       PKG_SELECTED_MODULES+=applications/luci-multiwan
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-wol),)
+       PKG_SELECTED_MODULES+=applications/luci-wol
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-vnstat),)
+       PKG_SELECTED_MODULES+=applications/luci-vnstat
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
        PKG_SELECTED_MODULES+=libs/sgi-cgi
 endif
+ifneq ($(CONFIG_PACKAGE_luci-sgi-uhttpd),)
+       PKG_SELECTED_MODULES+=libs/sgi-uhttpd
+endif
 ifneq ($(CONFIG_PACKAGE_luci-sgi-luci),)
        PKG_SELECTED_MODULES+=libs/sgi-luci
 endif
-ifneq ($(CONFIG_PACKAGE_luci-sgi-webuci),)
-       PKG_SELECTED_MODULES+=libs/sgi-webuci
-endif
 
 ifneq ($(CONFIG_PACKAGE_luci-theme-base),)
        PKG_SELECTED_MODULES+=themes/base
@@ -1027,36 +1269,52 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-greek),)
        PKG_SELECTED_MODULES+=i18n/greek
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-catalan),)
+       PKG_SELECTED_MODULES+=i18n/catalan
+endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-portuguese),)
+       PKG_SELECTED_MODULES+=i18n/portuguese
+endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-spanish),)
+       PKG_SELECTED_MODULES+=i18n/spanish
+endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-vietnamese),)
+       PKG_SELECTED_MODULES+=i18n/vietnamese
+endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-malay),)
+       PKG_SELECTED_MODULES+=i18n/malay
+endif
 
 
 MAKE_FLAGS += \
        MODULES="$(PKG_SELECTED_MODULES)" \
        LUA_TARGET="$(LUA_TARGET)" \
        LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
-       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
        LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
        NIXIO_TLS="$(NIXIO_TLS)" OS="Linux"
 
 
 $(eval $(call BuildPackage,luci-core))
-$(eval $(call BuildPackage,luci-cbi))
 $(eval $(call BuildPackage,luci-fastindex))
 $(eval $(call BuildPackage,luci-http))
 $(eval $(call BuildPackage,luci-httpclient))
 $(eval $(call BuildPackage,luci-ipkg))
 $(eval $(call BuildPackage,luci-json))
+$(eval $(call BuildPackage,luci-lmo))
 $(eval $(call BuildPackage,luci-luanet))
+$(eval $(call BuildPackage,luci-lucid))
 $(eval $(call BuildPackage,luci-nixio))
+$(eval $(call BuildPackage,luci-px5g))
 $(eval $(call BuildPackage,luci-uci))
 $(eval $(call BuildPackage,luci-sys))
 $(eval $(call BuildPackage,luci-web))
 $(eval $(call BuildPackage,luci-uvl))
 
-$(eval $(call BuildPackage,luci-httpd))
-
 $(eval $(call BuildPackage,luci-admin-core))
 $(eval $(call BuildPackage,luci-admin-mini))
 $(eval $(call BuildPackage,luci-admin-full))
+$(eval $(call BuildPackage,luci-niu))
 $(eval $(call BuildPackage,luci-admin-rpc))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
@@ -1069,25 +1327,31 @@ $(eval $(call BuildPackage,luci-app-olsr))
 $(eval $(call BuildPackage,luci-app-qos))
 $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))
+$(eval $(call BuildPackage,luci-app-diag-core))
+$(eval $(call BuildPackage,luci-app-diag-devinfo))
+$(eval $(call BuildPackage,luci-app-voice-core))
+$(eval $(call BuildPackage,luci-app-voice-diag))
 $(eval $(call BuildPackage,luci-app-upnp))
 $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
-$(eval $(call BuildPackage,luci-app-uvc_streamer))
-$(eval $(call BuildPackage,luci-app-mmc_over_gpio))
+$(eval $(call BuildPackage,luci-app-mmc-over-gpio))
 $(eval $(call BuildPackage,luci-app-p910nd))
 $(eval $(call BuildPackage,luci-app-ushare))
-$(eval $(call BuildPackage,luci-app-hd_idle))
+$(eval $(call BuildPackage,luci-app-hd-idle))
 $(eval $(call BuildPackage,luci-app-tinyproxy))
 $(eval $(call BuildPackage,luci-app-initmgr))
 $(eval $(call BuildPackage,luci-app-livestats))
 $(eval $(call BuildPackage,luci-app-asterisk))
 $(eval $(call BuildPackage,luci-app-polipo))
 $(eval $(call BuildPackage,luci-app-openvpn))
+$(eval $(call BuildPackage,luci-app-p2pblock))
+$(eval $(call BuildPackage,luci-app-multiwan))
+$(eval $(call BuildPackage,luci-app-wol))
+$(eval $(call BuildPackage,luci-app-vnstat))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
-$(eval $(call BuildPackage,luci-sgi-luci))
-$(eval $(call BuildPackage,luci-sgi-webuci))
+$(eval $(call BuildPackage,luci-sgi-uhttpd))
 
 $(eval $(call BuildPackage,luci-theme-base))
 $(eval $(call BuildPackage,luci-theme-fledermaus))
@@ -1105,3 +1369,13 @@ $(eval $(call BuildPackage,luci-i18n-russian))
 $(eval $(call BuildPackage,luci-i18n-portuguese_brazilian))
 $(eval $(call BuildPackage,luci-i18n-japanese))
 $(eval $(call BuildPackage,luci-i18n-greek))
+$(eval $(call BuildPackage,luci-i18n-catalan))
+$(eval $(call BuildPackage,luci-i18n-portuguese))
+$(eval $(call BuildPackage,luci-i18n-spanish))
+$(eval $(call BuildPackage,luci-i18n-vietnamese))
+$(eval $(call BuildPackage,luci-i18n-malay))
+
+$(eval $(call BuildPackage,luci))
+$(eval $(call BuildPackage,luci-ssl))
+$(eval $(call BuildPackage,luci-medium))
+$(eval $(call BuildPackage,luci-light))