contrib/package: add Makefile entry for luci-app-ahcp
[project/luci.git] / contrib / package / luci / Makefile
index 0427e4b..8f2f909 100644 (file)
@@ -39,31 +39,6 @@ ifeq ($(BOARD),brcm-2.4)
 endif
 
 
-include $(INCLUDE_DIR)/package.mk
-
-ifeq ($(USELOCAL),1)
-  define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(TAR) c -C ../../../ . \
-               --exclude=.pc --exclude=.svn --exclude=.git \
-               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
-               --exclude=dist | \
-                       tar x -C $(PKG_BUILD_DIR)/
-  endef
-endif
-
-define Build/Configure
-endef
-
-MAKE_FLAGS += \
-       MODULES="$(LUCI_SELECTED_MODULES)" \
-       LUA_TARGET="$(LUA_TARGET)" \
-       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
-       CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
-       NIXIO_TLS="$(NIXIO_TLS)" OS="Linux"
-
-
 ### Templates ###
 define Package/luci/install/template
        $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
@@ -103,6 +78,9 @@ define Package/luci-lib-core/config
        config PACKAGE_luci-lib-core_stripped
                bool "Stripped"
 
+       config PACKAGE_luci-lib-core_srcdiet
+               bool "Compressed Source"
+
        config PACKAGE_luci-lib-core_source
                bool "Full Source"
 
@@ -117,8 +95,8 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-core_stripped),)
   LUA_TARGET:=strip
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-lib-core_zipped),)
-  LUA_TARGET:=gzip
+ifneq ($(CONFIG_PACKAGE_luci-lib-core_srcdiet),)
+  LUA_TARGET:=diet
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-lib-core),)
@@ -220,12 +198,12 @@ define Package/luci-mod-freifunk-community
   TITLE:=Freifunk Community Meta-Package
   DEPENDS+= \
    +luci-lib-web +luci-app-splash \
-   +luci-app-ffwizard-leipzig \
+   +luci-app-ffwizard \
    +luci-i18n-german \
    +PACKAGE_luci-mod-freifunk-community:olsrd +PACKAGE_luci-mod-freifunk-community:olsrd-mod-dyn-gw-plain \
    +PACKAGE_luci-mod-freifunk-community:olsrd-mod-txtinfo +PACKAGE_luci-mod-freifunk-community:olsrd-mod-nameservice \
    +PACKAGE_luci-mod-freifunk-community:olsrd-mod-watchdog +PACKAGE_luci-mod-freifunk-community:kmod-tun \
-   +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr
+   +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr +luci-app-olsr-services
 endef
 
 define Package/luci-mod-freifunk-community/install
@@ -319,8 +297,6 @@ define Package/luci-app-diag-devinfo/conffiles
 endef
 
 
-$(eval $(call application,ffwizard-leipzig,Freifunk Leipzig configuration wizard))
-
 $(eval $(call application,ffwizard,Freifunk configuration wizard,\
        +luci-mod-freifunk))
 
@@ -330,12 +306,18 @@ $(eval $(call application,siitwizard,SIIT IPv4-over-IPv6 configuration wizard,\
 $(eval $(call application,firewall,Firmware and Portforwarding application,\
        +PACKAGE_luci-app-firewall:firewall))
 
+$(eval $(call application,freifunk-policyrouting,Policy routing for mesh traffic,\
+        +PACKAGE_luci-app-freifunk-policyrouting:freifunk-policyrouting +luci-mod-freifunk))
+
 $(eval $(call application,olsr,OLSR configuration and status module,\
        +luci-mod-admin-full +PACKAGE_luci-app-olsr:olsrd +PACKAGE_luci-app-olsr:olsrd-mod-txtinfo))
 
 $(eval $(call application,olsr-viz,OLSR Visualisation,\
        +PACKAGE_luci-app-olsr-viz:luci-app-olsr +PACKAGE_luci-app-olsr-viz:olsrd-mod-txtinfo))
 
+$(eval $(call application,olsr-services,Show services announced with the nameservice plugin,\
+       +PACKAGE_luci-app-olsr-services:olsrd-mod-nameservice +luci-mod-freifunk +PACKAGE_luci-app-olsr-services:luci-app-olsr))
+
 $(eval $(call application,qos,Quality of Service configuration module,\
        +PACKAGE_luci-app-qos:qos-scripts))
 
@@ -396,9 +378,6 @@ $(eval $(call application,hd-idle,Hard Disk Idle Spin-Down module,\
 $(eval $(call application,tinyproxy,Tinyproxy - HTTP(S)-Proxy configuration,\
        +luci-mod-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy))
 
-$(eval $(call application,initmgr,LuCI Initscript Management,\
-       +luci-mod-admin-full))
-
 $(eval $(call application,polipo,LuCI Support for the Polipo Proxy,\
        +PACKAGE_luci-app-polipo:polipo))
 
@@ -421,6 +400,9 @@ $(eval $(call application,vnstat,LuCI Support for VnStat,\
 $(eval $(call application,radvd,LuCI Support for Radvd,\
        +luci-mod-admin-full +PACKAGE_luci-app-radvd:radvd))
 
+$(eval $(call application,ahcp,LuCI Support for AHCPd,\
+       +luci-mod-admin-full +PACKAGE_luci-app-ahcp:ahcpd))
+
 $(eval $(call application,lqtapifoss,Lantiq voip))
 
 ### Server Gateway Interfaces ###
@@ -521,6 +503,7 @@ $(eval $(call translation,french,French (by Florian Fainelli)))
 $(eval $(call translation,italian,Italian (by Matteo Croce)))
 $(eval $(call translation,russian,Russian (by Skryabin Dmitry)))
 $(eval $(call translation,portuguese_brazilian,Portuguese (Brazilian) (by Carlos Cesario)))
+$(eval $(call translation,chinese,Chinese (by Chinese Translators)))
 $(eval $(call translation,japanese,Japanese (by Tsukasa Hamano)))
 $(eval $(call translation,greek,Greek (by Vasilis Tsiligiannis)))
 $(eval $(call translation,catalan,Catalan (by Eduard Duran)))
@@ -554,12 +537,12 @@ endef
 $(eval $(call collection,,\
        Standard OpenWrt set including full and mini admin and the standard theme,\
        +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
-       +luci-app-initmgr +libiwinfo))
+       +libiwinfo))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
        +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
-       +luci-app-firewall +luci-app-initmgr +libiwinfo))
+       +luci-app-firewall +libiwinfo))
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and the standard theme,\
@@ -568,4 +551,30 @@ $(eval $(call collection,light,\
 
 ### Compile ###
 PKG_CONFIG_DEPENDS=$(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
+
+include $(INCLUDE_DIR)/package.mk
+
+ifeq ($(USELOCAL),1)
+  define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(TAR) c -C ../../../ . \
+               --exclude=.pc --exclude=.svn --exclude=.git \
+               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+               --exclude=dist | \
+                       tar x -C $(PKG_BUILD_DIR)/
+  endef
+endif
+
+define Build/Configure
+endef
+
+MAKE_FLAGS += \
+       MODULES="$(LUCI_SELECTED_MODULES)" \
+       LUA_TARGET="$(LUA_TARGET)" \
+       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
+       CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
+       NIXIO_TLS="$(NIXIO_TLS)" OS="Linux"
+
+
 $(foreach b,$(LUCI_BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))