contrib/package: switch to olsrd dyn_gw_plain plugin and enable it by default
[project/luci.git] / contrib / package / luci / Makefile
index a70c303..82921c8 100644 (file)
@@ -10,12 +10,12 @@ PKG_NAME:=luci
 PKG_RELEASE:=1
 
 ifeq ($(USELOCAL),1)
-  PKG_VERSION:=0.7+svn
+  PKG_VERSION:=0.9+svn
 else
-  PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
+  PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
     PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Last Changed Rev: //p')
-    PKG_VERSION:=0.7+svn$(PKG_REV)
+    PKG_VERSION:=0.9+svn$(PKG_REV)
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -61,13 +61,13 @@ endef
 
 define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Freifunk Support (PARTLY BROKEN)
-  DEPENDS:=+luci-mod-freifunk @BROKEN
+  SUBMENU:=LuCI Freifunk Support
+  DEPENDS:=+luci-mod-freifunk
 endef
 
 define Package/luci/httpdtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
+  SUBMENU:=LuCIttpd
   DEPENDS:=+luci-httpd
 endef
 
@@ -100,12 +100,17 @@ endef
 
 define Package/luci-core
   $(call Package/luci/libtemplate)
-  DEPENDS:=+lua +luaposix +bitlib
+  DEPENDS:=+lua
   TITLE:=LuCI core libraries
 endef
 
-define Package/luci-core/install               
+define Package/luci-core/install
        $(call Package/luci/install/template,$(1),libs/core)
+       $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
+               "OpenWrt Firmware" \
+               "$(OPENWRTVERSION)" \
+               "$(PKG_BRANCH)" \
+               "$(PKG_VERSION)"
 endef
 
 define Package/luci-core/config
@@ -115,7 +120,7 @@ define Package/luci-core/config
 
        config PACKAGE_luci-core_compile
                bool "Precompiled"
-               
+
        config PACKAGE_luci-core_stripped
                bool "Stripped"
 
@@ -137,7 +142,7 @@ endif
 ### Libraries ###
 define Package/luci-cbi
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web
+  DEPENDS+=+luci-web +luci-uvl +luci-uci
   TITLE:=Configuration Binding Interface
 endef
 
@@ -179,7 +184,7 @@ endef
 
 define Package/luci-ipkg
   $(call Package/luci/libtemplate)
-  TITLE:=LuCI IPKG/OPKG call abstraction library 
+  TITLE:=LuCI IPKG/OPKG call abstraction library
 endef
 
 define Package/luci-ipkg/install
@@ -187,6 +192,16 @@ define Package/luci-ipkg/install
 endef
 
 
+define Package/luci-json
+  $(call Package/luci/libtemplate)
+  TITLE:=LuCI JSON Library
+endef
+
+define Package/luci-json/install
+       $(call Package/luci/install/template,$(1),libs/json)
+endef
+
+
 define Package/luci-sys
   $(call Package/luci/libtemplate)
   TITLE:=LuCI Linux/POSIX system library
@@ -199,8 +214,9 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-sys +luci-addons +luci-uci +luci-sgi-cgi
+  DEPENDS+=+luci-http +luci-sys +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
+  $(call Config,luci.main.lang,string,en,Default Language)
 endef
 
 define Package/luci-web/conffiles
@@ -212,100 +228,50 @@ define Package/luci-web/install
 endef
 
 
+define Package/luci-uvl
+  $(call Package/luci/libtemplate)
+  DEPENDS+=+luci-sys +luci-uci +luci-core
+  TITLE:=UVL - UCI Validation Layer
+endef
+
+define Package/luci-uvl/install
+       $(call Package/luci/install/template,$(1),libs/uvl)
+endef
+
+
 
 ### HTTPD ###
 
 define Package/luci-httpd
   $(call Package/luci/httpdtemplate)
-  DEPENDS:=+luci-http +luasocket
+  DEPENDS:=+luci-http +libuci
   TITLE:=Server Core
 endef
 
 define Package/luci-httpd/install
-       $(call Package/luci/install/template,$(1),libs/httpd)
+       $(call Package/luci/install/template,$(1),libs/lucittpd)
 endef
 
 
 
 ### Community Packages ###
 
-define Package/luci-ff-halle
-  $(call Package/luci/fftemplate)
-  DEPENDS+= \
-   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
-   +luci-app-ffwizard-leipzig \
-   +luci-theme-fledermaus \
-   +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice \
-   +kmod-tun +ip
-  TITLE:=Freifunk Halle Community Meta-Package
-endef
-
-define Package/luci-ff-halle/install
-       $(call Package/luci/install/template,$(1),applications/community-halle)
-endef
-
-
-define Package/luci-ff-leipzig
+define Package/luci-freifunk-community
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
+   +luci-sgi-cgi +luci-app-splash \
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice \
-   +kmod-tun +ip
-  TITLE:=Freifunk Leipzig Community Meta-Package
-endef
-
-define Package/luci-ff-leipzig/install
-       $(call Package/luci/install/template,$(1),applications/community-leipzig)
-endef
-
-
-define Package/luci-ff-hannover
-  $(call Package/luci/fftemplate)
-  DEPENDS+= \
-   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
-   +luci-theme-fledermaus \
-   +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
-  TITLE:=Freifunk Hannover Community Meta-Package
-  URL:=http://www.freifunk-hannover.de/
-  MAINTAINER:=Mickey Knox <mickey-at-netfreaks-dot-org>
-endef
-
-define Package/luci-ff-hannover/install
-       $(call Package/luci/install/template,$(1),applications/community-hannover)
-endef
-
-
-define Package/luci-ff-berlin
-  $(call Package/luci/fftemplate)
-  DEPENDS+= \
-   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
-   +luci-theme-fledermaus \
-   +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
-  TITLE:=Freifunk Berlin Community Meta-Package
-endef
-
-define Package/luci-ff-berlin/install
-       $(call Package/luci/install/template,$(1),applications/community-berlin)
-endef
-
-define Package/luci-ff-augsburg
-  $(call Package/luci/fftemplate)
-  DEPENDS+= \
-   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
-   +luci-theme-fledermaus \
-   +luci-i18n-german \
-   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
-  TITLE:=Freifunk Augsburg Community Meta-Package
+   +PACKAGE_luci-freifunk-community:olsrd-luci +PACKAGE_luci-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
+   +PACKAGE_luci-freifunk-community:olsrd-luci-mod-txtinfo +PACKAGE_luci-freifunk-community:olsrd-luci-mod-nameservice \
+   +PACKAGE_luci-freifunk-community:kmod-tun +PACKAGE_luci-freifunk-community:ip \
+   +luci-app-olsr
+  TITLE:=Freifunk Community Meta-Package
 endef
 
-define Package/luci-ff-augsburg/install
-        $(call Package/luci/install/template,$(1),applications/community-augsburg)
+define Package/luci-freifunk-community/install
+       $(call Package/luci/install/template,$(1),applications/freifunk-community)
 endef
 
 ### Modules ###
@@ -316,15 +282,21 @@ define Package/luci-admin-core
   TITLE:=Web UI Core Module
 endef
 
+define Package/luci-admin-core/conffiles
+/etc/config/luci_hosts
+/etc/config/luci_ethers
+endef
+
 define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
+       touch $(1)/etc/init.d/luci_fixtime || true
 endef
 
 
 define Package/luci-admin-mini
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-core
-  TITLE:=LuCI Essentials - casual user's interface
+  TITLE:=LuCI Essentials - stripped down and user-friendly
 endef
 
 define Package/luci-admin-mini/install
@@ -335,7 +307,7 @@ endef
 define Package/luci-admin-full
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-core +luci-ipkg
-  TITLE:=LuCI Administration - power user's interface
+  TITLE:=LuCI Administration - full-featured for full control
 endef
 
 define Package/luci-admin-full/install
@@ -343,9 +315,20 @@ define Package/luci-admin-full/install
 endef
 
 
+define Package/luci-admin-rpc
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-json
+  TITLE:=LuCI RPC - JSON-RPC API
+endef
+
+define Package/luci-admin-rpc/install
+       $(call Package/luci/install/template,$(1),modules/rpc)
+endef
+
+
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-admin-full
+  DEPENDS:=+luci-admin-full +luci-json
   TITLE:=LuCI Freifunk module
 endef
 
@@ -363,7 +346,6 @@ endef
 
 define Package/luci-app-ffwizard-leipzig
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luci-app-firewall
   TITLE:=Freifunk Leipzig configuration wizard
 endef
 
@@ -372,9 +354,20 @@ define Package/luci-app-ffwizard-leipzig/install
 endef
 
 
+define Package/luci-app-siitwizard
+  $(call Package/luci/fftemplate)
+  TITLE:=SIIT IPv4-over-IPv6 configuration wizard
+  DEPENDS:=+luci-admin-core +PACKAGE_luci-app-siitwizard:kmod-siit
+endef
+
+define Package/luci-app-siitwizard/install
+       $(call Package/luci/install/template,$(1),applications/luci-siitwizard)
+endef
+
+
 define Package/luci-app-firewall
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +firewall
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-firewall:firewall
   TITLE:=Firewall and Portforwarding application
 endef
 
@@ -385,7 +378,7 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +olsrd +olsrd-mod-txtinfo
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-olsr:olsrd-luci +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -396,7 +389,7 @@ endef
 
 define Package/luci-app-qos
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +qos-scripts
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-qos:qos-scripts
   TITLE:=Quality of Service configuration module
 endef
 
@@ -407,7 +400,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luasocket +luci-app-firewall
+  DEPENDS+=+PACKAGE_luci-app-splash:luasocket
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -422,7 +415,8 @@ endef
 
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +collectd +collectd-mod-rrdtool1 +rrdtool1
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-statistics:collectd \
+   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 +PACKAGE_luci-app-statistics:rrdtool1
   TITLE:=LuCI Statistics Application
 endef
 
@@ -437,7 +431,7 @@ endef
 
 define Package/luci-app-upnp
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +miniupnpd
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-upnp:miniupnpd
   TITLE:=Universal Plug & Play configuration module
 endef
 
@@ -448,7 +442,7 @@ endef
 
 define Package/luci-app-ntpc
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +ntpclient
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-ntpc:ntpclient
   TITLE:=NTP time synchronisation client configuration module
 endef
 
@@ -459,7 +453,7 @@ endef
 
 define Package/luci-app-ddns
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +ddns-scripts
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-ddns:ddns-scripts
   TITLE:=Dynamic DNS configuration module
 endef
 
@@ -470,7 +464,7 @@ endef
 
 define Package/luci-app-samba
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +samba3
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-samba:samba3
   TITLE:=Network Shares - Samba SMB/CIFS module
 endef
 
@@ -479,6 +473,120 @@ define Package/luci-app-samba/install
 endef
 
 
+define Package/luci-app-uvc_streamer
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-uvc_streamer:uvc-streamer
+  TITLE:=Webcam Streaming - UVC-Streamer module
+endef
+
+define Package/luci-app-uvc_streamer/install
+        $(call Package/luci/install/template,$(1),applications/luci-uvc_streamer)
+endef
+
+
+define Package/luci-app-mmc_over_gpio
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-mmc_over_gpio:kmod-mmc-over-gpio
+  TITLE:=mmc_over_gpio
+endef
+
+define Package/luci-app-mmc_over_gpio/install
+        $(call Package/luci/install/template,$(1),applications/luci-mmc_over_gpio)
+endef
+
+
+define Package/luci-app-p910nd
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-p910nd:p910nd
+  TITLE:=p910nd - Printer server module
+endef
+
+define Package/luci-app-p910nd/install
+        $(call Package/luci/install/template,$(1),applications/luci-p910nd)
+endef
+
+
+define Package/luci-app-ushare
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-ushare:ushare
+  TITLE:=ushare - UPnP A/V & DLNA Media Server
+endef
+
+define Package/luci-app-ushare/install
+        $(call Package/luci/install/template,$(1),applications/luci-ushare)
+endef
+
+define Package/luci-app-hd_idle
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-hd_idle:hd-idle
+  TITLE:=hd-idle
+endef
+
+define Package/luci-app-hd_idle/install
+        $(call Package/luci/install/template,$(1),applications/luci-hd_idle)
+endef
+
+define Package/luci-app-tinyproxy
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy
+  TITLE:=Tinyproxy - HTTP(S)-Proxy
+endef
+
+define Package/luci-app-tinyproxy/install
+        $(call Package/luci/install/template,$(1),applications/luci-tinyproxy)
+endef
+
+define Package/luci-app-initmgr
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full
+  TITLE:=LuCI Initscript Management
+endef
+
+define Package/luci-app-initmgr/install
+        $(call Package/luci/install/template,$(1),applications/luci-initmgr)
+endef
+
+define Package/luci-app-livestats
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +luci-admin-rpc
+  TITLE:=LuCI Realtime Statistics
+endef
+
+define Package/luci-app-livestats/install
+        $(call Package/luci/install/template,$(1),applications/luci-livestats)
+endef
+
+define Package/luci-app-asterisk
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for Asterisk PBX
+  DEPENDS+=@BROKEN +luci-admin-core +PACKAGE_luci-app-asterisk:asterisk14-xip-core
+endef
+
+define Package/luci-app-asterisk/install
+        $(call Package/luci/install/template,$(1),applications/luci-asterisk)
+endef
+
+define Package/luci-app-polipo
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for the Polipo Proxy
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-polipo:polipo
+endef
+
+define Package/luci-app-polipo/install
+        $(call Package/luci/install/template,$(1),applications/luci-polipo)
+endef
+
+define Package/luci-app-openvpn
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for OpenVPN
+  DEPENDS+=@BROKEN +luci-admin-core +PACKAGE_luci-app-openvpn:openvpn
+endef
+
+define Package/luci-app-openvpn/install
+        $(call Package/luci/install/template,$(1),applications/luci-openvpn)
+endef
+
+
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
@@ -493,7 +601,7 @@ endef
 define Package/luci-sgi-luci
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-httpd
-  TITLE:=SGI for LuCI HTTPD
+  TITLE:=SGI for LuCIttpd
 endef
 
 define Package/luci-sgi-luci/install
@@ -510,6 +618,16 @@ define Package/luci-sgi-webuci/install
 endef
 
 ### Themes ###
+define Package/luci-theme-base
+  $(call Package/luci/thtemplate)
+  DEPENDS:=+luci-web
+  TITLE:=Common base for all themes
+endef
+
+define Package/luci-theme-base/install
+       $(call Package/luci/install/template,$(1),themes/base)
+endef
+
 define Package/luci-theme-fledermaus
   $(call Package/luci/fftemplate)
   DEPENDS:=+luci-web
@@ -520,9 +638,32 @@ define Package/luci-theme-fledermaus/install
        $(call Package/luci/install/template,$(1),themes/fledermaus)
 endef
 
+define Package/luci-theme-freifunk
+  $(call Package/luci/fftemplate)
+  DEPENDS:=+luci-web
+  MAINTAINER:=Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>
+  TITLE:=alternative Freifunk Theme
+endef
+
+define Package/luci-theme-freifunk/install
+        $(call Package/luci/install/template,$(1),themes/freifunk)
+endef
+
+define Package/luci-theme-freifunk-bno
+  $(call Package/luci/fftemplate)
+  DEPENDS:=+luci-web
+  MAINTAINER:=Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>
+  TITLE:=Freifunk Berlin Nordost Theme
+endef
+
+define Package/luci-theme-freifunk-bno/install
+       $(call Package/luci/install/template,$(1),themes/freifunk-bno)
+endef
+
 define Package/luci-theme-openwrt
   $(call Package/luci/thtemplate)
-  TITLE:=OpenWRT.org (default)
+  TITLE:=OpenWrt.org (default)
+  DEPENDS:=+luci-theme-base
 endef
 
 define Package/luci-theme-openwrt/install
@@ -531,7 +672,8 @@ endef
 
 define Package/luci-theme-openwrtlight
   $(call Package/luci/thtemplate)
-  TITLE:=OpenWRT.org - light variant without images
+  TITLE:=OpenWrt.org - light variant without images
+  DEPENDS:=+luci-theme-base
 endef
 
 define Package/luci-theme-openwrtlight/install
@@ -562,7 +704,7 @@ endef
 
 define Package/luci-i18n-french
   $(call Package/luci/i18ntemplate)
-  TITLE:=French
+  TITLE:=French (by Florian Fainelli)
 endef
 
 define Package/luci-i18n-french/install
@@ -570,6 +712,34 @@ define Package/luci-i18n-french/install
 endef
 
 
+define Package/luci-i18n-italian
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Italian (by Matteo Croce)
+endef
+
+define Package/luci-i18n-italian/install
+       $(call Package/luci/install/template,$(1),i18n/italian)
+endef
+
+
+define Package/luci-i18n-russian
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Russian (by Skryabin Dmitry)
+endef
+
+define Package/luci-i18n-russian/install
+       $(call Package/luci/install/template,$(1),i18n/russian)
+endef
+
+
+define Package/luci-i18n-portuguese_brazilian
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Portuguese (Brazilian) (by Carlos Cesario)
+endef
+
+define Package/luci-i18n-portuguese_brazilian/install
+       $(call Package/luci/install/template,$(1),i18n/portuguese_brazilian)
+endef
 
 
 ### Compile ###
@@ -588,6 +758,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-ipkg),)
        PKG_SELECTED_MODULES+=libs/ipkg
 endif
+ifneq ($(CONFIG_PACKAGE_luci-json),)
+       PKG_SELECTED_MODULES+=libs/json
+endif
 ifneq ($(CONFIG_PACKAGE_luci-uci),)
        PKG_SELECTED_MODULES+=libs/uci
 endif
@@ -597,25 +770,12 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-web),)
        PKG_SELECTED_MODULES+=libs/web
 endif
-
-ifneq ($(CONFIG_PACKAGE_luci-httpd),)
-       PKG_SELECTED_MODULES+=libs/httpd
+ifneq ($(CONFIG_PACKAGE_luci-uvl),)
+       PKG_SELECTED_MODULES+=libs/uvl
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-ff-halle),)
-       PKG_SELECTED_MODULES+=applications/community-halle
-endif
-ifneq ($(CONFIG_PACKAGE_luci-ff-leipzig),)
-       PKG_SELECTED_MODULES+=applications/community-leipzig
-endif
-ifneq ($(CONFIG_PACKAGE_luci-ff-hannover),)
-       PKG_SELECTED_MODULES+=applications/community-hannover
-endif
-ifneq ($(CONFIG_PACKAGE_luci-ff-berlin),)
-       PKG_SELECTED_MODULES+=applications/community-berlin
-endif
-ifneq ($(CONFIG_PACKAGE_luci-ff-augsburg),)
-        PKG_SELECTED_MODULES+=applications/community-augsburg
+ifneq ($(CONFIG_PACKAGE_luci-httpd),)
+       PKG_SELECTED_MODULES+=libs/lucittpd
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-admin-core),)
@@ -627,13 +787,23 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-admin-full),)
        PKG_SELECTED_MODULES+=modules/admin-full
 endif
+ifneq ($(CONFIG_PACKAGE_luci-admin-rpc),)
+       PKG_SELECTED_MODULES+=modules/rpc
+endif
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk),)
        PKG_SELECTED_MODULES+=modules/freifunk
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-freifunk-community),)
+       PKG_SELECTED_MODULES+=applications/freifunk-community
+endif
+
 ifneq ($(CONFIG_PACKAGE_luci-app-ffwizard-leipzig),)
        PKG_SELECTED_MODULES+=applications/luci-ffwizard-leipzig
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-siitwizard),)
+       PKG_SELECTED_MODULES+=applications/luci-siitwizard
+endif
 ifneq ($(CONFIG_PACKAGE_luci-app-firewall),)
        PKG_SELECTED_MODULES+=applications/luci-fw
 endif
@@ -661,6 +831,39 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-samba),)
        PKG_SELECTED_MODULES+=applications/luci-samba
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
+       PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-mmc_over_gpio),)
+        PKG_SELECTED_MODULES+=applications/luci-mmc_over_gpio
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
+        PKG_SELECTED_MODULES+=applications/luci-p910nd
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-ushare),)
+        PKG_SELECTED_MODULES+=applications/luci-ushare
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-hd_idle),)
+       PKG_SELECTED_MODULES+=applications/luci-hd_idle
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-tinyproxy),)
+       PKG_SELECTED_MODULES+=applications/luci-tinyproxy
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-initmgr),)
+       PKG_SELECTED_MODULES+=applications/luci-initmgr
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-livestats),)
+       PKG_SELECTED_MODULES+=applications/luci-livestats
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-asterisk),)
+       PKG_SELECTED_MODULES+=applications/luci-asterisk
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-polipo),)
+       PKG_SELECTED_MODULES+=applications/luci-polipo
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-openvpn),)
+       PKG_SELECTED_MODULES+=applications/luci-openvpn
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -673,9 +876,18 @@ ifneq ($(CONFIG_PACKAGE_luci-sgi-webuci),)
        PKG_SELECTED_MODULES+=libs/sgi-webuci
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-theme-base),)
+       PKG_SELECTED_MODULES+=themes/base
+endif
 ifneq ($(CONFIG_PACKAGE_luci-theme-fledermaus),)
        PKG_SELECTED_MODULES+=themes/fledermaus
 endif
+ifneq ($(CONFIG_PACKAGE_luci-theme-freifunk-bno),)
+       PKG_SELECTED_MODULES+=themes/freifunk-bno
+endif
+ifneq ($(CONFIG_PACKAGE_luci-theme-freifunk),)
+       PKG_SELECTED_MODULES+=themes/freifunk
+endif
 ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
        PKG_SELECTED_MODULES+=themes/openwrt.org
 endif
@@ -692,12 +904,21 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-french),)
        PKG_SELECTED_MODULES+=i18n/french
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-italian),)
+       PKG_SELECTED_MODULES+=i18n/italian
+endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-russian),)
+       PKG_SELECTED_MODULES+=i18n/russian
+endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-portuguese_brazilian),)
+       PKG_SELECTED_MODULES+=i18n/portuguese_brazilian
+endif
 
 
 MAKE_FLAGS += \
        MODULES="$(PKG_SELECTED_MODULES)" \
        LUA_TARGET="$(LUA_TARGET)" \
-       LUA_SHLIBS="-llua -lm" \
+       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
        CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
        LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
        OS="Linux"
@@ -708,24 +929,24 @@ $(eval $(call BuildPackage,luci-cbi))
 $(eval $(call BuildPackage,luci-fastindex))
 $(eval $(call BuildPackage,luci-http))
 $(eval $(call BuildPackage,luci-ipkg))
+$(eval $(call BuildPackage,luci-json))
 $(eval $(call BuildPackage,luci-uci))
 $(eval $(call BuildPackage,luci-sys))
 $(eval $(call BuildPackage,luci-web))
+$(eval $(call BuildPackage,luci-uvl))
 
 $(eval $(call BuildPackage,luci-httpd))
 
-$(eval $(call BuildPackage,luci-ff-halle))
-$(eval $(call BuildPackage,luci-ff-leipzig))
-$(eval $(call BuildPackage,luci-ff-hannover))
-$(eval $(call BuildPackage,luci-ff-berlin))
-$(eval $(call BuildPackage,luci-ff-augsburg))
-
 $(eval $(call BuildPackage,luci-admin-core))
 $(eval $(call BuildPackage,luci-admin-mini))
 $(eval $(call BuildPackage,luci-admin-full))
+$(eval $(call BuildPackage,luci-admin-rpc))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
+$(eval $(call BuildPackage,luci-freifunk-community))
+
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
+$(eval $(call BuildPackage,luci-app-siitwizard))
 $(eval $(call BuildPackage,luci-app-firewall))
 $(eval $(call BuildPackage,luci-app-olsr))
 $(eval $(call BuildPackage,luci-app-qos))
@@ -735,15 +956,32 @@ $(eval $(call BuildPackage,luci-app-upnp))
 $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
+$(eval $(call BuildPackage,luci-app-uvc_streamer))
+$(eval $(call BuildPackage,luci-app-mmc_over_gpio))
+$(eval $(call BuildPackage,luci-app-p910nd))
+$(eval $(call BuildPackage,luci-app-ushare))
+$(eval $(call BuildPackage,luci-app-hd_idle))
+$(eval $(call BuildPackage,luci-app-tinyproxy))
+$(eval $(call BuildPackage,luci-app-initmgr))
+$(eval $(call BuildPackage,luci-app-livestats))
+$(eval $(call BuildPackage,luci-app-asterisk))
+$(eval $(call BuildPackage,luci-app-polipo))
+$(eval $(call BuildPackage,luci-app-openvpn))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))
 $(eval $(call BuildPackage,luci-sgi-webuci))
 
+$(eval $(call BuildPackage,luci-theme-base))
 $(eval $(call BuildPackage,luci-theme-fledermaus))
+$(eval $(call BuildPackage,luci-theme-freifunk))
+$(eval $(call BuildPackage,luci-theme-freifunk-bno))
 $(eval $(call BuildPackage,luci-theme-openwrt))
 $(eval $(call BuildPackage,luci-theme-openwrtlight))
 
 $(eval $(call BuildPackage,luci-i18n-german))
 $(eval $(call BuildPackage,luci-i18n-english))
 $(eval $(call BuildPackage,luci-i18n-french))
+$(eval $(call BuildPackage,luci-i18n-italian))
+$(eval $(call BuildPackage,luci-i18n-russian))
+$(eval $(call BuildPackage,luci-i18n-portuguese_brazilian))