contrib/package: switch to olsrd dyn_gw_plain plugin and enable it by default
[project/luci.git] / contrib / package / luci / Makefile
index 60f1190..82921c8 100644 (file)
@@ -61,13 +61,13 @@ endef
 
 define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Freifunk Support (GERMAN ONLY)
+  SUBMENU:=LuCI Freifunk Support
   DEPENDS:=+luci-mod-freifunk
 endef
 
 define Package/luci/httpdtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
+  SUBMENU:=LuCIttpd
   DEPENDS:=+luci-httpd
 endef
 
@@ -106,6 +106,11 @@ endef
 
 define Package/luci-core/install
        $(call Package/luci/install/template,$(1),libs/core)
+       $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
+               "OpenWrt Firmware" \
+               "$(OPENWRTVERSION)" \
+               "$(PKG_BRANCH)" \
+               "$(PKG_VERSION)"
 endef
 
 define Package/luci-core/config
@@ -211,6 +216,7 @@ define Package/luci-web
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-http +luci-sys +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
+  $(call Config,luci.main.lang,string,en,Default Language)
 endef
 
 define Package/luci-web/conffiles
@@ -238,12 +244,12 @@ endef
 
 define Package/luci-httpd
   $(call Package/luci/httpdtemplate)
-  DEPENDS:=+luci-http +luasocket
+  DEPENDS:=+luci-http +libuci
   TITLE:=Server Core
 endef
 
 define Package/luci-httpd/install
-       $(call Package/luci/install/template,$(1),libs/httpd)
+       $(call Package/luci/install/template,$(1),libs/lucittpd)
 endef
 
 
@@ -253,12 +259,14 @@ endef
 define Package/luci-freifunk-community
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
+   +luci-sgi-cgi +luci-app-splash \
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
-   +olsrd-luci +olsrd-luci-mod-dyn-gw +olsrd-luci-mod-txtinfo +olsrd-luci-mod-nameservice \
-   +kmod-tun +ip
+   +PACKAGE_luci-freifunk-community:olsrd-luci +PACKAGE_luci-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
+   +PACKAGE_luci-freifunk-community:olsrd-luci-mod-txtinfo +PACKAGE_luci-freifunk-community:olsrd-luci-mod-nameservice \
+   +PACKAGE_luci-freifunk-community:kmod-tun +PACKAGE_luci-freifunk-community:ip \
+   +luci-app-olsr
   TITLE:=Freifunk Community Meta-Package
 endef
 
@@ -281,6 +289,7 @@ endef
 
 define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
+       touch $(1)/etc/init.d/luci_fixtime || true
 endef
 
 
@@ -319,7 +328,7 @@ endef
 
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-admin-full
+  DEPENDS:=+luci-admin-full +luci-json
   TITLE:=LuCI Freifunk module
 endef
 
@@ -345,9 +354,20 @@ define Package/luci-app-ffwizard-leipzig/install
 endef
 
 
+define Package/luci-app-siitwizard
+  $(call Package/luci/fftemplate)
+  TITLE:=SIIT IPv4-over-IPv6 configuration wizard
+  DEPENDS:=+luci-admin-core +PACKAGE_luci-app-siitwizard:kmod-siit
+endef
+
+define Package/luci-app-siitwizard/install
+       $(call Package/luci/install/template,$(1),applications/luci-siitwizard)
+endef
+
+
 define Package/luci-app-firewall
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-firewall:firewall
   TITLE:=Firewall and Portforwarding application
 endef
 
@@ -358,7 +378,7 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +olsrd-luci +olsrd-luci-mod-txtinfo
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-olsr:olsrd-luci +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -369,7 +389,7 @@ endef
 
 define Package/luci-app-qos
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +qos-scripts
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-qos:qos-scripts
   TITLE:=Quality of Service configuration module
 endef
 
@@ -380,7 +400,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luasocket
+  DEPENDS+=+PACKAGE_luci-app-splash:luasocket
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -395,7 +415,8 @@ endef
 
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +collectd +collectd-mod-rrdtool1 +rrdtool1
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-statistics:collectd \
+   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 +PACKAGE_luci-app-statistics:rrdtool1
   TITLE:=LuCI Statistics Application
 endef
 
@@ -410,7 +431,7 @@ endef
 
 define Package/luci-app-upnp
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +miniupnpd
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-upnp:miniupnpd
   TITLE:=Universal Plug & Play configuration module
 endef
 
@@ -421,7 +442,7 @@ endef
 
 define Package/luci-app-ntpc
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +ntpclient
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-ntpc:ntpclient
   TITLE:=NTP time synchronisation client configuration module
 endef
 
@@ -432,7 +453,7 @@ endef
 
 define Package/luci-app-ddns
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core +ddns-scripts
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-ddns:ddns-scripts
   TITLE:=Dynamic DNS configuration module
 endef
 
@@ -443,7 +464,7 @@ endef
 
 define Package/luci-app-samba
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +samba3
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-samba:samba3
   TITLE:=Network Shares - Samba SMB/CIFS module
 endef
 
@@ -454,7 +475,7 @@ endef
 
 define Package/luci-app-uvc_streamer
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +uvc-streamer
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-uvc_streamer:uvc-streamer
   TITLE:=Webcam Streaming - UVC-Streamer module
 endef
 
@@ -463,9 +484,20 @@ define Package/luci-app-uvc_streamer/install
 endef
 
 
+define Package/luci-app-mmc_over_gpio
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-mmc_over_gpio:kmod-mmc-over-gpio
+  TITLE:=mmc_over_gpio
+endef
+
+define Package/luci-app-mmc_over_gpio/install
+        $(call Package/luci/install/template,$(1),applications/luci-mmc_over_gpio)
+endef
+
+
 define Package/luci-app-p910nd
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +p910nd
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-p910nd:p910nd
   TITLE:=p910nd - Printer server module
 endef
 
@@ -476,7 +508,7 @@ endef
 
 define Package/luci-app-ushare
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +ushare
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-ushare:ushare
   TITLE:=ushare - UPnP A/V & DLNA Media Server
 endef
 
@@ -486,7 +518,7 @@ endef
 
 define Package/luci-app-hd_idle
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +hd-idle
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-hd_idle:hd-idle
   TITLE:=hd-idle
 endef
 
@@ -496,7 +528,7 @@ endef
 
 define Package/luci-app-tinyproxy
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +tinyproxy
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy
   TITLE:=Tinyproxy - HTTP(S)-Proxy
 endef
 
@@ -516,8 +548,8 @@ endef
 
 define Package/luci-app-livestats
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +luci-admin-rpc
-  TITLE:=LuCI Realtime Statistics (Experimental)
+  DEPENDS+=+luci-admin-core +luci-admin-rpc
+  TITLE:=LuCI Realtime Statistics
 endef
 
 define Package/luci-app-livestats/install
@@ -526,13 +558,34 @@ endef
 
 define Package/luci-app-asterisk
   $(call Package/luci/webtemplate)
-  TITLE:=LuCI Support for Asterisk PBX (Incomplete)
+  TITLE:=LuCI Support for Asterisk PBX
+  DEPENDS+=@BROKEN +luci-admin-core +PACKAGE_luci-app-asterisk:asterisk14-xip-core
 endef
 
 define Package/luci-app-asterisk/install
         $(call Package/luci/install/template,$(1),applications/luci-asterisk)
 endef
 
+define Package/luci-app-polipo
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for the Polipo Proxy
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-polipo:polipo
+endef
+
+define Package/luci-app-polipo/install
+        $(call Package/luci/install/template,$(1),applications/luci-polipo)
+endef
+
+define Package/luci-app-openvpn
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for OpenVPN
+  DEPENDS+=@BROKEN +luci-admin-core +PACKAGE_luci-app-openvpn:openvpn
+endef
+
+define Package/luci-app-openvpn/install
+        $(call Package/luci/install/template,$(1),applications/luci-openvpn)
+endef
+
 
 ### Server Gateway Interfaces ###
 
@@ -548,7 +601,7 @@ endef
 define Package/luci-sgi-luci
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-httpd
-  TITLE:=SGI for LuCI HTTPD
+  TITLE:=SGI for LuCIttpd
 endef
 
 define Package/luci-sgi-luci/install
@@ -586,7 +639,7 @@ define Package/luci-theme-fledermaus/install
 endef
 
 define Package/luci-theme-freifunk
-  $(call Package/luci/thtemplate)
+  $(call Package/luci/fftemplate)
   DEPENDS:=+luci-web
   MAINTAINER:=Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>
   TITLE:=alternative Freifunk Theme
@@ -597,7 +650,7 @@ define Package/luci-theme-freifunk/install
 endef
 
 define Package/luci-theme-freifunk-bno
-  $(call Package/luci/thtemplate)
+  $(call Package/luci/fftemplate)
   DEPENDS:=+luci-web
   MAINTAINER:=Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>
   TITLE:=Freifunk Berlin Nordost Theme
@@ -659,6 +712,16 @@ define Package/luci-i18n-french/install
 endef
 
 
+define Package/luci-i18n-italian
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Italian (by Matteo Croce)
+endef
+
+define Package/luci-i18n-italian/install
+       $(call Package/luci/install/template,$(1),i18n/italian)
+endef
+
+
 define Package/luci-i18n-russian
   $(call Package/luci/i18ntemplate)
   TITLE:=Russian (by Skryabin Dmitry)
@@ -712,7 +775,7 @@ ifneq ($(CONFIG_PACKAGE_luci-uvl),)
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-httpd),)
-       PKG_SELECTED_MODULES+=libs/httpd
+       PKG_SELECTED_MODULES+=libs/lucittpd
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-admin-core),)
@@ -738,6 +801,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-ffwizard-leipzig),)
        PKG_SELECTED_MODULES+=applications/luci-ffwizard-leipzig
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-siitwizard),)
+       PKG_SELECTED_MODULES+=applications/luci-siitwizard
+endif
 ifneq ($(CONFIG_PACKAGE_luci-app-firewall),)
        PKG_SELECTED_MODULES+=applications/luci-fw
 endif
@@ -768,6 +834,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
        PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-mmc_over_gpio),)
+        PKG_SELECTED_MODULES+=applications/luci-mmc_over_gpio
+endif
 ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
         PKG_SELECTED_MODULES+=applications/luci-p910nd
 endif
@@ -789,6 +858,12 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-asterisk),)
        PKG_SELECTED_MODULES+=applications/luci-asterisk
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-polipo),)
+       PKG_SELECTED_MODULES+=applications/luci-polipo
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-openvpn),)
+       PKG_SELECTED_MODULES+=applications/luci-openvpn
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -829,6 +904,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-french),)
        PKG_SELECTED_MODULES+=i18n/french
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-italian),)
+       PKG_SELECTED_MODULES+=i18n/italian
+endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-russian),)
        PKG_SELECTED_MODULES+=i18n/russian
 endif
@@ -840,7 +918,7 @@ endif
 MAKE_FLAGS += \
        MODULES="$(PKG_SELECTED_MODULES)" \
        LUA_TARGET="$(LUA_TARGET)" \
-       LUA_SHLIBS="-llua -lm" \
+       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
        CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
        LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
        OS="Linux"
@@ -868,6 +946,7 @@ $(eval $(call BuildPackage,luci-mod-freifunk))
 $(eval $(call BuildPackage,luci-freifunk-community))
 
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
+$(eval $(call BuildPackage,luci-app-siitwizard))
 $(eval $(call BuildPackage,luci-app-firewall))
 $(eval $(call BuildPackage,luci-app-olsr))
 $(eval $(call BuildPackage,luci-app-qos))
@@ -878,6 +957,7 @@ $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
 $(eval $(call BuildPackage,luci-app-uvc_streamer))
+$(eval $(call BuildPackage,luci-app-mmc_over_gpio))
 $(eval $(call BuildPackage,luci-app-p910nd))
 $(eval $(call BuildPackage,luci-app-ushare))
 $(eval $(call BuildPackage,luci-app-hd_idle))
@@ -885,6 +965,8 @@ $(eval $(call BuildPackage,luci-app-tinyproxy))
 $(eval $(call BuildPackage,luci-app-initmgr))
 $(eval $(call BuildPackage,luci-app-livestats))
 $(eval $(call BuildPackage,luci-app-asterisk))
+$(eval $(call BuildPackage,luci-app-polipo))
+$(eval $(call BuildPackage,luci-app-openvpn))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))
@@ -900,5 +982,6 @@ $(eval $(call BuildPackage,luci-theme-openwrtlight))
 $(eval $(call BuildPackage,luci-i18n-german))
 $(eval $(call BuildPackage,luci-i18n-english))
 $(eval $(call BuildPackage,luci-i18n-french))
+$(eval $(call BuildPackage,luci-i18n-italian))
 $(eval $(call BuildPackage,luci-i18n-russian))
 $(eval $(call BuildPackage,luci-i18n-portuguese_brazilian))