contrib/package: make sgi-uhttpd and uhttpd tls support optional
[project/luci.git] / contrib / package / luci / Makefile
index a598d98..6229646 100644 (file)
@@ -275,7 +275,7 @@ endef
 
 
 
-NIXIO_TLS:=axtls
+NIXIO_TLS:=
 
 define Package/luci-nixio
   $(call Package/luci/libtemplate)
@@ -290,7 +290,10 @@ endef
 define Package/luci-nixio/config
        choice
                prompt "TLS Provider"
-               default PACKAGE_luci-nixio_axtls
+               default PACKAGE_luci-nixio_notls
+
+               config PACKAGE_luci-nixio_notls
+                       bool "Disabled"
 
                config PACKAGE_luci-nixio_axtls
                        bool "Builtin (axTLS)"
@@ -305,6 +308,10 @@ define Package/luci-nixio/config
        endchoice
 endef
 
+ifneq ($(CONFIG_PACKAGE_luci-nixio_axtls),)
+  NIXIO_TLS:=axtls
+endif
+
 ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
   NIXIO_TLS:=openssl
 endif
@@ -340,7 +347,7 @@ endef
 define Package/luci-web
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-http +luci-sys +luci-nixio +luci-uci \
-       +luci-sgi-cgi +luci-sgi-uhttpd +luci-lmo
+       +luci-sgi-cgi +luci-lmo
   TITLE:=MVC Webframework
   $(call Config,luci.main.lang,string,auto,Default Language)
 endef
@@ -775,7 +782,7 @@ endef
 define Package/luci-sgi-uhttpd
   $(call Package/luci/webservertemplate)
   TITLE:=Binding for the uHTTPd server
-  DEPENDS+=+uhttpd +px5g
+  DEPENDS+=+uhttpd +uhttpd-mod-lua
 endef
 
 define Package/luci-sgi-uhttpd/install
@@ -786,7 +793,7 @@ endef
 ### Themes ###
 define Package/luci-theme-base
   $(call Package/luci/thtemplate)
-  DEPENDS:=+luci-web
+  DEPENDS:=
   TITLE:=Common base for all themes
 endef