contrib, build: bundle LuaSrcDiet and make it available in build targets
[project/luci.git] / contrib / package / luci / Makefile
index c4b27ef..45039a1 100644 (file)
@@ -9,6 +9,8 @@ endif
 PKG_NAME:=luci
 PKG_RELEASE:=1
 
+PKG_BUILD_PARALLEL:=0
+
 ifeq ($(USELOCAL),1)
   PKG_VERSION:=0.10+svn
 else
@@ -29,14 +31,13 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 LUA_TARGET:=source
 LUCI_CFLAGS:=
-PKG_SELECTED_MODULES:=
+LUCI_BUILD_PACKAGES:=
+LUCI_SELECTED_MODULES:=
 
 ifeq ($(BOARD),brcm-2.4)
   MAKE_FLAGS += CRAP="1"
 endif
 
-BUILD_PACKAGES:=
-
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -55,7 +56,7 @@ define Build/Configure
 endef
 
 MAKE_FLAGS += \
-       MODULES="$(PKG_SELECTED_MODULES)" \
+       MODULES="$(LUCI_SELECTED_MODULES)" \
        LUA_TARGET="$(LUA_TARGET)" \
        LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
        CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
@@ -64,71 +65,25 @@ MAKE_FLAGS += \
 
 
 ### Templates ###
-
-define Package/luci/libtemplate
-  SECTION:=luci
-  CATEGORY:=LuCI
-  TITLE:=LuCI - Lua Configuration Interface
-  URL:=http://luci.freifunk-halle.net/
-  MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
-  SUBMENU:=Internal Libraries
-  DEPENDS:=+luci-core
-endef
-
-define Package/luci/webservertemplate
-  $(call Package/luci/libtemplate)
-  SUBMENU:=Webserver
-endef
-
-define Package/luci/fftemplate
-  $(call Package/luci/libtemplate)
-  SUBMENU:=Freifunk
-  DEPENDS:=+luci-mod-freifunk
-endef
-
-define Package/luci/i18ntemplate
-  $(call Package/luci/libtemplate)
-  SUBMENU:=Translations
-  DEPENDS:=+luci-web
-endef
-
-define Package/luci/thtemplate
-  $(call Package/luci/libtemplate)
-  SUBMENU:=Themes
-  DEPENDS:=+luci-web
-endef
-
-define Package/luci/maintemplate
-  $(call Package/luci/libtemplate)
-  SUBMENU:=
-endef
-
-define Package/luci/webtemplate
-  $(call Package/luci/libtemplate)
-  SUBMENU:=Components
-endef
-
-define Package/luci/collectiontemplate
-  $(call Package/luci/libtemplate)
-  SUBMENU:=Collections
-endef
-
-
 define Package/luci/install/template
        $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
        $(CP) -a $(PKG_BUILD_DIR)/$(2)/ipkg/* $(1)/CONTROL/ 2>/dev/null || true
 endef
 
 
-
 ### Core package ###
-define Package/luci-core
-  $(call Package/luci/libtemplate)
-  DEPENDS:=+lua +luci-nixio
+define Package/luci-lib-core
+  SECTION:=luci
+  CATEGORY:=LuCI
+  TITLE:=LuCI - Lua Configuration Interface
+  URL:=http://luci.subsignal.org/
+  MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+  SUBMENU:=Libraries
+  DEPENDS:=+lua +libuci-lua
   TITLE:=LuCI core libraries
 endef
 
-define Package/luci-core/install
+define Package/luci-lib-core/install
        $(call Package/luci/install/template,$(1),libs/core)
        $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
                "OpenWrt Firmware" \
@@ -137,86 +92,90 @@ define Package/luci-core/install
                "$(PKG_VERSION)"
 endef
 
-define Package/luci-core/config
+define Package/luci-lib-core/config
        choice
                prompt "Build Target"
-               default PACKAGE_luci-core_source
+               default PACKAGE_luci-lib-core_source
 
-       config PACKAGE_luci-core_compile
+       config PACKAGE_luci-lib-core_compile
                bool "Precompiled"
 
-       config PACKAGE_luci-core_stripped
+       config PACKAGE_luci-lib-core_stripped
                bool "Stripped"
 
-       config PACKAGE_luci-core_source
+       config PACKAGE_luci-lib-core_srcdiet
+               bool "Compressed Source"
+
+       config PACKAGE_luci-lib-core_source
                bool "Full Source"
 
        endchoice
 endef
 
-ifneq ($(CONFIG_PACKAGE_luci-core_compile),)
+ifneq ($(CONFIG_PACKAGE_luci-lib-core_compile),)
   LUA_TARGET:=compile
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-core_stripped),)
+ifneq ($(CONFIG_PACKAGE_luci-lib-core_stripped),)
   LUA_TARGET:=strip
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-core_zipped),)
-  LUA_TARGET:=gzip
+ifneq ($(CONFIG_PACKAGE_luci-lib-core_srcdiet),)
+  LUA_TARGET:=diet
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-core),)
-  PKG_SELECTED_MODULES+=libs/core
+ifneq ($(CONFIG_PACKAGE_luci-lib-core),)
+  LUCI_SELECTED_MODULES+=libs/core
 endif
 
-BUILD_PACKAGES += luci-core
+LUCI_BUILD_PACKAGES += luci-lib-core
 
 
 ### Libraries ###
 define library
-  define Package/luci-$(1)
-    $(call Package/luci/libtemplate)
+  define Package/luci-lib-$(1)
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+    SUBMENU:=Libraries
     TITLE:=$(if $(2),$(2),LuCI $(1) library)
-    $(if $(3),DEPENDS:=$(3))
+    $(if $(3),DEPENDS:=+luci-lib-core $(3))
   endef
 
-  define Package/luci-$(1)/install
+  define Package/luci-lib-$(1)/install
        $(call Package/luci/install/template,$$(1),libs/$(1))
-       $(call Package/luci-$(1)/extra-install)
+       $(call Package/luci-lib-$(1)/extra-install)
   endef
 
-  ifneq ($(CONFIG_PACKAGE_luci-$(1)),)
-    PKG_SELECTED_MODULES+=libs/$(1)
+  ifneq ($(CONFIG_PACKAGE_luci-lib-$(1)),)
+    LUCI_SELECTED_MODULES+=libs/$(1)
   endif
 
-  BUILD_PACKAGES += luci-$(1)
+  LUCI_BUILD_PACKAGES += luci-lib-$(1)
 endef
 
-define Package/luci-lucid/extra-install
-       $(call Package/luci/install/template,$(1),libs/lucid-http)
-endef
-
-define Package/luci-web/conffiles
+define Package/luci-lib-web/conffiles
 /etc/config/luci
 endef
 
-define Package/luci-nixio/config
+define Package/luci-lib-nixio/config
        choice
                prompt "TLS Provider"
-               default PACKAGE_luci-nixio_notls
+               default PACKAGE_luci-lib-nixio_notls
 
-               config PACKAGE_luci-nixio_notls
+               config PACKAGE_luci-lib-nixio_notls
                        bool "Disabled"
 
-               config PACKAGE_luci-nixio_axtls
+               config PACKAGE_luci-lib-nixio_axtls
                        bool "Builtin (axTLS)"
 
-               config PACKAGE_luci-nixio_cyassl
+               config PACKAGE_luci-lib-nixio_cyassl
                        bool "CyaSSL"
                        select PACKAGE_libcyassl
 
-               config PACKAGE_luci-nixio_openssl
+               config PACKAGE_luci-lib-nixio_openssl
                        bool "OpenSSL"
                        select PACKAGE_libopenssl
        endchoice
@@ -225,81 +184,91 @@ endef
 
 NIXIO_TLS:=
 
-ifneq ($(CONFIG_PACKAGE_luci-nixio_axtls),)
+ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_axtls),)
   NIXIO_TLS:=axtls
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
+ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_openssl),)
   NIXIO_TLS:=openssl
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-nixio_cyassl),)
+ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_cyassl),)
   NIXIO_TLS:=cyassl
   LUCI_CFLAGS+=-I$(STAGING_DIR)/usr/include/cyassl
 endif
 
 
 $(eval $(call library,fastindex,Fastindex indexing module))
-$(eval $(call library,httpclient,HTTP(S) client library,+luci-web +luci-nixio))
+$(eval $(call library,httpclient,HTTP(S) client library,+luci-lib-web +luci-lib-nixio))
 $(eval $(call library,ipkg,LuCI IPKG/OPKG call abstraction library))
 $(eval $(call library,json,LuCI JSON library))
 $(eval $(call library,lmo,LuCI LMO I18N library))
-$(eval $(call library,luanet,LuCI luanet library,+libiw))
-$(eval $(call library,lucid,LuCId Full-Stack Webserver,+luci-nixio +luci-web +luci-px5g))
-$(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-nixio_openssl:libopenssl +PACKAGE_luci-nixio_cyassl:libcyassl))
-$(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-nixio))
-$(eval $(call library,sys,LuCI Linux/POSIX system library,+libiwinfo))
-$(eval $(call library,web,MVC Webframework,+luci-sys +luci-nixio +luci-core +luci-sgi-cgi +luci-lmo))
-$(eval $(call library,uvl,UVL - UCI Validation Layer,+luci-sys +luci-core))
+$(eval $(call library,lucid,LuCId Full-Stack Webserver,+luci-lib-nixio +luci-lib-web +luci-lib-px5g))
+$(eval $(call library,lucid-http,LuCId HTTP Backend,+luci-lib-lucid))
+$(eval $(call library,lucid-rpc,LuCId RPC Backend,+luci-lib-lucid))
+$(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl))
+$(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
+$(eval $(call library,sys,LuCI Linux/POSIX system library))
+$(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi +luci-lib-lmo))
 
 
 ### Community Packages ###
-define Package/luci-freifunk-community
-  $(call Package/luci/fftemplate)
+define Package/luci-mod-freifunk-community
+  SECTION:=luci
+  CATEGORY:=LuCI
+  TITLE:=LuCI - Lua Configuration Interface
+  URL:=http://luci.subsignal.org/
+  MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+  SUBMENU:=Freifunk
   TITLE:=Freifunk Community Meta-Package
   DEPENDS+= \
-   +luci-web +luci-app-splash \
+   +luci-lib-web +luci-app-splash \
    +luci-app-ffwizard-leipzig \
    +luci-i18n-german \
-   +PACKAGE_luci-freifunk-community:olsrd-luci +PACKAGE_luci-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
-   +PACKAGE_luci-freifunk-community:olsrd-luci-mod-txtinfo +PACKAGE_luci-freifunk-community:olsrd-luci-mod-nameservice \
-   +PACKAGE_luci-freifunk-community:olsrd-luci-mod-watchdog +PACKAGE_luci-freifunk-community:kmod-tun \
-   +PACKAGE_luci-freifunk-community:ip +PACKAGE_luci-freifunk-community:freifunk-watchdog +luci-app-olsr
+   +PACKAGE_luci-mod-freifunk-community:olsrd +PACKAGE_luci-mod-freifunk-community:olsrd-mod-dyn-gw-plain \
+   +PACKAGE_luci-mod-freifunk-community:olsrd-mod-txtinfo +PACKAGE_luci-mod-freifunk-community:olsrd-mod-nameservice \
+   +PACKAGE_luci-mod-freifunk-community:olsrd-mod-watchdog +PACKAGE_luci-mod-freifunk-community:kmod-tun \
+   +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr
 endef
 
-define Package/luci-freifunk-community/install
+define Package/luci-mod-freifunk-community/install
        $(call Package/luci/install/template,$(1),applications/freifunk-community)
 endef
 
-ifneq ($(CONFIG_PACKAGE_luci-freifunk-community),)
-       PKG_SELECTED_MODULES+=applications/freifunk-community
+ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk-community),)
+       LUCI_SELECTED_MODULES+=applications/freifunk-community
 endif
 
-BUILD_PACKAGES += luci-freifunk-community
+LUCI_BUILD_PACKAGES += luci-mod-freifunk-community
 
 
 ### Modules ###
 define module
-  define Package/luci-$(1)
-    $(call Package/luci/webtemplate)
-    TITLE:=$(if $(2),$(2),LuCI luci-$(1) module)
+  define Package/luci-mod-$(1)
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+    SUBMENU:=Modules
+    TITLE:=$(if $(2),$(2),LuCI $(1) module)
     $(if $(3),DEPENDS+=$(3))
   endef
 
-  define Package/luci-$(1)/install
-       $(call Package/luci/install/template,$$(1),modules/admin-core)
-       $(call Package/luci-$(1)/extra-install)
+  define Package/luci-mod-$(1)/install
+       $(call Package/luci/install/template,$$(1),modules/$(1))
+       $(call Package/luci-mod-$(1)/extra-install)
   endef
 
-  ifneq ($(CONFIG_PACKAGE_luci-$(1)),)
-    PKG_SELECTED_MODULES+=modules/$(1)
+  ifneq ($(CONFIG_PACKAGE_luci-mod-$(1)),)
+    LUCI_SELECTED_MODULES+=modules/$(1)
   endif
 
-  BUILD_PACKAGES += luci-$(1)
+  LUCI_BUILD_PACKAGES += luci-mod-$(1)
 endef
 
 
-define Package/luci-admin-core/extra-install
+define Package/luci-mod-admin-core/extra-install
        touch $(1)/etc/init.d/luci_fixtime || true
 endef
 
@@ -307,21 +276,25 @@ define Package/luci-mod-freifunk/conffiles
 /etc/config/freifunk
 endef
 
-$(eval $(call module,admin-core,Web UI Core module,+luci-web +luci-i18n-english))
-$(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendly,+luci-admin-core))
-$(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-admin-core +luci-ipkg))
-$(eval $(call module,admin-rpc,LuCI RPC - JSON-RPC API,+luci-json))
-$(eval $(call module,mod-freifunk,LuCI Freifunk module,+luci-admin-full +luci-json +PACKAGE_luci-mod-freifunk:freifunk-firewall))
-
-$(eval $(call module,niu,NIU - Next Generation Interface,+luci-admin-core @BROKEN))
+$(eval $(call module,admin-core,Web UI Core module,+luci-lib-web +luci-i18n-english))
+$(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendly,+luci-mod-admin-core @BROKEN))
+$(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-mod-admin-core +luci-lib-ipkg))
+$(eval $(call module,rpc,LuCI RPC - JSON-RPC API,+luci-lib-json))
+$(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall))
+$(eval $(call module,niu,NIU - Next Generation Interface,+luci-mod-admin-core @BROKEN))
 
 
 ### Applications ###
 define application
   define Package/luci-app-$(1)
-    $(call Package/luci/webtemplate)
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+    SUBMENU:=Applications
     TITLE:=$(if $(2),$(2),LuCI $(1) application)
-       $(if $(3),DEPENDS:=$(3))
+       DEPENDS:=+luci-mod-admin-core $(3)
   endef
 
   define Package/luci-app-$(1)/install
@@ -329,14 +302,15 @@ define application
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-app-$(1)),)
-    PKG_SELECTED_MODULES+=applications/luci-$(1)
+    LUCI_SELECTED_MODULES+=applications/luci-$(1)
   endif
 
-  BUILD_PACKAGES += luci-app-$(1)
+  LUCI_BUILD_PACKAGES += luci-app-$(1)
 endef
 
 define Package/luci-app-splash/conffiles
 /etc/config/luci_splash
+/usr/lib/luci-splash/splashtext.html
 endef
 
 define Package/luci-app-statistics/conffiles
@@ -350,25 +324,31 @@ endef
 
 $(eval $(call application,ffwizard-leipzig,Freifunk Leipzig configuration wizard))
 
+$(eval $(call application,ffwizard,Freifunk configuration wizard,\
+       +luci-mod-freifunk))
+
 $(eval $(call application,siitwizard,SIIT IPv4-over-IPv6 configuration wizard,\
-       +luci-admin-core +PACKAGE_luci-app-siitwizard:kmod-siit))
+       +PACKAGE_luci-app-siitwizard:kmod-siit))
 
 $(eval $(call application,firewall,Firmware and Portforwarding application,\
-       +luci-admin-core +PACKAGE_luci-app-firewall:firewall))
+       +PACKAGE_luci-app-firewall:firewall))
 
 $(eval $(call application,olsr,OLSR configuration and status module,\
-       +luci-admin-full +PACKAGE_luci-app-olsr:olsrd-luci +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo))
+       +luci-mod-admin-full +PACKAGE_luci-app-olsr:olsrd +PACKAGE_luci-app-olsr:olsrd-mod-txtinfo))
+
+$(eval $(call application,olsr-viz,OLSR Visualisation,\
+       +PACKAGE_luci-app-olsr-viz:luci-app-olsr +PACKAGE_luci-app-olsr-viz:olsrd-mod-txtinfo))
 
 $(eval $(call application,qos,Quality of Service configuration module,\
-       +luci-admin-core +PACKAGE_luci-app-qos:qos-scripts))
+       +PACKAGE_luci-app-qos:qos-scripts))
 
 $(eval $(call application,splash,Freifunk DHCP-Splash application,\
-       +PACKAGE_luci-app-splash:luci-nixio +PACKAGE_luci-app-splash:tc \
+       +luci-lib-nixio +PACKAGE_luci-app-splash:tc \
        +PACKAGE_luci-app-splash:kmod-sched +PACKAGE_luci-app-splash:iptables-mod-nat-extra \
        +PACKAGE_luci-app-splash:iptables-mod-ipopt))
 
 $(eval $(call application,statistics,LuCI Statistics Application,\
-       +luci-admin-full +PACKAGE_luci-app-statistics:collectd \
+       +luci-mod-admin-full +PACKAGE_luci-app-statistics:collectd \
        +PACKAGE_luci-app-statistics:rrdtool1 \
        +PACKAGE_luci-app-statistics:collectd-mod-rrdtool \
        +PACKAGE_luci-app-statistics:collectd-mod-wireless \
@@ -376,11 +356,10 @@ $(eval $(call application,statistics,LuCI Statistics Application,\
        +PACKAGE_luci-app-statistics:collectd-mod-load))
 
 
-$(eval $(call application,diag-core,LuCI Diagnostics Tools (Core),\
-       +luci-admin-core))
+$(eval $(call application,diag-core,LuCI Diagnostics Tools (Core)))
 
 $(eval $(call application,diag-devinfo,LuCI Diagnostics Tools (Device Info),\
-       +PACKAGE_luci-app-diag-devinfo:luci-app-diag-core \
+       +luci-app-diag-core \
        +PACKAGE_luci-app-diag-devinfo:smap \
        +PACKAGE_luci-app-diag-devinfo:netdiscover \
        +PACKAGE_luci-app-diag-devinfo:mac-to-devinfo \
@@ -388,74 +367,74 @@ $(eval $(call application,diag-devinfo,LuCI Diagnostics Tools (Device Info),\
        +PACKAGE_luci-app-diag-devinfo:smap-to-devinfo \
        +PACKAGE_luci-app-diag-devinfo:netdiscover-to-devinfo))
 
-$(eval $(call application,voice-core,LuCI Voice Software (Core),\
-       +luci-admin-core))
-
-$(eval $(call application,voide-diag,LuCI Voice Software (Diagnostics),\
-       +PACKAGE_luci-app-voice-diag:luci-app-voice-core \
-    +PACKAGE_luci-app-voice-diag:luci-app-diag-devinfo))
+$(eval $(call application,voice-core,LuCI Voice Software (Core)))
 
+$(eval $(call application,voice-diag,LuCI Voice Software (Diagnostics),\
+       +luci-app-voice-core +luci-app-diag-devinfo))
 
 $(eval $(call application,upnp,Universal Plug & Play configuration module,\
-       +luci-admin-core +PACKAGE_luci-app-upnp:miniupnpd))
+       +PACKAGE_luci-app-upnp:miniupnpd))
 
 $(eval $(call application,ntpc,NTP time synchronisation configuration module,\
-       +luci-admin-core +PACKAGE_luci-app-ntpc:ntpclient))
+       +PACKAGE_luci-app-ntpc:ntpclient))
 
 $(eval $(call application,ddns,Dynamic DNS configuration module,\
-       +luci-admin-core +PACKAGE_luci-app-ddns:ddns-scripts))
+       +PACKAGE_luci-app-ddns:ddns-scripts))
 
 $(eval $(call application,samba,Network Shares - Samba SMB/CIFS module,\
-       +luci-admin-full +PACKAGE_luci-app-samba:samba3))
+       +luci-mod-admin-full +PACKAGE_luci-app-samba:samba3))
 
 $(eval $(call application,mmc-over-gpio,MMC-over-GPIO configuration module,\
-       +luci-admin-full +PACKAGE_luci-app-mmc-over-gpio:kmod-mmc-over-gpio))
+       +luci-mod-admin-full +PACKAGE_luci-app-mmc-over-gpio:kmod-mmc-over-gpio))
 
 $(eval $(call application,p910nd,p910nd - Printer server module,\
-       +luci-admin-full +PACKAGE_luci-app-p910nd:p910nd))
+       +luci-mod-admin-full +PACKAGE_luci-app-p910nd:p910nd))
 
 $(eval $(call application,ushare,uShare - UPnP A/V & DLNA Media Server,\
-       +luci-admin-full +PACKAGE_luci-app-ushare:ushare))
+       +luci-mod-admin-full +PACKAGE_luci-app-ushare:ushare))
 
 $(eval $(call application,hd-idle,Hard Disk Idle Spin-Down module,\
-       +luci-admin-full +PACKAGE_luci-app-hd-idle:hd-idle))
+       +luci-mod-admin-full +PACKAGE_luci-app-hd-idle:hd-idle))
 
 $(eval $(call application,tinyproxy,Tinyproxy - HTTP(S)-Proxy configuration,\
-       +luci-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy))
+       +luci-mod-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy))
 
 $(eval $(call application,initmgr,LuCI Initscript Management,\
-       +luci-admin-full))
-
-$(eval $(call application,livestats,LuCI Realtime Statistics,\
-       +luci-admin-core +luci-admin-rpc))
-
-$(eval $(call application,asterisk,LuCI Support for Asterisk PBX,\
-       @BROKEN +luci-admin-core +PACKAGE_luci-app-asterisk:asterisk14-xip-core))
+       +luci-mod-admin-full))
 
 $(eval $(call application,polipo,LuCI Support for the Polipo Proxy,\
-       +luci-admin-core +PACKAGE_luci-app-polipo:polipo))
+       +PACKAGE_luci-app-polipo:polipo))
 
 $(eval $(call application,openvpn,LuCI Support for OpenVPN,\
-       +luci-admin-core +PACKAGE_luci-app-openvpn:openvpn))
+       +PACKAGE_luci-app-openvpn:openvpn))
 
 $(eval $(call application,p2pblock,LuCI Support for the Freifunk P2P-Block addon,\
-       +luci-admin-core +luci-app-firewall +PACKAGE_luci-app-p2pblock:freifunk-p2pblock))
+       +luci-app-firewall +PACKAGE_luci-app-p2pblock:freifunk-p2pblock))
 
 $(eval $(call application,multiwan,LuCI Support for the OpenWrt MultiWAN agent,\
-       +luci-admin-core +luci-app-firewall +PACKAGE_luci-app-multiwan:multiwan))
+       +luci-app-firewall +PACKAGE_luci-app-multiwan:multiwan))
 
 $(eval $(call application,wol,LuCI Support for Wake-on-LAN,\
-       +luci-admin-core +PACKAGE_luci-app-wol:etherwake))
+       +PACKAGE_luci-app-wol:etherwake))
 
 $(eval $(call application,vnstat,LuCI Support for VnStat,\
-       +luci-admin-core +PACKAGE_luci-app-vnstat:vnstat \
+       +PACKAGE_luci-app-vnstat:vnstat \
     +PACKAGE_luci-app-vnstat:vnstati))
 
+$(eval $(call application,radvd,LuCI Support for Radvd,\
+       +luci-mod-admin-full +PACKAGE_luci-app-radvd:radvd))
+
+$(eval $(call application,lqtapifoss,Lantiq voip))
 
 ### Server Gateway Interfaces ###
 define sgi
   define Package/luci-sgi-$(1)
-    $(call Package/luci/webservertemplate)
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+    SUBMENU:=Server Interfaces
     TITLE:=$(if $(2),$(2),LuCI $(1) server gateway interface)
        $(if $(3),DEPENDS:=$(3))
   endef
@@ -465,10 +444,10 @@ define sgi
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-sgi-$(1)),)
-    PKG_SELECTED_MODULES+=libs/sgi-$(1)
+    LUCI_SELECTED_MODULES+=libs/sgi-$(1)
   endif
 
-  BUILD_PACKAGES += luci-sgi-$(1)
+  LUCI_BUILD_PACKAGES += luci-sgi-$(1)
 endef
 
 $(eval $(call sgi,cgi,CGI Gateway behind existing Webserver))
@@ -478,11 +457,15 @@ $(eval $(call sgi,uhttpd,Binding for the uHTTPd server,+uhttpd +uhttpd-mod-lua))
 ### Themes ###
 define theme
   define Package/luci-theme-$(1)
-    $(call Package/luci/thtemplate)
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    SUBMENU:=Themes
     TITLE:=$(if $(2),$(2),LuCI $(1) theme)
-       $(if $(3),MAINTAINER:=$(3))
-       $(if $(4),DEPENDS:=$(4))
-       $(if $(5),DEFAULT:=y if PACKAGE_luci-core)
+       MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
+       DEPENDS:=$(if $(filter-out base,$(1)),+luci-theme-base) $(4)
+       $(if $(5),DEFAULT:=PACKAGE_luci-lib-core)
   endef
 
   define Package/luci-theme-$(1)/install
@@ -490,39 +473,37 @@ define theme
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-theme-$(1)),)
-    PKG_SELECTED_MODULES+=themes/$(1)
+    LUCI_SELECTED_MODULES+=themes/$(1)
   endif
 
-  BUILD_PACKAGES += luci-theme-$(1)
+  LUCI_BUILD_PACKAGES += luci-theme-$(1)
 endef
 
-$(eval $(call theme,base,Common base for all themes,\
-       LuCI developers <luci-at-lists-dot-subsignal.org>))
-
-$(eval $(call theme,openwrt,OpenWrt.org (default),\
-       LuCI developers <luci-at-lists-dot-subsignal.org>,\
-       +luci-theme-base luci-core,1))
-
-$(eval $(call theme,openwrtlight,OpenWrt.org - light variant without images,\
-       LuCI developers <luci-at-lists-dot-subsignal.org>,+luci-theme-base))
-
-$(eval $(call theme,fledermaus,Fledermaus Theme,\
-       LuCI developers <luci-at-lists-dot-subsignal.org>,+luci-web))
+$(eval $(call theme,base,Common base for all themes,,+luci-lib-web))
+$(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
+$(eval $(call theme,fledermaus,Fledermaus Theme))
 
 $(eval $(call theme,freifunk,alternative Freifunk Theme,\
-       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>,+luci-web))
+       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
 
 $(eval $(call theme,freifunk-bno,Freifunk Berlin Nordost Theme,\
-       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>,+luci-web))
+       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
 
 $(eval $(call theme,freifunk-hannover,Freifunk Hannover Theme,\
-       Mikolas Bingemer <mickey-at-freifunk-hannover-dot-de>,+luci-web))
+       Mikolas Bingemer <mickey-at-freifunk-hannover-dot-de>))
 
+$(eval $(call theme,freifunk-generic,Freifunk Generic Theme,\
+        Manuel Munz <freifunk-at-somakoma-dot-de>))
 
 ### Translations ###
 define translation
   define Package/luci-i18n-$(1)
-    $(call Package/luci/i18ntemplate)
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+    SUBMENU:=Translations
     TITLE:=$(if $(2),$(2),$(1))
   endef
 
@@ -531,10 +512,10 @@ define translation
   endef
 
   ifneq ($(CONFIG_PACKAGE_luci-i18n-$(1)),)
-    PKG_SELECTED_MODULES+=i18n/$(1)
+    LUCI_SELECTED_MODULES+=i18n/$(1)
   endif
 
-  BUILD_PACKAGES += luci-i18n-$(1)
+  LUCI_BUILD_PACKAGES += luci-i18n-$(1)
 endef
 
 $(eval $(call translation,german,German))
@@ -555,36 +536,39 @@ $(eval $(call translation,norwegian,Norwegian (by Lars Hardy)))
 
 ### Collections ###
 define collection
-  define Package/$(1)
-    $(call Package/luci/collectiontemplate)
-    TITLE:=$(if $(2),$(2),LuCI $(1) collection)
+  define Package/luci$(if $(1),-$(1))
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+    SUBMENU:=Collections
+    TITLE:=$(if $(2),$(2),LuCI $(if $(1),$(1),general) collection)
     $(if $(3),DEPENDS:=$(3))
   endef
 
-  define Package/$(1)/install
+  define Package/luci$(if $(1),-$(1))/install
        true
   endef
 
-  BUILD_PACKAGES += $(1)
+  LUCI_BUILD_PACKAGES += luci$(if $(1),-$(1))
 endef
 
-$(eval $(call collection,luci,\
+$(eval $(call collection,,\
        Standard OpenWrt set including full and mini admin and the standard theme,\
-       +uhttpd +luci-admin-full +luci-admin-mini +luci-theme-openwrt \
-    +luci-app-firewall +luci-app-initmgr))
+       +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
+       +luci-app-initmgr +libiwinfo))
 
-$(eval $(call collection,luci-ssl,\
+$(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +uhttpd +uhttpd-mod-tls +px5g +luci-admin-full +luci-admin-mini \
-    +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr))
-
-$(eval $(call collection,luci-medium,\
-       Medium package set using only admin full and a theme without graphics,\
-       +uhttpd +luci-admin-full +luci-theme-openwrtlight))
+       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
+       +luci-app-firewall +luci-app-initmgr +libiwinfo))
 
-$(eval $(call collection,luci-light,\
-       Minimum package set using only admin mini and a theme without graphics,\
-       +uhttpd +luci-admin-mini +luci-theme-openwrtlight))
+$(eval $(call collection,light,\
+       Minimum package set using only admin mini and the standard theme,\
+       +uhttpd +luci-mod-admin-mini +luci-theme-openwrt @BROKEN))
 
 
-$(foreach b,$(BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))
+### Compile ###
+PKG_CONFIG_DEPENDS=$(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
+$(foreach b,$(LUCI_BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))