contrib: fix rebuild triggering by assembling PKG_CONFIG_DEPENDS before including...
[project/luci.git] / contrib / package / luci / Makefile
index 8d248b1..3641757 100644 (file)
@@ -39,31 +39,6 @@ ifeq ($(BOARD),brcm-2.4)
 endif
 
 
-include $(INCLUDE_DIR)/package.mk
-
-ifeq ($(USELOCAL),1)
-  define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(TAR) c -C ../../../ . \
-               --exclude=.pc --exclude=.svn --exclude=.git \
-               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
-               --exclude=dist | \
-                       tar x -C $(PKG_BUILD_DIR)/
-  endef
-endif
-
-define Build/Configure
-endef
-
-MAKE_FLAGS += \
-       MODULES="$(LUCI_SELECTED_MODULES)" \
-       LUA_TARGET="$(LUA_TARGET)" \
-       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
-       CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
-       NIXIO_TLS="$(NIXIO_TLS)" OS="Linux"
-
-
 ### Templates ###
 define Package/luci/install/template
        $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
@@ -103,6 +78,9 @@ define Package/luci-lib-core/config
        config PACKAGE_luci-lib-core_stripped
                bool "Stripped"
 
+       config PACKAGE_luci-lib-core_srcdiet
+               bool "Compressed Source"
+
        config PACKAGE_luci-lib-core_source
                bool "Full Source"
 
@@ -117,8 +95,8 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-core_stripped),)
   LUA_TARGET:=strip
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-lib-core_zipped),)
-  LUA_TARGET:=gzip
+ifneq ($(CONFIG_PACKAGE_luci-lib-core_srcdiet),)
+  LUA_TARGET:=diet
 endif
 
 ifneq ($(CONFIG_PACKAGE_luci-lib-core),)
@@ -207,7 +185,6 @@ $(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:
 $(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
 $(eval $(call library,sys,LuCI Linux/POSIX system library))
 $(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi +luci-lib-lmo))
-$(eval $(call library,uvl,UVL - UCI Validation Layer,+luci-lib-sys +luci-lib-core))
 
 
 ### Community Packages ###
@@ -221,12 +198,12 @@ define Package/luci-mod-freifunk-community
   TITLE:=Freifunk Community Meta-Package
   DEPENDS+= \
    +luci-lib-web +luci-app-splash \
-   +luci-app-ffwizard-leipzig \
+   +luci-app-ffwizard \
    +luci-i18n-german \
    +PACKAGE_luci-mod-freifunk-community:olsrd +PACKAGE_luci-mod-freifunk-community:olsrd-mod-dyn-gw-plain \
    +PACKAGE_luci-mod-freifunk-community:olsrd-mod-txtinfo +PACKAGE_luci-mod-freifunk-community:olsrd-mod-nameservice \
    +PACKAGE_luci-mod-freifunk-community:olsrd-mod-watchdog +PACKAGE_luci-mod-freifunk-community:kmod-tun \
-   +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr
+   +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr +luci-app-olsr-services
 endef
 
 define Package/luci-mod-freifunk-community/install
@@ -320,7 +297,8 @@ define Package/luci-app-diag-devinfo/conffiles
 endef
 
 
-$(eval $(call application,ffwizard-leipzig,Freifunk Leipzig configuration wizard))
+$(eval $(call application,ffwizard,Freifunk configuration wizard,\
+       +luci-mod-freifunk))
 
 $(eval $(call application,siitwizard,SIIT IPv4-over-IPv6 configuration wizard,\
        +PACKAGE_luci-app-siitwizard:kmod-siit))
@@ -334,6 +312,9 @@ $(eval $(call application,olsr,OLSR configuration and status module,\
 $(eval $(call application,olsr-viz,OLSR Visualisation,\
        +PACKAGE_luci-app-olsr-viz:luci-app-olsr +PACKAGE_luci-app-olsr-viz:olsrd-mod-txtinfo))
 
+$(eval $(call application,olsr-services,Show services announced with the nameservice plugin,\
+       +PACKAGE_luci-app-olsr-services:olsrd-mod-nameservice +luci-mod-freifunk +PACKAGE_luci-app-olsr-services:luci-app-olsr))
+
 $(eval $(call application,qos,Quality of Service configuration module,\
        +PACKAGE_luci-app-qos:qos-scripts))
 
@@ -566,4 +547,30 @@ $(eval $(call collection,light,\
 
 ### Compile ###
 PKG_CONFIG_DEPENDS=$(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
+
+include $(INCLUDE_DIR)/package.mk
+
+ifeq ($(USELOCAL),1)
+  define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(TAR) c -C ../../../ . \
+               --exclude=.pc --exclude=.svn --exclude=.git \
+               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
+               --exclude=dist | \
+                       tar x -C $(PKG_BUILD_DIR)/
+  endef
+endif
+
+define Build/Configure
+endef
+
+MAKE_FLAGS += \
+       MODULES="$(LUCI_SELECTED_MODULES)" \
+       LUA_TARGET="$(LUA_TARGET)" \
+       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
+       CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
+       NIXIO_TLS="$(NIXIO_TLS)" OS="Linux"
+
+
 $(foreach b,$(LUCI_BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))