contrib/package: add definition for Bootstrap theme
[project/luci.git] / contrib / package / luci / Makefile
index 2a15d5d..25a2304 100644 (file)
@@ -216,7 +216,7 @@ $(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA))
 $(eval $(call protocol,pptp,Support for PPtP,+pptp))
 $(eval $(call protocol,6x4,Support for 6in4/6to4,+6in4 +6to4))
 $(eval $(call protocol,3g,Support for 3G,+comgt))
-$(eval $(call protocol,relay,Support for relayd pseudo bridges,+relayd))
+$(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
 
 
 ### Community Packages ###
@@ -355,7 +355,7 @@ $(eval $(call application,statistics,LuCI Statistics Application,\
        +PACKAGE_luci-app-statistics:collectd \
        +PACKAGE_luci-app-statistics:rrdtool1 \
        +PACKAGE_luci-app-statistics:collectd-mod-rrdtool \
-       +PACKAGE_luci-app-statistics:collectd-mod-wireless \
+       +PACKAGE_luci-app-statistics:collectd-mod-iwinfo \
        +PACKAGE_luci-app-statistics:collectd-mod-interface \
        +PACKAGE_luci-app-statistics:collectd-mod-load))
 
@@ -431,7 +431,22 @@ $(eval $(call application,ahcp,LuCI Support for AHCPd,\
 $(eval $(call application,wshaper,LuCI Support for wshaper,\
        +PACKAGE_luci-app-wshaper:wshaper))
 
-$(eval $(call application,lqtapifoss,Lantiq voip))
+$(eval $(call application,pbx,LuCI PBX Administration,\
+       +PACKAGE_luci-app-pbx:asterisk18 \
+       +PACKAGE_luci-app-pbx:asterisk18-app-authenticate \
+       +PACKAGE_luci-app-pbx:asterisk18-app-disa \
+       +PACKAGE_luci-app-pbx:asterisk18-app-setcallerid \
+       +PACKAGE_luci-app-pbx:asterisk18-app-system \
+       +PACKAGE_luci-app-pbx:asterisk18-chan-gtalk \
+       +PACKAGE_luci-app-pbx:asterisk18-codec-a-mu \
+       +PACKAGE_luci-app-pbx:asterisk18-codec-alaw \
+       +PACKAGE_luci-app-pbx:asterisk18-func-cut \
+       +PACKAGE_luci-app-pbx:asterisk18-res-clioriginate))
+
+$(eval $(call application,pbx-voicemail,LuCI PBX Administration Voicemail Support,\
+       luci-app-pbx +PACKAGE_luci-app-pbx-voicemail:msmtp))
+
+$(eval $(call application,ltqtapi,Lantiq voip))
 
 ### Server Gateway Interfaces ###
 define sgi
@@ -488,6 +503,7 @@ endef
 
 $(eval $(call theme,base,Common base for all themes))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
+$(eval $(call theme,bootstrap,Bootstrap Theme))
 $(eval $(call theme,fledermaus,Fledermaus Theme))
 
 $(eval $(call theme,freifunk,alternative Freifunk Theme,\
@@ -500,7 +516,7 @@ $(eval $(call theme,freifunk-hannover,Freifunk Hannover Theme,\
        Mikolas Bingemer <mickey-at-freifunk-hannover-dot-de>))
 
 $(eval $(call theme,freifunk-generic,Freifunk Generic Theme,\
-        Manuel Munz <freifunk-at-somakoma-dot-de>))
+       Manuel Munz <freifunk-at-somakoma-dot-de>))
 
 ### Translations ###
 define translation
@@ -530,7 +546,7 @@ $(eval $(call translation,english,English))
 $(eval $(call translation,french,French (by Florian Fainelli)))
 $(eval $(call translation,italian,Italian (by Matteo Croce)))
 $(eval $(call translation,russian,Russian (by Skryabin Dmitry)))
-$(eval $(call translation,portuguese_brazilian,Portuguese (Brazilian) (by Carlos Cesario)))
+$(eval $(call translation,portuguese-brazilian,Portuguese (Brazilian) (by Carlos Cesario)))
 $(eval $(call translation,chinese,Chinese (by Chinese Translators)))
 $(eval $(call translation,japanese,Japanese (by Tsukasa Hamano)))
 $(eval $(call translation,greek,Greek (by Vasilis Tsiligiannis)))
@@ -542,6 +558,7 @@ $(eval $(call translation,malay,Malay (by Teow Wai Chet)))
 $(eval $(call translation,norwegian,Norwegian (by Lars Hardy)))
 $(eval $(call translation,hebrew,Hebrew))
 $(eval $(call translation,romanian,Romanian))
+$(eval $(call translation,ukrainian,Ukrainian))
 
 
 ### Collections ###
@@ -568,7 +585,7 @@ $(eval $(call collection,,\
        Standard OpenWrt set including full admin with ppp support and the \
        default OpenWrt theme,\
        +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
-       +luci-proto-core +luci-proto-ppp +libiwinfo))
+       +luci-proto-core +luci-proto-ppp +libiwinfo-lua))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\