i18n: sync translations
[project/luci.git] / applications / luci-app-vpnbypass / Makefile
index 58b3d30..e26fe27 100644 (file)
@@ -3,42 +3,13 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=luci-app-vpnbypass
-PKG_VERSION:=1.0.0
-PKG_RELEASE:=3
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(INCLUDE_DIR)/package.mk
+LUCI_TITLE:=VPN Bypass Web UI
+LUCI_DEPENDS:=+vpnbypass
+LUCI_PKGARCH:=all
 
-define Package/luci-app-vpnbypass
-  SECTION:=luci
-  CATEGORY:=LuCI
-  SUBMENU:=3. Applications
-  TITLE:=VPN Bypass Web UI
-  DEPENDS:=+luci-mod-admin-full +vpnbypass
-  PKGARCH:=all
-endef
+include ../../luci.mk
 
-define Package/luci-app-vpnbypass/description
- This package will install VPN Bypass Web UI.
-endef
-
-define Build/Prepare
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/luci-app-vpnbypass/install
-       $(INSTALL_DIR) $(1)/usr/lib/lua/luci/controller/
-       $(INSTALL_BIN) ./luasrc/controller/vpnbypass.lua  $(1)/usr/lib/lua/luci/controller/vpnbypass.lua
-       $(INSTALL_DIR) $(1)/usr/lib/lua/luci/model/cbi/
-       $(INSTALL_BIN) ./luasrc/model/cbi/vpnbypass.lua $(1)/usr/lib/lua/luci/model/cbi/vpnbypass.lua
-endef
-
-$(eval $(call BuildPackage,luci-app-vpnbypass))
\ No newline at end of file
+# call BuildPackage - OpenWrt buildroot signature
\ No newline at end of file