luci-base: zh_CN: update Simplified Chinese translation
[project/luci.git] / applications / luci-app-aria2 / Makefile
index 0179f04..f5b006c 100644 (file)
@@ -6,8 +6,32 @@
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
+PKG_NAME:=luci-app-aria2
+
+# Version == major.minor.patch
+# increase "minor" on new functionality and "patch" on patches/optimization
+PKG_VERSION:=1.0.1
+
+# Release == build
+# increase on changes of translation files
+PKG_RELEASE:=2
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Hsing-Wang Liao <kuoruan@gmail.com>
+
+# LuCI specific settings
 LUCI_TITLE:=LuCI Support for Aria2
 LUCI_DEPENDS:=+aria2
 LUCI_TITLE:=LuCI Support for Aria2
 LUCI_DEPENDS:=+aria2
+LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+               $(LUCI_TITLE)
+               .
+               Version: $(PKG_VERSION)-$(PKG_RELEASE)
+               $(PKG_MAINTAINER)
+endef
 
 include ../../luci.mk
 
 
 include ../../luci.mk