* Moved Freifunk status pages to admin-core and linked them in Freifunk
[project/luci.git] / Makefile
index bc765c9..fa9a407 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,48 +1,41 @@
-LUAC = luac
-LUAC_OPTIONS = -s
+include build/config.mk
 
-FILES = 
+MODULES = applications/* libs/* modules/* themes/* i18n/* contrib/luaposix
+LUA_TARGET = source
 
-CFILES = ffluci/util.lua ffluci/http.lua ffluci/fs.lua \
-ffluci/model/uci.lua ffluci/config.lua ffluci/i18n.lua  \
-ffluci/template.lua ffluci/cbi.lua ffluci/dispatcher.lua \
-ffluci/menu.lua ffluci/init.lua ffluci/sys.lua 
+OS:=$(shell uname)
+export OS
 
-DIRECTORIES = dist/ffluci/model/cbi dist/ffluci/controller dist/ffluci/i18n dist/ffluci/view
+.PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
-INFILES = $(CFILES:%=src/%)
-OUTFILE = ffluci/init.lua
+all: build
 
-.PHONY: all dist-compile dist-source examples-compile examples-source dist examples compile source clean
+build: luabuild gccbuild
 
-all: compile
+gccbuild:
+       for i in $(MODULES); do make -C$$i compile; done        
 
-dist-compile: compile dist
-dist-source: source dist
+luabuild:
+       for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
 
-examples-compile: compile examples
-examples-source: source examples
+clean:
+       for i in $(MODULES); do make -C$$i clean; done
 
 
-dist:
-       cp src/ffluci/controller/* dist/ffluci/controller/ -R
-       cp src/ffluci/i18n/* dist/ffluci/i18n/
-       cp src/ffluci/view/* dist/ffluci/view/ -R
-       cp src/ffluci/model/cbi/* dist/ffluci/model/cbi/ -R
-       
-examples:
-       cp examples/* dist/ -R
+host: build hostcopy
 
-compile:
-       mkdir -p $(DIRECTORIES)
-       $(LUAC) $(LUAC_OPTIONS) -o dist/$(OUTFILE) $(INFILES)
-       for i in $(CFILES); do [ -f dist/$$i ] || ln -s `dirname $$i | cut -s -d / -f 2- | sed -e 's/[^/]*\/*/..\//g'``basename $(OUTFILE)` dist/$$i; done
-       for i in $(FILES); do cp src/$$i dist/$$i; done
+gcchost: gccbuild hostcopy
 
-source:
-       mkdir -p $(DIRECTORIES)
-       for i in $(CFILES); do cp src/$$i dist/$$i; done
-       for i in $(FILES); do cp src/$$i dist/$$i; done
-       
-clean:
-       rm dist -rf
+luahost: luabuild hostcopy
+
+hostcopy: 
+       mkdir -p host
+       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
+       rm -f host/luci
+       ln -s .$(LUCI_INSTALLDIR) host/luci
+
+run: host
+       ./host/usr/bin/boa -c ./host/etc/boa -d
+
+hostclean: clean
+       rm -rf host