add "run" target
[project/luci.git] / Makefile
index 473d031..ec0d76a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,22 +1,45 @@
 include build/config.mk
 
-MODULES = applications/* core modules/* themes/*
+MODULES = applications/* libs/* modules/* themes/* i18n/*
 LUA_TARGET = source
 
+### luaposix merge (temporary) ###
+OS:=$(shell uname)
+export OS
+ifeq ($(OS),Darwin)
+  MODULES += contrib/luaposix
+endif
 
-.PHONY: all build clean host hostclean
+
+.PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
 all: build
 
-build:
-       for i in $(MODULES); do make -C$$i $(LUA_TARGET); done
+build: luabuild gccbuild
+
+gccbuild:
+       for i in $(MODULES); do make -C$$i compile; done        
+
+luabuild:
+       for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
 
 clean:
        for i in $(MODULES); do make -C$$i clean; done
 
-host: build
-       mkdir -p host/ffluci
-       for i in $(MODULES); do cp $$i/dist$(LUCI_INSTALLDIR) host/ -R 2>/dev/null || true; done
-       
-hostclean:
-       rm host -rf
+
+host: build hostcopy
+
+gcchost: gccbuild hostcopy
+
+luahost: luabuild hostcopy
+
+hostcopy: 
+       mkdir -p host
+       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
+       ln -sf .$(LUCI_INSTALLDIR) host/luci
+
+run: host
+       ./host/usr/bin/boa -c ./host/etc/boa -d
+
+hostclean: clean
+       rm -rf host