Sync nixio
[project/luci.git] / Makefile
index 38b7981..cbebd45 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,40 +1,84 @@
-LUAC = luac
-LUAC_OPTIONS = -s
+include build/config.mk
 
-FILES = ffluci/config.lua
+MODULES = contrib/* applications/* libs/* modules/* themes/* i18n/*
 
-CFILES = ffluci/util.lua ffluci/http.lua \
-ffluci/fs.lua ffluci/i18n.lua ffluci/model/uci.lua \
-ffluci/template.lua ffluci/dispatcher.lua ffluci/menu.lua ffluci/init.lua
+OS:=$(shell uname)
+export OS
 
-DIRECTORIES = dist/ffluci/model dist/ffluci/controller/public dist/ffluci/controller/admin dist/ffluci/i18n dist/ffluci/view
+.PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
-INFILES = $(CFILES:%=src/%)
-OUTFILE = ffluci/init.lua
+all: build
 
-all: compile
+build: gccbuild luabuild
 
-dist-compile: compile examples
-dist-source: source examples
+gccbuild:
+       for i in $(MODULES); do make -C$$i compile; done
 
-examples:
-       cp src/ffluci/controller/public/* dist/ffluci/controller/public/
-       cp src/ffluci/controller/admin/* dist/ffluci/controller/admin/
-       cp src/ffluci/i18n/* dist/ffluci/i18n/
-       cp src/ffluci/view/* dist/ffluci/view/ -R
+luabuild:
+       for i in $(MODULES); do make -C$$i luabuild; done
 
-compile:
-       mkdir -p $(DIRECTORIES)
-       $(LUAC) $(LUAC_OPTIONS) -o dist/$(OUTFILE) $(INFILES)
-       for i in $(CFILES); do [ -f dist/$$i ] || ln -s `dirname $$i | cut -s -d / -f 2- | sed -e 's/[^/]*\/*/..\//g'``basename $(OUTFILE)` dist/$$i; done
-       for i in $(FILES); do cp src/$$i dist/$$i; done
+clean:
+       rm -rf docs
+       for i in $(MODULES); do make -C$$i clean; done
 
-source:
-       mkdir -p $(DIRECTORIES)
-       for i in $(CFILES); do cp src/$$i dist/$$i; done
-       for i in $(FILES); do cp src/$$i dist/$$i; done
-       
 
-.PHONY: clean
-clean:
-       rm dist -rf
+host: build hostcopy
+
+gcchost: gccbuild hostcopy
+
+luahost: luabuild hostcopy
+
+hostcopy: 
+       mkdir -p host/tmp
+       for i in $(MODULES); do cp -pR $$i/dist/* host/ 2>/dev/null || true; done
+       for i in $(MODULES); do cp -pR $$i/hostfiles/* host/ 2>/dev/null || true; done
+       rm -f host/luci
+       ln -s .$(LUCI_MODULEDIR) host/luci
+       rm -rf /tmp/luci-* || true
+
+hostenv: host ucidefaults
+
+ucidefaults:
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/bin/uci-defaults --exclude luci-freifunk-*"
+
+runboa: hostenv
+       libs/sgi-webuci/host/buildconfig.sh $(realpath host) > host/etc/boa/boa.conf
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/boa) -c $(realpath host/etc/boa) -d"
+
+runhttpd: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/lucittpd) $(realpath host)/usr/lib/lucittpd/plugins"
+
+runluci: luahost
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath libs/httpd/host/runluci) $(realpath host) $(HTDOCS)"
+
+runlua: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) lua
+
+runshell: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) $$SHELL
+
+hostclean: clean
+       rm -rf host
+
+apidocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
+
+uvldocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
+       "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+
+run:
+       #       make run is deprecated                          #
+       #       Please use:                                     #
+       #                                                       #
+       #       To run LuCI WebUI using LuCIttpd                #
+       #       make runhttpd                                   #
+       #                                                       #
+       #       To run LuCI WebUI using Boa/Webuci              #
+       #       make runboa                                     #
+       #                                                       #
+       #       To start a shell in the LuCI environment        #
+       #       make runshell                                   #
+       #                                                       #
+       #       To run Lua CLI in the LuCI environment          #
+       #       make runlua                                     #