* luci/contrib/olsr: sync initscript and config format to current Kamikaze version
[project/luci.git] / Makefile
index 12c1d89..c90f11f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,9 +15,10 @@ gccbuild:
        for i in $(MODULES); do make -C$$i compile; done        
 
 luabuild:
-       for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
+       for i in $(MODULES); do make -C$$i luabuild; done
 
 clean:
+       rm -rf docs
        for i in $(MODULES); do make -C$$i clean; done
 
 
@@ -58,6 +59,13 @@ runshell: hostenv
 hostclean: clean
        rm -rf host
 
+apidocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
+
+uvldocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
+       "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+
 run:
        #       make run is deprecated                          #
        #       Please use:                                     #