Fixed UCI save support for LuCI SDK
[project/luci.git] / Makefile
index c90f11f..6c7d399 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -29,11 +29,12 @@ gcchost: gccbuild hostcopy
 luahost: luabuild hostcopy
 
 hostcopy: 
-       mkdir -p host
+       mkdir -p host/tmp
        for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        for i in $(MODULES); do cp -a $$i/hostfiles/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_MODULEDIR) host/luci
+       rm -rf /tmp/luci-* || true
 
 hostenv: host ucidefaults