add -Wmissing-declarations to cflags
authorFelix Fietkau <nbd@openwrt.org>
Mon, 22 Oct 2012 18:03:53 +0000 (20:03 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 22 Oct 2012 18:03:53 +0000 (20:03 +0200)
CMakeLists.txt

index 93ee787..00b3b41 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(ubox C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
 
 OPTION(BUILD_LUA "build Lua plugin" ON)