[package] base-files: add udhcpc vendorid option (#7744)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Oct 2010 21:21:28 +0000 (21:21 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Oct 2010 21:21:28 +0000 (21:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23279 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/network/config.sh

index 5a6c1a9..bd77d34 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=59
+PKG_RELEASE:=60
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index c948c83..d285da2 100755 (executable)
@@ -344,12 +344,13 @@ setup_interface() {
                        local pidfile="/var/run/dhcp-${iface}.pid"
                        service_kill udhcpc "$pidfile"
 
-                       local ipaddr netmask hostname proto1 clientid broadcast
+                       local ipaddr netmask hostname proto1 clientid vendorid broadcast
                        config_get ipaddr "$config" ipaddr
                        config_get netmask "$config" netmask
                        config_get hostname "$config" hostname
                        config_get proto1 "$config" proto
                        config_get clientid "$config" clientid
+                       config_get vendorid "$config" vendorid
                        config_get_bool broadcast "$config" broadcast 0
 
                        [ -z "$ipaddr" ] || \
@@ -364,6 +365,7 @@ setup_interface() {
                                ${ipaddr:+-r $ipaddr} \
                                ${hostname:+-H $hostname} \
                                ${clientid:+-c $clientid} \
+                               ${vendorid:+-V $vendorid} \
                                -b -p "$pidfile" $broadcast \
                                ${dhcpopts:- -O rootpath -R &}
                ;;