libreadline: cleanup Makefile, fix shlib perms
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Apr 2015 15:11:32 +0000 (15:11 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Apr 2015 15:11:32 +0000 (15:11 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45223 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/libreadline/Makefile
package/libs/libreadline/patches/001-install_perm.patch [new file with mode: 0644]

index a9e6a22..21c8b21 100644 (file)
@@ -19,6 +19,8 @@ PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
 
 PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -38,27 +40,22 @@ define Package/libreadline/description
        history expansion on previous commands.
 endef
 
-define Build/Configure
-       $(CP) $(SCRIPT_DIR)/config.guess $(SCRIPT_DIR)/config.sub $(PKG_BUILD_DIR)/support/
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --without-curses \
-               bash_cv_wcwidth_broken=no \
-               bash_cv_func_sigsetjmp=yes \
-       )
-endef
+# prevent "autoreconf" from removing "aclocal.m4"
+PKG_REMOVE_FILES:=
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --with-curses \
+
+CONFIGURE_VARS += \
+       bash_cv_wcwidth_broken=no \
+       bash_cv_func_sigsetjmp=yes \
 
 TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/Compile
-       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
diff --git a/package/libs/libreadline/patches/001-install_perm.patch b/package/libs/libreadline/patches/001-install_perm.patch
new file mode 100644 (file)
index 0000000..951ff73
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/support/shlib-install
++++ b/support/shlib-install
+@@ -73,7 +73,7 @@ fi
+ case "$host_os" in
+ hpux*|darwin*|macosx*|linux*|solaris2*)
+       if [ -z "$uninstall" ]; then
+-              chmod 555 ${INSTALLDIR}/${LIBNAME}
++              chmod +x ${INSTALLDIR}/${LIBNAME}
+       fi ;;
+ cygwin*|mingw*)
+       IMPLIBNAME=`echo ${LIBNAME} \