kernel/modules: move SHA512 to its own package
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Nov 2015 21:34:00 +0000 (21:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Nov 2015 21:34:00 +0000 (21:34 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47478 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk

index 2328fac..ca36c2f 100644 (file)
@@ -508,6 +508,18 @@ endef
 $(eval $(call KernelPackage,crypto-sha256))
 
 
+define KernelPackage/crypto-sha512
+  TITLE:=SHA512 digest CryptoAPI module
+  DEPENDS:=+kmod-crypto-hash
+  KCONFIG:=CONFIG_CRYPTO_SHA512
+  FILES:=$(LINUX_DIR)/crypto/sha512_generic.ko
+  AUTOLOAD:=$(call AutoLoad,09,sha512_generic)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-sha512))
+
+
 define KernelPackage/crypto-misc
   TITLE:=Other CryptoAPI modules
   DEPENDS:=+kmod-crypto-manager
@@ -520,7 +532,6 @@ define KernelPackage/crypto-misc
        CONFIG_CRYPTO_FCRYPT \
        CONFIG_CRYPTO_KHAZAD \
        CONFIG_CRYPTO_SERPENT \
-       CONFIG_CRYPTO_SHA512 \
        CONFIG_CRYPTO_TEA \
        CONFIG_CRYPTO_TGR192 \
        CONFIG_CRYPTO_TWOFISH \
@@ -534,7 +545,6 @@ define KernelPackage/crypto-misc
        $(LINUX_DIR)/crypto/cast5_generic.ko \
        $(LINUX_DIR)/crypto/cast6_generic.ko \
        $(LINUX_DIR)/crypto/khazad.ko \
-       $(LINUX_DIR)/crypto/sha512_generic.ko \
        $(LINUX_DIR)/crypto/tea.ko \
        $(LINUX_DIR)/crypto/tgr192.ko \
        $(LINUX_DIR)/crypto/twofish_common.ko \