ramips: rt3883: add profile and build sysupgrade image for the RT-N56U
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2012 12:30:44 +0000 (12:30 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2012 12:30:44 +0000 (12:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31399 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile
target/linux/ramips/rt3883/profiles/asus.mk [new file with mode: 0644]

index d310d26..1330fa3 100644 (file)
@@ -449,6 +449,19 @@ define Image/Build/Profile/Default
 endef
 endif
 
+#
+# RT3662/RT3883 Profiles
+#
+define Image/Build/Profile/RTN56U
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,rt-n56u,RT-N56U,ttyS1,57600,phys)
+endef
+
+ifeq ($(CONFIG_RALINK_RT3883),y)
+define Image/Build/Profile/Default
+       $(call Image/Build/Profile/RTN56U,$(1))
+endef
+endif
+
 define Image/Build/Initramfs
        $(call Image/Build/Profile/$(PROFILE),initramfs)
 endef
diff --git a/target/linux/ramips/rt3883/profiles/asus.mk b/target/linux/ramips/rt3883/profiles/asus.mk
new file mode 100644 (file)
index 0000000..e1c60ee
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RTN56U
+       NAME:=Asus RT-N56U
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb-usb2 swconfig
+endef
+
+define Profile/RTN56U/Description
+       Package set compatible with the Asus RT-N56U board.
+endef
+$(eval $(call Profile,RTN56U))