another round of ppc fixes - the unfinished include/asm-ppc => asm-powerpc migration...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Nov 2006 18:30:16 +0000 (18:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Nov 2006 18:30:16 +0000 (18:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5683 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/kernel-headers/Makefile
toolchain/uClibc/patches/180-powerpc_headers.patch [new file with mode: 0644]

index 4cd0199..d2d9c3d 100644 (file)
@@ -26,7 +26,9 @@ define Build/Prepare
 endef
 
 define Build/Configure/powerpc
-       $(CP) $(PKG_BUILD_DIR)/include/asm-powerpc/* $(PKG_BUILD_DIR)/include/asm-ppc/
+       $(CP) $(PKG_BUILD_DIR)/include/asm-ppc/* $(PKG_BUILD_DIR)/include/asm-powerpc/
+       rm -rf $(PKG_BUILD_DIR)/include/asm-ppc
+       mv $(PKG_BUILD_DIR)/include/asm-powerpc $(PKG_BUILD_DIR)/include/asm-ppc
 endef
 
 define Build/Configure
diff --git a/toolchain/uClibc/patches/180-powerpc_headers.patch b/toolchain/uClibc/patches/180-powerpc_headers.patch
new file mode 100644 (file)
index 0000000..98af0c0
--- /dev/null
@@ -0,0 +1,13 @@
+diff -ur uClibc.old/libc/sysdeps/linux/powerpc/bits/kernel_types.h uClibc.dev/libc/sysdeps/linux/powerpc/bits/kernel_types.h
+--- uClibc.old/libc/sysdeps/linux/powerpc/bits/kernel_types.h  2005-08-18 00:49:41.000000000 +0200
++++ uClibc.dev/libc/sysdeps/linux/powerpc/bits/kernel_types.h  2006-11-30 19:26:22.000000000 +0100
+@@ -4,7 +4,8 @@
+  * our private content, and not the kernel header, will win.
+  *  -Erik
+  */
+-#if ! defined _PPC_POSIX_TYPES_H && ! defined _PPC64_POSIX_TYPES_H
++#if ! defined _PPC_POSIX_TYPES_H && ! defined _PPC64_POSIX_TYPES_H && !defined _ASM_POWERPC_POSIX_TYPES_H
++#define _ASM_POWERPC_POSIX_TYPES_H
+ #define _PPC_POSIX_TYPES_H
+ #define _PPC64_POSIX_TYPES_H