brcm63xx: F@ST2504n board support (image, base-files)
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Feb 2014 11:16:42 +0000 (11:16 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Feb 2014 11:16:42 +0000 (11:16 +0000)
Signed-off-by: Max Staudt <openwrt.max@enpas.org>
Patchwork: http://patchwork.openwrt.org/patch/4730/
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39676 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile

index b4ab46d..6233531 100755 (executable)
@@ -82,6 +82,7 @@ DVG3810BN)
 963281TAN |\
 963281T_TEF |\
 96368MVNgr |\
+"F@ST2504n" |\
 "F@ST2704V2")
        ucidef_set_interface_lan "eth0.1"
        ucidef_add_switch "eth0" "1" "1"
index 1d9b448..679fedd 100755 (executable)
@@ -125,6 +125,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       "F@ST2504n")
+               status_led="fast2504n:green:ok"
+               brcm63xx_has_reset_button="true"
+               ifname=eth0
+               ;;
        'F@ST2704V2')
                status_led="F@ST2704V2:green:power"
                brcm63xx_has_reset_button="true"
index ecdceca..8f661d2 100755 (executable)
@@ -220,6 +220,9 @@ define Image/Build
        # Neufbox6
        $(call Image/Build/CFE,$(1),NB6-SER-r0,6362,NEUFBOX6,OpenWRT-$(REVISION))
 
+       # Sagem F@ST2504n
+       $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
+
        # Comtrend 6373
        $(call Image/Build/CFE,$(1),CT6373-1,6358,CT6373)
        # Comtrend 536, 5621