fix "make target/linux/package/*-*" targets
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jan 2006 21:55:38 +0000 (21:55 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jan 2006 21:55:38 +0000 (21:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3103 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/Makefile
target/linux/Makefile
target/linux/kernel.mk

index ec3b659..e066fa9 100644 (file)
@@ -35,3 +35,5 @@ linux-imagebuilder:
        @$(TRACE) target/linux/imagebuilder
        $(MAKE) -C linux imagebuilder
 
+linux/package/%:
+       $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
index 2fff3b3..626587b 100644 (file)
@@ -45,6 +45,8 @@ compile: $(1)/$(2)-compile
 rebuild: $(1)/$(2)-rebuild
 $(BIN_DIR)/$(IB_NAME).tar.bz2 install: $(1)/$(2)-image
 install-ib: $(1)/$(2)-install-ib
+package/%:
+       $(MAKE) -C $(2)-$(1) BOARD="$(2)" $$@
 endif
 
 .PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install $(1)/$(2)-image $(1)/$(2)-install-ib
index b1ac947..5406fae 100644 (file)
@@ -114,3 +114,8 @@ clean:
        rm -f $(STAMP_DIR)/.linux-compile
        rm -rf $(LINUX_BUILD_DIR)
        rm -f $(TARGETS)
+
+package/%:
+       $(MAKE) -C $(TOPDIR)/target/linux/package \
+               $(KPKG_MAKEOPTS) \
+               $(patsubst package/%,%,$@)