move ccache to tools/ and fix potential dependency issue
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Feb 2007 23:46:34 +0000 (23:46 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Feb 2007 23:46:34 +0000 (23:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6413 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/Makefile
toolchain/ccache/Makefile [deleted file]
tools/Makefile
tools/ccache/Makefile [new file with mode: 0644]

index 4832a65..7773c32 100644 (file)
@@ -10,7 +10,6 @@ include $(TOPDIR)/rules.mk
 
 TARGETS-y:=kernel-headers
 TARGETS-$(CONFIG_GDB) += gdb
 
 TARGETS-y:=kernel-headers
 TARGETS-$(CONFIG_GDB) += gdb
-TARGETS-$(CONFIG_CCACHE) += ccache
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   TARGETS-y+=binutils gcc uClibc
 endif
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   TARGETS-y+=binutils gcc uClibc
 endif
diff --git a/toolchain/ccache/Makefile b/toolchain/ccache/Makefile
deleted file mode 100644 (file)
index e8e85b4..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/target.mk
-
-PKG_NAME:=ccache
-PKG_VERSION:=2.4
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=73c1ed1e767c1752dd0f548ec1e66ce7
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Build/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
-  endef
-
-  define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(STAGING_DIR)" \
-               install
-  endef
-
-  define Build/Clean
-       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Clean/Default)
-  endef
-else
-  define Build/Prepare
-  endef
-  define Build/Configure
-  endef
-  define Build/Compile
-  endef
-  define Build/Clean
-  endef
-endif
-
-$(eval $(call HostBuild))
index d03ab38..8c5f699 100644 (file)
@@ -8,6 +8,7 @@
 #
 include $(TOPDIR)/rules.mk
 TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
 #
 include $(TOPDIR)/rules.mk
 TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
+TARGETS-$(CONFIG_CCACHE) += ccache
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
 TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
 TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
@@ -28,7 +29,7 @@ ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
   $(STAMP): $(TARGETS_INSTALL)
 endif
 
   $(STAMP): $(TARGETS_INSTALL)
 endif
 
-$(STAMP):
+$(STAMP): $(TOPDIR)/.config
        mkdir -p $(shell dirname $@)
        touch $@
        
        mkdir -p $(shell dirname $@)
        touch $@
        
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
new file mode 100644 (file)
index 0000000..e8e85b4
--- /dev/null
@@ -0,0 +1,49 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+PKG_NAME:=ccache
+PKG_VERSION:=2.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
+PKG_MD5SUM:=73c1ed1e767c1752dd0f548ec1e66ce7
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
+  define Build/Compile
+       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+  endef
+
+  define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(STAGING_DIR)" \
+               install
+  endef
+
+  define Build/Clean
+       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Clean/Default)
+  endef
+else
+  define Build/Prepare
+  endef
+  define Build/Configure
+  endef
+  define Build/Compile
+  endef
+  define Build/Clean
+  endef
+endif
+
+$(eval $(call HostBuild))