bcm63xx: Add support for the T-Com Speedport W 500V.
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 22:04:44 +0000 (22:04 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 22:04:44 +0000 (22:04 +0000)
Add support for the T-Com Speedport W 500V using a special tagged image as it
identifies itself as a 96348GW, but has some gpios wired differently, and also
has only one ethernet port without a switch attached to it.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24190 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/base-files/etc/defconfig/SP500W/network [new file with mode: 0644]
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-2.6.35/420-board_spw500v.patch [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/SP500W/network b/target/linux/brcm63xx/base-files/etc/defconfig/SP500W/network
new file mode 100644 (file)
index 0000000..a35fd2e
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth0
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
index bacd666..a9ac79b 100755 (executable)
@@ -25,7 +25,7 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth1
                ;;
-       "bcm63xx/96358GW "*)
+       "bcm63xx/96358GW "* | "bcm63xx/SPW500V "*)
                status_led="power:green"
                brcm63xx_has_reset_button="true"
                ifname=eth0
index 589e47c..2671536 100644 (file)
@@ -189,6 +189,8 @@ define Image/Build
        # Telsey CPVA642-type (e.g. CPA-ZNTE60T)
        $(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
 
+       # T-Com Speedport W 500V
+       $(call Image/Build/CFEFIXUP,$(1),96348GW,6348,SPW500V)
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/brcm63xx/patches-2.6.35/420-board_spw500v.patch b/target/linux/brcm63xx/patches-2.6.35/420-board_spw500v.patch
new file mode 100644 (file)
index 0000000..9724aa6
--- /dev/null
@@ -0,0 +1,78 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -575,6 +575,67 @@ static struct board_info __initdata boar
+ };
++static struct board_info __initdata board_spw500v = {
++      .name                           = "SPW500V",
++      .expected_cpu_id                = 0x6348,
++
++      .has_uart0                      = 1,
++      .has_enet0                      = 1,
++      .has_pci                        = 1,
++
++      .enet0 = {
++              .has_phy                = 1,
++              .use_internal_phy       = 1,
++      },
++
++      .has_dsp                        = 1,
++      .dsp = {
++              .gpio_rst               = 6,
++              .gpio_int               = 34,
++              .ext_irq                = 2,
++              .cs                     = 2,
++      },
++
++      .leds = {
++              {
++                      .name           = "power:red",
++                      .gpio           = 1,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "power:green",
++                      .gpio           = 0,
++                      .active_low     = 1,
++                      .default_trigger = "default-on",
++              },
++              {
++                      .name           = "ppp",
++                      .gpio           = 3,
++                      .active_low     = 1,
++              },
++              {       .name           = "pstn",
++                      .gpio           = 28,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "voip",
++                      .gpio           = 32,
++                      .active_low     = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc           = "reset",
++                      .gpio           = 33,
++                      .active_low     = 1,
++                      .type           = EV_KEY,
++                      .code           = KEY_RESTART,
++                      .threshold      = 3,
++              },
++      },
++};
++
+ #endif
+ /*
+@@ -1409,6 +1470,7 @@ static const struct board_info __initdat
+       &board_96348gw_a,
+       &board_rta1025w_16,
+       &board_96348_D4PW,
++      &board_spw500v,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6358