add pkgconfig information for popt library
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jan 2015 12:52:28 +0000 (12:52 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jan 2015 12:52:28 +0000 (12:52 +0000)
Modify makefile to record pkgconfig information for the popt library.

Signed-off-by: Mike Brady <mikebrady@eircom.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43994 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/popt/Makefile

index bd2e6e2..b31b311 100644 (file)
@@ -45,6 +45,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/popt.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libpopt/install