[rdc] add lzma tuning options, patch from Bernhard Loos
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 May 2010 19:31:05 +0000 (19:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 May 2010 19:31:05 +0000 (19:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21311 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch [new file with mode: 0644]
target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch [deleted file]
target/linux/rdc/patches-2.6.32/011-tune_lzma_options.patch [new file with mode: 0644]

diff --git a/target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch b/target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch
new file mode 100644 (file)
index 0000000..0b236df
--- /dev/null
@@ -0,0 +1,26 @@
+Index: linux-2.6.32.9/scripts/Makefile.lib
+===================================================================
+--- linux-2.6.32.9.orig/scripts/Makefile.lib   2010-04-13 07:55:06.543296524 +0200
++++ linux-2.6.32.9/scripts/Makefile.lib        2010-04-13 07:55:06.814268461 +0200
+@@ -228,7 +228,7 @@
+ quiet_cmd_lzma = LZMA    $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+-      lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++      lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+       (rm -f $@ ; false)
+ quiet_cmd_lzo = LZO    $@
+Index: linux-2.6.32.9/arch/x86/include/asm/boot.h
+===================================================================
+--- linux-2.6.32.9.orig/arch/x86/include/asm/boot.h    2010-02-23 16:38:51.000000000 +0100
++++ linux-2.6.32.9/arch/x86/include/asm/boot.h 2010-04-13 08:00:14.474369306 +0200
+@@ -28,7 +28,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE             0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
diff --git a/target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch b/target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch
deleted file mode 100644 (file)
index 0cb4734..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -204,4 +204,4 @@ cmd_bzip2 = (bzip2 -9 < $< && $(size_app
- # ---------------------------------------------------------------------------
- quiet_cmd_lzma = LZMA    $@
--cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
-+cmd_lzma = (/usr/bin/lzma -9 -c $< ; $(size_append) $<) >$@ || (rm -f $@ ; false)
diff --git a/target/linux/rdc/patches-2.6.32/011-tune_lzma_options.patch b/target/linux/rdc/patches-2.6.32/011-tune_lzma_options.patch
new file mode 100644 (file)
index 0000000..0b236df
--- /dev/null
@@ -0,0 +1,26 @@
+Index: linux-2.6.32.9/scripts/Makefile.lib
+===================================================================
+--- linux-2.6.32.9.orig/scripts/Makefile.lib   2010-04-13 07:55:06.543296524 +0200
++++ linux-2.6.32.9/scripts/Makefile.lib        2010-04-13 07:55:06.814268461 +0200
+@@ -228,7 +228,7 @@
+ quiet_cmd_lzma = LZMA    $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+-      lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++      lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+       (rm -f $@ ; false)
+ quiet_cmd_lzo = LZO    $@
+Index: linux-2.6.32.9/arch/x86/include/asm/boot.h
+===================================================================
+--- linux-2.6.32.9.orig/arch/x86/include/asm/boot.h    2010-02-23 16:38:51.000000000 +0100
++++ linux-2.6.32.9/arch/x86/include/asm/boot.h 2010-04-13 08:00:14.474369306 +0200
+@@ -28,7 +28,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE             0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */