odhcp6c: various bugfixes
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Mar 2013 07:04:38 +0000 (07:04 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Mar 2013 07:04:38 +0000 (07:04 +0000)
* Don't prematurely send RENEW / REBIND when T1 or T2 is > 1 day
* Add "norelease" option to not send a RELEASE when stopping

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35902 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index 8bf3ebe..f1509f7 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-02-12
+PKG_VERSION:=2013-03-08
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=31ce2ea9f57322d526daf266c7fca4bd407297cb
+PKG_SOURCE_VERSION:=e8b07f018cbdf8f2a08f93af46904e7ffb9eb123
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index b1837a9..6cf7521 100755 (executable)
@@ -10,6 +10,7 @@ proto_dhcpv6_init_config() {
        proto_config_add_string "clientid"
        proto_config_add_string "reqopts"
        proto_config_add_string "noslaaconly"
+       proto_config_add_string "norelease"
        proto_config_add_string "ip6prefix"
 }
 
@@ -17,8 +18,8 @@ proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly ip6prefix
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly ip6prefix
+       local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix
 
 
        # Configure
@@ -32,6 +33,8 @@ proto_dhcpv6_setup() {
 
        [ "$noslaaconly" = "1" ] && append opts "-S"
 
+       [ "$norelease" = "1" ] && append opts "-k"
+
        for opt in $reqopts; do
                append opts "-r$opt"
        done