gettext-full: use uclibc workarounds for musl as well
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Jun 2014 22:25:43 +0000 (22:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Jun 2014 22:25:43 +0000 (22:25 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41397 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/gettext-full/Makefile

index 11dc1f5..ca521b4 100644 (file)
@@ -38,6 +38,9 @@ TARGET_CFLAGS += $(FPIC)
 ifneq ($(HOST_OS),Linux)
   TARGET_CFLAGS += -I$(STAGING_DIR_HOST)/include
 endif
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -D__UCLIBC__
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \