openssl: detect configuration changes and clean build tree accordingly (fixes #15067)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Mar 2014 13:19:29 +0000 (13:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Mar 2014 13:19:29 +0000 (13:19 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39852 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/openssl/Makefile

index fe99a53..38679ac 100644 (file)
@@ -110,7 +110,13 @@ else
   endif
 endif
 
+STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(subst $(space),_,$(OPENSSL_OPTIONS))
+
 define Build/Configure
+       [ -f $(STAMP_CONFIGURED) ] || { \
+               rm -f $(PKG_BUILD_DIR)/*.so.* $(PKG_BUILD_DIR)/*.a; \
+               find $(PKG_BUILD_DIR) -name \*.o | xargs rm -f; \
+       }
        (cd $(PKG_BUILD_DIR); \
                ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \