package/busybox: add upstream udhcp hostname truncation fix, bump release number
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 May 2010 21:39:10 +0000 (21:39 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 May 2010 21:39:10 +0000 (21:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21510 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
package/busybox/patches/000-upstream-dhcpd.patch [new file with mode: 0644]

index 3b93a05..60daf8d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.16.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/patches/000-upstream-dhcpd.patch b/package/busybox/patches/000-upstream-dhcpd.patch
new file mode 100644 (file)
index 0000000..eef33f8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/networking/udhcp/leases.c
++++ b/networking/udhcp/leases.c
+@@ -64,6 +64,8 @@ struct dyn_lease* FAST_FUNC add_lease(
+               oldest->hostname[0] = '\0';
+               if (hostname) {
+                       char *p;
++
++                      hostname_len++; /* include NUL */
+                       if (hostname_len > sizeof(oldest->hostname))
+                               hostname_len = sizeof(oldest->hostname);
+                       p = safe_strncpy(oldest->hostname, hostname, hostname_len);