fix nl80211
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Oct 2007 23:01:35 +0000 (23:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Oct 2007 23:01:35 +0000 (23:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9296 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile

index 800ae48..bbc8a6c 100644 (file)
@@ -32,19 +32,20 @@ define KernelPackage/mac80211/description
 Linux 802.11 Wireless Networking Stack
 endef
 
-CONFOPTS:=MAC80211 CFG80211 NL80211
+CONFOPTS:=MAC80211 CFG80211
 
 BUILDFLAGS:= \
        $(foreach opt,$(CONFOPTS),-DCONFIG_$(opt) ) \
-       $(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS)
+       $(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS -DCONFIG_NL80211)
 
 MAKE_OPTS:= \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        ARCH="$(LINUX_KARCH)" \
        EXTRA_CFLAGS="$(BUILDFLAGS)" \
        $(foreach opt,$(CONFOPTS),CONFIG_$(opt)=m) \
+       CONFIG_NL80211=y \
        CONFIG_MAC80211_LEDS=$(CONFIG_LEDS_TRIGGERS) \
-       LINUXINCLUDE="-I${CURDIR}/src/include -I$(LINUX_DIR)/include -include linux/autoconf.h"
+       LINUXINCLUDE="-I${CURDIR}/src/include -I$(LINUX_DIR)/include -include linux/autoconf.h" \
 
 ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),)
   define Build/Prepare