ar71xx: image: add OpenMesh profile
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Dec 2012 15:16:05 +0000 (15:16 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Dec 2012 15:16:05 +0000 (15:16 +0000)
It allows to build firmware images for all OpenMesh
products in one step.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34761 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/generic/profiles/openmesh.mk
target/linux/ar71xx/image/Makefile

index 92aec4b..53ae598 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -27,3 +27,14 @@ endef
 
 $(eval $(call Profile,MR600))
 
+define Profile/OPENMESH
+       NAME:=OpenMesh products
+       PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OPENMESH/Description
+       Build images for all OpenMesh products.
+endef
+
+$(eval $(call Profile,OPENMESH))
+
index 83037c4..d3aa6c9 100644 (file)
@@ -948,6 +948,7 @@ $(eval $(call SingleProfile,ZyXEL,$(fs_64k),NBG_460N_550N_550NH,nbg460n_550n_550
 
 $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
 $(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT))
+$(eval $(call MultiProfile,OPENMESH,OM2P MR600))
 $(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
 $(eval $(call MultiProfile,TLWA801,TLWA801NV1))
 $(eval $(call MultiProfile,TLWA901,TLWA901NV1 TLWA901NV2))