store the default kernel version for our ports in a single place (target makefiles...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Dec 2006 09:12:57 +0000 (09:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Dec 2006 09:12:57 +0000 (09:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5899 3c298f89-4303-0410-b956-a3cf2f4a3e73

16 files changed:
include/kernel-build.mk
include/kernel-version.mk [new file with mode: 0644]
target/linux/ar7-2.4/Makefile
target/linux/aruba-2.6/Makefile
target/linux/atheros-2.6/Makefile
target/linux/au1000-2.6/Makefile
target/linux/brcm-2.4/Makefile
target/linux/brcm-2.6/Makefile
target/linux/brcm63xx-2.6/Makefile
target/linux/ixp4xx-2.6/Makefile
target/linux/magicbox-2.6/Makefile
target/linux/rb532-2.6/Makefile
target/linux/rdc-2.6/Makefile
target/linux/sibyte-2.6/Makefile
target/linux/uml-2.6/Makefile
target/linux/x86-2.6/Makefile

index 6643d46..6d9c9d9 100644 (file)
@@ -33,8 +33,8 @@ ifeq ($(DUMP),1)
 else
   all: compile
 endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
 
+include $(INCLUDE_DIR)/kernel-version.mk
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/kernel.mk
 
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
new file mode 100644 (file)
index 0000000..af457a2
--- /dev/null
@@ -0,0 +1,15 @@
+# Use the default kernel version if the Makefile doesn't override it
+
+ifeq ($(LINUX_VERSION),)
+  ifeq ($(KERNEL),2.4)
+    LINUX_VERSION:=2.4.33.4
+    LINUX_RELEASE:=1
+    LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+  else
+    LINUX_VERSION:=2.6.19.1
+    LINUX_RELEASE:=1
+    LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
+  endif
+endif
+KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+
index f9d3290..970bb4b 100644 (file)
@@ -15,9 +15,7 @@ define Target/Description
        Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
 endef
 
-LINUX_VERSION:=2.4.33.4
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-avalanche-cpmac
index 989f321..5d3e19e 100644 (file)
@@ -15,10 +15,6 @@ define Target/Description
        Build firmware images for Aruba boards
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
index f3f3ca6..92f9d36 100644 (file)
@@ -15,10 +15,6 @@ define Target/Description
        Build firmware images for Atheros SoC boards (currently AR2315-AR2317)
 endef
 
-LINUX_VERSION:=2.6.19
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
-
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
index 4b20032..2f2a92b 100644 (file)
@@ -16,10 +16,6 @@ define Target/Description
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 define Kernel/BuildImage
index 226da56..4e1267d 100644 (file)
@@ -20,9 +20,7 @@ define Target/Description
        with TFTP client too.
 endef
 
-LINUX_VERSION:=2.4.33.4
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch nvram
index c30e150..8e69332 100644 (file)
@@ -20,10 +20,6 @@ define Target/Description
        with TFTP client too.
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch
 
index 4757eff..5b98e90 100644 (file)
@@ -16,10 +16,6 @@ define Target/Description
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 define Profile/Broadcom
index 1d08708..352671e 100644 (file)
@@ -14,9 +14,5 @@ FEATURES:=jffs2
 define Target/Description
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index 0dcc1e7..b829965 100644 (file)
@@ -11,9 +11,5 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=jffs2
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index ae28b87..6ec9bdc 100644 (file)
@@ -11,9 +11,5 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index 3fbd700..f1f751e 100644 (file)
@@ -16,10 +16,6 @@ define Target/Description
         (e.g. Airlink101 AR525W)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 define Profile/Ralink
index 2dd590c..364d116 100644 (file)
@@ -11,9 +11,5 @@ BOARD:=sibyte
 BOARDNAME:=SiByte MIPS
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index ff2297f..33bf806 100644 (file)
@@ -10,9 +10,5 @@ ARCH:=i386
 BOARD:=uml
 BOARDNAME:=User Mode Linux
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))
index f7e3fa8..25e7356 100644 (file)
@@ -11,10 +11,6 @@ BOARD:=x86
 BOARDNAME:=x86
 FEATURES:=jffs2 ext2
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
 $(eval $(call BuildKernel))