add kmod-fs-minix
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Jan 2006 04:01:20 +0000 (04:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Jan 2006 04:01:20 +0000 (04:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3024 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar531x-2.4/config
target/linux/aruba-2.6/config
target/linux/brcm-2.4/config
target/linux/brcm-2.6/config
target/linux/control/kmod-fs-minix.control [new file with mode: 0644]
target/linux/generic-2.4/modules.mk
target/linux/generic-2.6/modules.mk
target/linux/x86-2.4/config
target/linux/x86-2.6/config

index 77c5beb..e48d8d0 100644 (file)
@@ -836,7 +836,7 @@ CONFIG_JOLIET=y
 # CONFIG_JFS_FS is not set
 # CONFIG_JFS_DEBUG is not set
 # CONFIG_JFS_STATISTICS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
 # CONFIG_VXFS_FS is not set
 # CONFIG_NTFS_FS is not set
 # CONFIG_NTFS_RW is not set
index e662d99..a5e81fe 100644 (file)
@@ -1272,7 +1272,7 @@ CONFIG_JFS_FS=m
 # CONFIG_JFS_STATISTICS is not set
 # CONFIG_FS_POSIX_ACL is not set
 # CONFIG_XFS_FS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
 # CONFIG_ROMFS_FS is not set
 # CONFIG_INOTIFY is not set
 # CONFIG_QUOTA is not set
index 26d9cd1..d40fc72 100644 (file)
@@ -1038,7 +1038,7 @@ CONFIG_JOLIET=y
 # CONFIG_JFS_FS is not set
 # CONFIG_JFS_DEBUG is not set
 # CONFIG_JFS_STATISTICS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
 # CONFIG_VXFS_FS is not set
 # CONFIG_NTFS_FS is not set
 # CONFIG_NTFS_RW is not set
index b3a9c5d..9a67406 100644 (file)
@@ -1448,7 +1448,7 @@ CONFIG_XFS_FS=m
 # CONFIG_XFS_SECURITY is not set
 # CONFIG_XFS_POSIX_ACL is not set
 # CONFIG_XFS_RT is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
 # CONFIG_ROMFS_FS is not set
 CONFIG_INOTIFY=y
 # CONFIG_QUOTA is not set
diff --git a/target/linux/control/kmod-fs-minix.control b/target/linux/control/kmod-fs-minix.control
new file mode 100644 (file)
index 0000000..2169ba6
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-fs-minix
+Priority: optional
+Section: sys
+Description: Kernel modules for MINIX filesystem support
index 9efcce7..e65ef81 100644 (file)
@@ -142,6 +142,10 @@ $(eval $(call KMOD_template,FS_CIFS,fs-cifs,\
        $(MODULES_DIR)/kernel/fs/cifs/cifs.o \
 ,CONFIG_CIFS,,30,cifs))
 
+$(eval $(call KMOD_template,FS_MINIX,fs-minix,\
+       $(MODULES_DIR)/kernel/fs/minix/*.o \
+,CONFIG_MINIX_FS,,30,minix))
+
 $(eval $(call KMOD_template,FS_EXT2,fs-ext2,\
        $(MODULES_DIR)/kernel/fs/ext2/*.o \
 ,CONFIG_EXT2_FS,,30,ext2))
index 71b3df5..7765c12 100644 (file)
@@ -133,6 +133,10 @@ $(eval $(call KMOD_template,FS_CIFS,fs-cifs,\
        $(MODULES_DIR)/kernel/fs/cifs/cifs.ko \
 ,CONFIG_CIFS,kmod-nls-base,30,cifs))
 
+$(eval $(call KMOD_template,FS_MINIX,fs-minix,\
+       $(MODULES_DIR)/kernel/fs/minix/minix.ko \
+,CONFIG_MINIX_FS,,30,minix))
+
 $(eval $(call KMOD_template,FS_EXT2,fs-ext2,\
        $(MODULES_DIR)/kernel/fs/ext2/ext2.ko \
 ,CONFIG_EXT2_FS,,30,ext2))
index 339196f..d46dc3c 100644 (file)
@@ -1027,7 +1027,7 @@ CONFIG_JOLIET=y
 # CONFIG_JFS_FS is not set
 # CONFIG_JFS_DEBUG is not set
 # CONFIG_JFS_STATISTICS is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
 # CONFIG_VXFS_FS is not set
 # CONFIG_NTFS_FS is not set
 # CONFIG_NTFS_RW is not set
index 87cc55d..39c5bff 100644 (file)
@@ -1764,7 +1764,7 @@ CONFIG_XFS_FS=m
 # CONFIG_XFS_SECURITY is not set
 # CONFIG_XFS_POSIX_ACL is not set
 # CONFIG_XFS_RT is not set
-# CONFIG_MINIX_FS is not set
+CONFIG_MINIX_FS=m
 # CONFIG_ROMFS_FS is not set
 # CONFIG_INOTIFY is not set
 # CONFIG_QUOTA is not set