fill in the kernel version info for every target, move the kernel tarball md5sums...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jun 2007 05:52:00 +0000 (05:52 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jun 2007 05:52:00 +0000 (05:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7748 3c298f89-4303-0410-b956-a3cf2f4a3e73

20 files changed:
include/kernel-version.mk
target/linux/adm5120-2.6/Makefile
target/linux/adm5120eb-2.6/Makefile
target/linux/amcc-2.6/Makefile
target/linux/ar7-2.6/Makefile
target/linux/at91-2.6/Makefile
target/linux/atheros-2.6/Makefile
target/linux/au1000-2.6/Makefile
target/linux/avr32-2.6/Makefile
target/linux/brcm47xx-2.6/Makefile
target/linux/brcm63xx-2.6/Makefile
target/linux/iop32x-2.6/Makefile
target/linux/ixp4xx-2.6/Makefile
target/linux/magicbox-2.6/Makefile
target/linux/pxa-2.6/Makefile
target/linux/rb532-2.6/Makefile
target/linux/rdc-2.6/Makefile
target/linux/sibyte-2.6/Makefile
target/linux/uml-2.6/Makefile
target/linux/x86-2.6/Makefile

index eaac886..9a9f1c8 100644 (file)
@@ -3,13 +3,24 @@
 ifeq ($(LINUX_VERSION),)
   ifeq ($(KERNEL),2.4)
     LINUX_VERSION:=2.4.34
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
   else
     LINUX_VERSION:=2.6.21.5
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
   endif
 endif
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),2.4.34)
+  LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
+endif
+ifeq ($(LINUX_VERSION),2.6.22-rc6)
+  LINUX_KERNEL_MD5SUM:=37adac36f3928f5e05dd2704c083620d
+endif
+ifeq ($(LINUX_VERSION),2.6.21.5)
+  LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
 KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
 
index 1ac2093..3eeef4a 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=adm5120
 BOARDNAME:=ADM5120 (Little Endian)
 FEATURES:=squashfs jffs2 pci usb
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Infineon/ADMtek ADM5120 based boards
        (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
index b645d02..9b5c299 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=adm5120eb
 BOARDNAME:=ADM5120 (Big Endian)
 FEATURES:=squashfs pci usb
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Infineon/ADMTek ADM5120 based boards running in big-endian mode
        (e.g : ZyXEL Prestige 335WT ...)
index 58d739d..4dd366c 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=amcc
 BOARDNAME:=AMCC Taishan
 FEATURES:=jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for the AMCC Taishan evaluation board
 endef
index 4b10d56..e6056b2 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for TI AR7 based routers
 endef
index 982a911..ccd6353 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=at91
 BOARDNAME:=AT91
 FEATURES:=squashfs
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
   Build fimware images for Figment Design Labs VersaLink board.
 endef
index 1700dec..f750084 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=atheros
 BOARDNAME:=Atheros
 FEATURES:=squashfs jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Atheros SoC boards
 endef
index c90d59d..0b04a4f 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
 FEATURES:=jffs2 usb pci
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
        (e.g. 4G-Systems Mesh/Access Cube ...)
index 2dcd76a..465d96c 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
   Build firmware images for ATNGW100 board
 endef
index 34c29cf..5f07cf2 100644 (file)
@@ -11,8 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.22-rc5
-LINUX_KERNEL_MD5SUM:=50dda556ae492f68ff7c273e1f357c55
+LINUX_VERSION:=2.6.22-rc6
 
 define Target/Description
        Build firmware images for Broadcom based routers
index 81a40d9..a8c7a3c 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        (e.g. Inventel Livebox, Siemens SE515)
index 2259496..529a7e0 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=iop32x
 BOARDNAME:=Intel XScale IOP32x
 FEATURES:=squashfs jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
 endef
 
index d896334..79e8c10 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=ixp4xx
 BOARDNAME:=Intel XScale IXP4xx
 FEATURES:=squashfs
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
 endef
 
index 9fe548a..f80460f 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index 76ca28e..3e0e6cd 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=pxa
 BOARDNAME:=PXA
 FEATURES:=jffs2 broken
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Stub for boards based on intel PXA
 endef
index 27569a3..7d48438 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index bf0d0d4..d52974f 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=rdc
 BOARDNAME:=RDC x86
 FEATURES:=squashfs jffs2 pci broken
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
         Build firmware images for RDC3211 based routers
         (e.g. Airlink101 AR525W, Linksys WRT54R)
index 28b3302..35cdb37 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=sibyte
 BOARDNAME:=SiByte MIPS
 FEATURES:=broken
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index 089ef58..65e1b52 100644 (file)
@@ -23,6 +23,8 @@ BOARDNAME:=User Mode Linux
 FEATURES:=broken
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index db629fa..a870bbe 100644 (file)
@@ -11,8 +11,7 @@ BOARD:=x86
 BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
 
-LINUX_VERSION:=2.6.22-rc5
-LINUX_KERNEL_MD5SUM:=50dda556ae492f68ff7c273e1f357c55
+LINUX_VERSION:=2.6.22-rc6
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci