kernel: add a mtdsplit implementation for tp-link firmware headers
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jan 2015 21:52:44 +0000 (21:52 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jan 2015 21:52:44 +0000 (21:52 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43806 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/config-3.10
target/linux/generic/config-3.13
target/linux/generic/config-3.14
target/linux/generic/config-3.18
target/linux/generic/files/drivers/mtd/mtdsplit/Kconfig
target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
target/linux/generic/files/drivers/mtd/mtdsplit/mtdsplit_tplink.c [new file with mode: 0644]

index 5df8901..8b73b5f 100644 (file)
@@ -1972,6 +1972,7 @@ CONFIG_MTD_SPLIT_FIRMWARE_NAME="firmware"
 # CONFIG_MTD_SPLIT_LZMA_FW is not set
 # CONFIG_MTD_SPLIT_SEAMA_FW is not set
 # CONFIG_MTD_SPLIT_SQUASHFS_ROOT is not set
+# CONFIG_MTD_SPLIT_TPLINK_FW is not set
 # CONFIG_MTD_SPLIT_UIMAGE_FW is not set
 # CONFIG_MTD_SST25L is not set
 # CONFIG_MTD_SWAP is not set
index 79261d8..1ab5661 100644 (file)
@@ -2091,6 +2091,7 @@ CONFIG_MTD_SPLIT_FIRMWARE_NAME="firmware"
 # CONFIG_MTD_SPLIT_LZMA_FW is not set
 # CONFIG_MTD_SPLIT_SEAMA_FW is not set
 # CONFIG_MTD_SPLIT_SQUASHFS_ROOT is not set
+# CONFIG_MTD_SPLIT_TPLINK_FW is not set
 # CONFIG_MTD_SPLIT_UIMAGE_FW is not set
 # CONFIG_MTD_SST25L is not set
 # CONFIG_MTD_SWAP is not set
index 9485ea1..c45c065 100644 (file)
@@ -2134,6 +2134,7 @@ CONFIG_MTD_SPLIT_FIRMWARE_NAME="firmware"
 # CONFIG_MTD_SPLIT_LZMA_FW is not set
 # CONFIG_MTD_SPLIT_SEAMA_FW is not set
 CONFIG_MTD_SPLIT_SQUASHFS_ROOT=y
+# CONFIG_MTD_SPLIT_TPLINK_FW is not set
 # CONFIG_MTD_SPLIT_UIMAGE_FW is not set
 # CONFIG_MTD_SST25L is not set
 # CONFIG_MTD_SWAP is not set
index 34782e3..906e0a5 100644 (file)
@@ -2234,6 +2234,7 @@ CONFIG_MTD_SPLIT_FIRMWARE_NAME="firmware"
 # CONFIG_MTD_SPLIT_LZMA_FW is not set
 # CONFIG_MTD_SPLIT_SEAMA_FW is not set
 CONFIG_MTD_SPLIT_SQUASHFS_ROOT=y
+# CONFIG_MTD_SPLIT_TPLINK_FW is not set
 # CONFIG_MTD_SPLIT_UIMAGE_FW is not set
 # CONFIG_MTD_SST25L is not set
 # CONFIG_MTD_SWAP is not set
index 9a32daa..94775ea 100644 (file)
@@ -34,3 +34,8 @@ config MTD_SPLIT_LZMA_FW
        bool "LZMA compressed kernel based firmware partition parser"
        depends on MTD_SPLIT_SUPPORT
        select MTD_SPLIT
+
+config MTD_SPLIT_TPLINK_FW
+       bool "TP-Link firmware parser"
+       depends on MTD_SPLIT_SUPPORT
+       select MTD_SPLIT
index 41bc1de..bcb250b 100644 (file)
@@ -3,3 +3,4 @@ obj-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
 obj-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
 obj-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
 obj-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
+obj-$(CONFIG_MTD_SPLIT_TPLINK_FW) += mtdsplit_tplink.o
diff --git a/target/linux/generic/files/drivers/mtd/mtdsplit/mtdsplit_tplink.c b/target/linux/generic/files/drivers/mtd/mtdsplit/mtdsplit_tplink.c
new file mode 100644 (file)
index 0000000..00c2d39
--- /dev/null
@@ -0,0 +1,169 @@
+/*
+ *  Copyright (C) 2013 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2014 Felix Fietkau <nbd@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ *
+ */
+
+#include <linux/module.h>
+#include <linux/init.h>
+#include <linux/kernel.h>
+#include <linux/slab.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/byteorder/generic.h>
+
+#include "mtdsplit.h"
+
+#define TPLINK_NR_PARTS                2
+#define TPLINK_MIN_ROOTFS_OFFS 0x80000 /* 512KiB */
+
+#define MD5SUM_LEN  16
+
+struct fw_v1 {
+       char            vendor_name[24];
+       char            fw_version[36];
+       uint32_t        hw_id;          /* hardware id */
+       uint32_t        hw_rev;         /* hardware revision */
+       uint32_t        unk1;
+       uint8_t         md5sum1[MD5SUM_LEN];
+       uint32_t        unk2;
+       uint8_t         md5sum2[MD5SUM_LEN];
+       uint32_t        unk3;
+       uint32_t        kernel_la;      /* kernel load address */
+       uint32_t        kernel_ep;      /* kernel entry point */
+       uint32_t        fw_length;      /* total length of the firmware */
+       uint32_t        kernel_ofs;     /* kernel data offset */
+       uint32_t        kernel_len;     /* kernel data length */
+       uint32_t        rootfs_ofs;     /* rootfs data offset */
+       uint32_t        rootfs_len;     /* rootfs data length */
+       uint32_t        boot_ofs;       /* bootloader data offset */
+       uint32_t        boot_len;       /* bootloader data length */
+       uint8_t         pad[360];
+} __attribute__ ((packed));
+
+struct fw_v2 {
+       char            fw_version[48]; /* 0x04: fw version string */
+       uint32_t        hw_id;          /* 0x34: hardware id */
+       uint32_t        hw_rev;         /* 0x38: FIXME: hardware revision? */
+       uint32_t        unk1;           /* 0x3c: 0x00000000 */
+       uint8_t         md5sum1[MD5SUM_LEN]; /* 0x40 */
+       uint32_t        unk2;           /* 0x50: 0x00000000 */
+       uint8_t         md5sum2[MD5SUM_LEN]; /* 0x54 */
+       uint32_t        unk3;           /* 0x64: 0xffffffff */
+
+       uint32_t        kernel_la;      /* 0x68: kernel load address */
+       uint32_t        kernel_ep;      /* 0x6c: kernel entry point */
+       uint32_t        fw_length;      /* 0x70: total length of the image */
+       uint32_t        kernel_ofs;     /* 0x74: kernel data offset */
+       uint32_t        kernel_len;     /* 0x78: kernel data length */
+       uint32_t        rootfs_ofs;     /* 0x7c: rootfs data offset */
+       uint32_t        rootfs_len;     /* 0x80: rootfs data length */
+       uint32_t        boot_ofs;       /* 0x84: FIXME: seems to be unused */
+       uint32_t        boot_len;       /* 0x88: FIXME: seems to be unused */
+       uint16_t        unk4;           /* 0x8c: 0x55aa */
+       uint8_t         sver_hi;        /* 0x8e */
+       uint8_t         sver_lo;        /* 0x8f */
+       uint8_t         unk5;           /* 0x90: magic: 0xa5 */
+       uint8_t         ver_hi;         /* 0x91 */
+       uint8_t         ver_mid;        /* 0x92 */
+       uint8_t         ver_lo;         /* 0x93 */
+       uint8_t         pad[364];
+} __attribute__ ((packed));
+
+struct tplink_fw_header {
+       uint32_t version;
+       union {
+               struct fw_v1 v1;
+               struct fw_v2 v2;
+       };
+};
+
+static int mtdsplit_parse_tplink(struct mtd_info *master,
+                               struct mtd_partition **pparts,
+                               struct mtd_part_parser_data *data)
+{
+       struct tplink_fw_header hdr;
+       size_t hdr_len, retlen, kernel_size;
+       size_t rootfs_offset;
+       struct mtd_partition *parts;
+       int err;
+
+       hdr_len = sizeof(hdr);
+       err = mtd_read(master, 0, hdr_len, &retlen, (void *) &hdr);
+       if (err)
+               return err;
+
+       if (retlen != hdr_len)
+               return -EIO;
+
+       switch (le32_to_cpu(hdr.version)) {
+       case 1:
+               if (be32_to_cpu(hdr.v1.kernel_ofs) != sizeof(hdr))
+                       return -EINVAL;
+
+               kernel_size = sizeof(hdr) + be32_to_cpu(hdr.v1.kernel_len);
+               break;
+       case 2:
+       case 3:
+               if (be32_to_cpu(hdr.v2.kernel_ofs) != sizeof(hdr))
+                       return -EINVAL;
+
+               kernel_size = sizeof(hdr) + be32_to_cpu(hdr.v2.kernel_len);
+               break;
+       default:
+               return -EINVAL;
+       }
+
+       if (kernel_size > master->size)
+               return -EINVAL;
+
+       /* Find the rootfs after the kernel. */
+       err = mtd_check_rootfs_magic(master, kernel_size);
+       if (!err) {
+               rootfs_offset = kernel_size;
+       } else {
+               /*
+                * The size in the header might cover the rootfs as well.
+                * Start the search from an arbitrary offset.
+                */
+               err = mtd_find_rootfs_from(master, TPLINK_MIN_ROOTFS_OFFS,
+                                          master->size, &rootfs_offset);
+               if (err)
+                       return err;
+       }
+
+       parts = kzalloc(TPLINK_NR_PARTS * sizeof(*parts), GFP_KERNEL);
+       if (!parts)
+               return -ENOMEM;
+
+       parts[0].name = KERNEL_PART_NAME;
+       parts[0].offset = 0;
+       parts[0].size = rootfs_offset;
+
+       parts[1].name = ROOTFS_PART_NAME;
+       parts[1].offset = rootfs_offset;
+       parts[1].size = master->size - rootfs_offset;
+
+       *pparts = parts;
+       return TPLINK_NR_PARTS;
+}
+
+static struct mtd_part_parser mtdsplit_tplink_parser = {
+       .owner = THIS_MODULE,
+       .name = "tplink-fw",
+       .parse_fn = mtdsplit_parse_tplink,
+       .type = MTD_PARSER_TYPE_FIRMWARE,
+};
+
+static int __init mtdsplit_tplink_init(void)
+{
+       register_mtd_parser(&mtdsplit_tplink_parser);
+
+       return 0;
+}
+
+subsys_initcall(mtdsplit_tplink_init);