ramips: rt305x: add kernel support for the Asus RT-N13U Wireless-N300 Router
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 29 Nov 2012 17:37:11 +0000 (17:37 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 29 Nov 2012 17:37:11 +0000 (17:37 +0000)
The work has been backported from openwrt-dreambox with
some modifications & code cleanup.

* updated config-3.3
* updated config-3.6
* renamed rt-n13 to rt-n13u
* fixed mach-rt-n13u.c

[juhosg: move user-space support and image generation into separate
patches]

Signed-off-by: Amit Mendapara <mendapara.amit@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34405 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-n13u.c [new file with mode: 0644]
target/linux/ramips/rt305x/config-3.3
target/linux/ramips/rt305x/config-3.6

index 8f99ce1..d71bd1c 100644 (file)
@@ -43,6 +43,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_ESR_9753,           /* Senao / EnGenius ESR-9753*/
        RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
+       RAMIPS_MACH_RT_N13U,            /* ASUS RT-N13U */
        RAMIPS_MACH_FREESTATION5,       /* ARC Freestation5 */
        RAMIPS_MACH_HW550_3G,           /* Aztech HW550-3G */
        RAMIPS_MACH_MOFI3500_3GN,       /* MoFi Network MOFI3500-3GN */
index 945639b..562bea6 100644 (file)
@@ -96,6 +96,11 @@ config RT305X_MACH_FONERA20N
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_RT_N13U
+       bool "ASUS RT-N13U board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_FREESTATION5
        bool "ARC FreeStation5"
 
index c7c27cb..2cf25a1 100644 (file)
@@ -23,6 +23,7 @@ obj-$(CONFIG_RT305X_MACH_DAP_1350)    += mach-dap-1350.o
 obj-$(CONFIG_RT305X_MACH_ESR_9753)     += mach-esr-9753.o
 obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
+obj-$(CONFIG_RT305X_MACH_RT_N13U)      += mach-rt-n13u.o
 obj-$(CONFIG_RT305X_MACH_FREESTATION5)  += mach-freestation5.o
 obj-$(CONFIG_RT305X_MACH_HW550_3G)     += mach-hw550-3g.o
 obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-n13u.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-n13u.c
new file mode 100644 (file)
index 0000000..cae857a
--- /dev/null
@@ -0,0 +1,83 @@
+/*
+ *  ASUS RT-N13U board support
+ *
+ *  Copyright (C) 2012 lintel<lintel.huang@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define RT_N13U_GPIO_BUTTON_RESET      10
+#define RT_N13U_GPIO_BUTTON_WPS                0
+
+#define RT_N13U_GPIO_LED_POWER         7
+#define RT_N13U_GPIO_LED_WIFI          8
+
+
+#define RT_N13U_BUTTONS_POLL_INTERVAL  10
+#define RT_N13U_BUTTONS_DEBOUNCE_INTERVAL  (3 * RT_N13U_BUTTONS_POLL_INTERVAL)
+
+static struct gpio_led rt_n13u_leds_gpio[] __initdata = {
+       {
+               .name           = "rt-n13u:power",
+               .gpio           = RT_N13U_GPIO_LED_POWER,
+               .active_low     = 1,
+       }, {
+               .name           = "rt-n13u:wifi",
+               .gpio           = RT_N13U_GPIO_LED_WIFI,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button rt_n13u_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval      = RT_N13U_BUTTONS_DEBOUNCE_INTERVAL,
+               .gpio           = RT_N13U_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval      = RT_N13U_BUTTONS_DEBOUNCE_INTERVAL,
+               .gpio           = RT_N13U_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       },
+};
+
+static void __init rt_n13u_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_register_flash(0);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(rt_n13u_leds_gpio),
+                                 rt_n13u_leds_gpio);
+
+       ramips_register_gpio_buttons(-1, RT_N13U_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(rt_n13u_gpio_buttons),
+                                    rt_n13u_gpio_buttons);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_RT_N13U, "RT-N13U", "Asus RT-N13U",
+            rt_n13u_init);
index 9c9082d..7b6bafd 100644 (file)
@@ -108,6 +108,7 @@ CONFIG_RT305X_MACH_PSR_680W=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_RT_N10_PLUS=y
+CONFIG_RT305X_MACH_RT_N13U=y
 CONFIG_RT305X_MACH_SL_R7205=y
 CONFIG_RT305X_MACH_UR_336UN=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
index 5758104..86361af 100644 (file)
@@ -113,6 +113,7 @@ CONFIG_RT305X_MACH_PSR_680W=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_RT_N10_PLUS=y
+CONFIG_RT305X_MACH_RT_N13U=y
 CONFIG_RT305X_MACH_SL_R7205=y
 CONFIG_RT305X_MACH_UR_336UN=y
 CONFIG_RT305X_MACH_V22RW_2X2=y