[package] base-files: remove network preconfig, it collides with ar71xx network first...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Apr 2012 09:43:44 +0000 (09:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Apr 2012 09:43:44 +0000 (09:43 +0000)
To supply custom network settings, it is better to embed a complete network config file using the
files/ overlay, the old image lan preconfig options are also very limited in scope and actually collide
with sysupgrade and firstboot hardware detection on at least ar71xx and possibly other targets, therfore
drop this facility.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31258 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile

index 47785a2..c8088a0 100644 (file)
@@ -38,11 +38,6 @@ define Package/base-files
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
-  $(call Config,network.lan.proto,string,static,LAN Protocol)
-  $(call Config,network.lan.ipaddr,ip,192.168.1.1,LAN IP Address)
-  $(call Config,network.lan.netmask,netmask,255.255.255.0,LAN Network Mask)
-  $(call Config,network.lan.gateway,ip,,LAN Gateway)
-  $(call Config,network.lan.dns,ip,,LAN DNS server)
 endef
 
 define Package/base-files/conffiles