ncurses: install a dummy libtinfo.a for packages that try to link it
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 May 2016 10:49:26 +0000 (10:49 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 May 2016 10:49:26 +0000 (10:49 +0000)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49373 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/ncurses/Makefile

index 94da02e..d97d0b5 100644 (file)
@@ -127,6 +127,7 @@ define Build/InstallDev
        for lib in ncurses panel menu form; do \
                ln -s lib$$$${lib}w.so $(1)/usr/lib/lib$$$${lib}.so; \
        done
+       $(TARGET_CROSS)ar rc $(1)/usr/lib/libtinfo.a
        $(INSTALL_DIR) $(2)/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \