sdk: don't try to build in-kernel kmods
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Dec 2014 11:50:42 +0000 (11:50 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Dec 2014 11:50:42 +0000 (11:50 +0000)
We don't ship the kernel sources, so using the base git as a feed will
fail when trying to build kernel modules with separate install steps.
Instead of trying to fixup the install steps, let's just skip building
kernel modules alltogether and just create empty packages.

Out-of-kernel modules are still expected to exist and are packaged, as
for these sources are fetched during the normal build steps.

Reported-by: Jo-Philipp Wich <jow@openwrt.org>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43525 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index 01fb4db..d2754ab 100644 (file)
@@ -167,7 +167,7 @@ $(call KernelPackage/$(1)/config)
   $(call KernelPackage/depends)
 
   ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
-    ifneq ($(strip $(FILES)),)
+    ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
       define Package/kmod-$(1)/install
                  @for mod in $$(FILES); do \
                        if [ -e $$$$$$$$mod ]; then \