Fix download URL of the 4.x kernel.
authormb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Mar 2015 20:44:33 +0000 (20:44 +0000)
committermb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Mar 2015 20:44:33 +0000 (20:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44589 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index e21d53a..9c3a04b 100644 (file)
@@ -52,7 +52,7 @@ else
   LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
   LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
-      LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
+      LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x$(TESTING)
   endif
 
   ifneq ($(TARGET_BUILD),1)
   endif
 
   ifneq ($(TARGET_BUILD),1)